Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 376125 - net-misc/keychain-2.7.1 does not store gpg keys
Summary: net-misc/keychain-2.7.1 does not store gpg keys
Status: RESOLVED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-23 17:04 UTC by Miguel de Val-Borro
Modified: 2013-10-18 17:29 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Miguel de Val-Borro 2011-07-23 17:04:37 UTC
I have included the line below in my .bash_profile
eval `keychain --eval id_dsa 0123ABCD`
Keychain starts ssh-agent and gpg-agent at login and asks for the corresponding passphrases. After that I can ssh to remote machines from a new shell without asking for the passphrase. However gpg-agent does not seem to cache the private key because the PIN entry pops up the first time I do a decryption.

Reproducible: Always
Comment 1 Laurent Bachelier 2012-02-19 21:42:04 UTC
gpg-agent, by default, forgets you used the key after 10 minutes.

Some solutions for you:
* Don't put your gpg key to the keychain line in .bash_profile, and enter its password only when prompted. keychain is still an useful way to start gpg-agent (this is what I do).
* Change the TTL in ~/.gnupg/gpg-agent.conf (man gpg-agent) so gpg-agent won't forget the key.

Either way, it isn't a bug of keychain,
Comment 2 Daniel Robbins 2012-02-20 01:10:38 UTC
This information should be added to the man page if it is not there already.
Comment 3 Tony Vroon gentoo-dev 2013-10-18 17:29:55 UTC
Information in the bug suggests that you are not using keychain as designed, the author of the tool (Daniel Robbins) has already replied.

(I am closing out old base-systems bugs so I can see the forest for the trees)