Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 375825 - app-admin/ulogd-2.0.0_beta4 fails to build with +doc USE flag if latex is not installed
Summary: app-admin/ulogd-2.0.0_beta4 fails to build with +doc USE flag if latex is not...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Coacher
URL:
Whiteboard:
Keywords:
Depends on: 426868
Blocks:
  Show dependency tree
 
Reported: 2011-07-20 22:51 UTC by Paul Hartman
Modified: 2013-03-20 08:40 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
ulogd-2.0.0_beta4.ebuild.diff (ulogd-2.0.0_beta4.ebuild.diff,1.05 KB, patch)
2012-07-21 01:26 UTC, Stefan Kuhn
Details | Diff
ulogd-2.0.0_beta4.ebuild.diff (ulogd-2.0.0_beta4.ebuild.diff,1013 bytes, patch)
2012-07-21 01:31 UTC, Stefan Kuhn
Details | Diff
ulogd-2.0.0_beta4.ebuild.diff (ulogd-2.0.0_beta4.ebuild.diff,994 bytes, text/plain)
2012-07-21 01:35 UTC, Stefan Kuhn
Details
ulogd-2.0.0_beta4.ebuild.diff (ulogd-2.0.0_beta4.ebuild.diff,994 bytes, patch)
2012-07-21 01:36 UTC, Stefan Kuhn
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Hartman 2011-07-20 22:51:29 UTC
app-admin/ulogd-2.0.0_beta4 fails to emerge when the doc USE flag is set but latex is not installed on the machine:

make -C doc
make: Entering directory `/var/tmp/portage/app-admin/ulogd-2.0.0_beta4/work/ulogd-2.0.0beta4/doc'
sgml2txt ulogd.sgml
Processing file ulogd.sgml
sgml2latex --papersize=a4 --output=dvi ulogd.sgml
Processing file ulogd.sgml
sh: latex: command not found
sh: latex: command not found
sh: latex: command not found
dvips -t a4 -o ulogd.ps ulogd.dvi
This is dvips(k) 5.99 Copyright 2010 Radical Eye Software (www.radicaleye.com)
dvips: DVI file can't be opened: ulogd.dvi: No such file or directory
make: *** [all] Error 1
make: Leaving directory `/var/tmp/portage/app-admin/ulogd-2.0.0_beta4/work/ulogd-2.0.0beta4/doc'
emake failed

Then I emerged virtual/latex-base and tried again. It worked. So I think the ebuild should ensure latex is installed when +doc is set.


Reproducible: Always

Steps to Reproduce:
1. Don't have latex installed
2. USE="doc" emerge =app-admin/ulogd-2.0.0_beta4
3.
Actual Results:  
Emerge fails because latex is not present

Expected Results:  
Emerge succeeds

Portage 2.2.0_alpha46 (default/linux/amd64/10.0, gcc-4.5.2, glibc-2.13-r4, 2.6.34-xen-r4-vr.org x86_64)
=================================================================
System uname: Linux-2.6.34-xen-r4-vr.org-x86_64-Intel-R-_Xeon-R-_CPU_E5506_@_2.13GHz-with-gentoo-2.0.3
Timestamp of tree: Wed, 20 Jul 2011 19:15:01 +0000
app-shells/bash:          4.2_p10
dev-lang/python:          2.7.2, 3.2
dev-util/cmake:           2.8.5
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.8.3-r1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.68
sys-devel/automake:       1.11.1-r1
sys-devel/binutils:       2.21.1
sys-devel/gcc:            4.5.2
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 2.6.38 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo mysql
Installed sets:
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs buildsyspkg distlocks ebuild-locks fixlafiles fixpackages news nostrip parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://chi-10g-1-mirror.fastsoft.net/pub/linux/gentoo/gentoo-distfiles/ ftp://distro.ibiblio.org/pub/linux/distributions/gentoo/ http://mirror.csclub.uwaterloo.ca/gentoo-distfiles/ rsync://distro.ibiblio.org/pub/linux/distributions/gentoo/ ftp://mirror.csclub.uwaterloo.ca/gentoo-distfiles/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,--as-needed"
LINGUAS="en en_US"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/mysql"
SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"
USE="acl amd64 berkdb bzip2 cli cracklib crypt cups cxx dri fortran gdbm gpm iconv imap ipv6 libwww maildir mmx modules mudflap multilib ncurses nls nptl nptlonly openmp pam pcre perl pppd python readline sasl session slang sse sse2 ssl sysfs tcpd unicode xml xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="braindump flow karbon kexi kpresenter krita tables words" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, MAKEOPTS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Agostino Sarubbo gentoo-dev 2011-07-21 11:11:05 UTC
ok, missing depend.

In next case please add your log as attachment. TIA.
Comment 2 Marcin Mirosław 2012-01-29 18:57:29 UTC
Ping.
Comment 3 Stefan Kuhn 2012-07-21 01:26:28 UTC
Created attachment 318784 [details, diff]
ulogd-2.0.0_beta4.ebuild.diff

FIX:
Added "doc? ( virtual/latex-base )" to DEPEND
This fixes the issue.

OTHER CHANGES:
Also sorted DEPEND/RDEPEND alphabetically.

Also added net-libs/libmnl to RDEPEND, see http://www.netfilter.org/projects/ulogd/ 
Had to remove ~ia64 because of libmnl, so decide yourself it libmnl is worth that.
Comment 4 Stefan Kuhn 2012-07-21 01:31:08 UTC
Created attachment 318788 [details, diff]
ulogd-2.0.0_beta4.ebuild.diff

cosmetic fix
Comment 5 Stefan Kuhn 2012-07-21 01:35:45 UTC
Created attachment 318790 [details]
ulogd-2.0.0_beta4.ebuild.diff

cosmetic fix (sorry, it's late)
Comment 6 Stefan Kuhn 2012-07-21 01:36:27 UTC
Created attachment 318792 [details, diff]
ulogd-2.0.0_beta4.ebuild.diff

forgot patch checkbox
Comment 7 Pacho Ramos gentoo-dev 2012-09-16 09:14:45 UTC
This package needs a proxy maintainer for this and libnetfilter_acct:
http://www.gentoo.org/proj/en/qa/proxy-maintainers/
Comment 8 Coacher 2013-03-05 02:05:54 UTC
Appropriate dep changes added in ebuilds for ulogd-2.* you can find here:
https://bugs.gentoo.org/show_bug.cgi?id=426868
Comment 9 Sergey Popov gentoo-dev Security 2013-03-20 08:40:20 UTC
Fixed in 2.0.2