Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 375257 - python and >=linux-3 don't play well
Summary: python and >=linux-3 don't play well
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Python Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 374579 375253 375255 linux-3.0 387047
  Show dependency tree
 
Reported: 2011-07-15 07:40 UTC by Dirkjan Ochtman
Modified: 2012-10-05 08:30 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dirkjan Ochtman gentoo-dev 2011-07-15 07:40:05 UTC
This is a tracker bug for Python on Linux 3 issues.

Upstream so far:

http://bugs.python.org/issue12326
http://bugs.python.org/issue12571

Reproducible: Always
Comment 1 Alexandre Rostovtsev (RETIRED) gentoo-dev 2011-07-25 14:16:50 UTC
Note: for 99% of python packages out there, linux-3 issues can be fixed by

s/sys.platform == 'linux2'/sys.platform.startswith('linux')/
Comment 2 Martin von Gagern 2011-08-21 07:11:20 UTC
Will you apply http://hg.python.org/cpython/rev/c816479f6aaf/ (perhaps minus the NEWS changes, as they won't apply as easily) to all python versions supported by Gentoo? That minimizes breakage of existing code and still allows people to update their kernel to linux 3.
Comment 3 Nikolaj Šujskij 2011-09-13 06:40:27 UTC
(In reply to comment #2)
> Will you apply http://hg.python.org/cpython/rev/c816479f6aaf/ (perhaps minus
> the NEWS changes, as they won't apply as easily) to all python versions
> supported by Gentoo? That minimizes breakage of existing code and still allows
> people to update their kernel to linux 3.

I think it is the best solution there is: take an upstream fix (though it's arguably not that good). More and more bugs would appear (for example, Mercurial build is broken with sys.platform=='linux3'), and the sooner we roll back to 'linux2' as upstream had done, the less bugs would bother users.
Comment 4 Dirkjan Ochtman gentoo-dev 2011-09-16 13:34:59 UTC
I've started by adding 2.7.2-r3 and 3.1.4-r3 with the patch from upstream. Will see about older versions on the gentoo-python mailing list.
Comment 5 Nikoli 2011-10-19 17:03:48 UTC
gentoo-sources-3.0.6 are now marked amd64 stable, do you plan to stabilize python-2.7.2-r3 and 3.1.4-r3?
Comment 6 Dirkjan Ochtman gentoo-dev 2012-10-05 08:30:29 UTC
Since there have been no complaints about python:2.5 and python:2.6, closing.