Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 374043 - media-plugins/gst-plugins-ffmpeg-0.10.11-r1 does not compile on x86 with mstackrealign CFLAG and gcc-4.4
Summary: media-plugins/gst-plugins-ffmpeg-0.10.11-r1 does not compile on x86 with msta...
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: Normal normal (vote)
Assignee: GStreamer package maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-04 15:44 UTC by Till Korten
Modified: 2013-03-14 22:26 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (emerge--info.txt,4.88 KB, text/plain)
2011-07-04 15:44 UTC, Till Korten
Details
build log (media-plugins:gst-plugins-ffmpeg-0.10.11-r1:20110704-153121.log,55.31 KB, text/plain)
2011-07-04 15:45 UTC, Till Korten
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Till Korten 2011-07-04 15:44:00 UTC
trying to emerge gst-plugins-ffmpeg-0.10.11-r1 on x86 with the following CFLAGS on an Atom 330:
CFLAGS="-O2 -march=native -msse3 -mfpmath=sse -mstackrealign -pipe"

with these cflags it works nicely:
CFLAGS="-O2 -march=native -msse3 -mfpmath=sse -pipe"

however if I permanently disable mstackrealign system-wide, I get the infamous mozilla segfaults due to misaligned stacks (see bug #270120 and http://gcc.gnu.org/bugzilla/show_bug.cgi?id=40838 ).

In these bugs it is also suggested that this error only occurs with the sse CFLAGS enabled, however I think for performance reasons it is better to disable mstackrealign than sse.

Therefore, I suggest to disable the mstackrealign flag in the gst-plugins-ffmpeg ebuild.

I attached the compile error and emerge --info

Reproducible: Always

Steps to Reproduce:
1.enable sse and mstackrealign CFLAGs
2.try to emerge gst-plugins-ffmpeg

Actual Results:  
emerge fails with compile error if mstackrealign and sse is enabled in CFLAGS

Expected Results:  
ffmpeg ebuild should disable the mstackrealign CFLAG and then compile fine
Comment 1 Till Korten 2011-07-04 15:44:30 UTC
Created attachment 279051 [details]
emerge --info
Comment 2 Till Korten 2011-07-04 15:45:38 UTC
Created attachment 279053 [details]
build log
Comment 3 Gilles Dartiguelongue gentoo-dev 2013-03-14 22:26:00 UTC
gcc-4.4 was known to have several bugs with -mfpmath=sse and sse3.

Per our documentation http://www.gentoo.org/doc/en/gcc-optimization.xml, I 
don't think setting mstackrealign globally will do any good to your system.
It'd be best if mozilla ebuild added this to its CFLAGS if it needs it.

In any case, please test this with gcc-4.6 which is currently the stable gcc 
and gcc-4.7 if 4.6 still fails.

I certainly cannot reproduce this problem here.