Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 373895 - sys-apps/portage-2.1.10.3 fails to emerge
Summary: sys-apps/portage-2.1.10.3 fails to emerge
Status: RESOLVED DUPLICATE of bug 346899
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-03 11:03 UTC by DrSlony
Modified: 2011-07-03 12:08 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,5.38 KB, text/plain)
2011-07-03 11:05 UTC, DrSlony
Details

Note You need to log in before you can comment on or make changes to this bug.
Description DrSlony 2011-07-03 11:03:55 UTC
I have portage-2.1.9.42 on an x86_64 system.
emerge -NuDav world wants to update portage to 2.1.10.3
It fails with "permission denied" errors.
Naturally I've done "su -" first.

My sys-apps/coreutils is version 8.7 if that matters, no update required.
Comment 1 DrSlony 2011-07-03 11:05:07 UTC
Created attachment 278911 [details]
build.log
Comment 2 DrSlony 2011-07-03 11:05:48 UTC
ps. how do I submit a log file here so that it doesn't have those color tags?
Comment 3 DrSlony 2011-07-03 11:08:48 UTC
This problem is reproducible and I do not suspect any hardware problems. Other programs compile fine.
Comment 4 alex 2011-07-03 11:34:55 UTC
Can you please provide the output of 
emerge --info
Compiled fine here today.
Comment 5 Zac Medico gentoo-dev 2011-07-03 11:45:27 UTC

*** This bug has been marked as a duplicate of bug 346899 ***
Comment 6 Zac Medico gentoo-dev 2011-07-03 11:59:29 UTC
(In reply to comment #2)
> ps. how do I submit a log file here so that it doesn't have those color tags?

Use the emerge --color=n option, or you can try using sed:

http://www.commandlinefu.com/commands/view/3584/remove-color-codes-special-characters-with-sed
Comment 7 DrSlony 2011-07-03 12:08:52 UTC
Ah, thank you!