Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 37372 - The Helix DNA Client is a universal playback engine, supporting decode and playback of any data type, on any device.
Summary: The Helix DNA Client is a universal playback engine, supporting decode and pl...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: media-video herd
URL: http://forms.helixcommunity.org/helix...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-01-05 22:59 UTC by Robert Cole
Modified: 2004-04-26 12:29 UTC (History)
10 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
First attempt: helixplayer-0.3.0.71.ebuild (helixplayer-0.3.0.71.ebuild,1.10 KB, text/plain)
2004-04-23 16:18 UTC, Joel Martin (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Cole 2004-01-05 22:59:34 UTC
This is been out for a while and appears very usable. No it's not GPL but then again neither are the nvidia drivers.

This would be a great addition to the tree. I've seen comments/requests for this in the forums dating back almost a year.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 Seemant Kulleen (RETIRED) gentoo-dev 2004-01-06 07:42:06 UTC
wanna make an ebuild then?
Comment 2 Robert Cole 2004-01-06 07:47:34 UTC
Sure. I'll get to work on it. 
Comment 3 Donnie Berkholz (RETIRED) gentoo-dev 2004-01-24 11:00:55 UTC
So, it just won the best open-source project award at LWE and milestone 2 is out as of Jan. 15, which supposedly is the equivalent of realplayer 8.
Comment 4 Donovan Long 2004-02-13 15:56:08 UTC
"January 6, 2004 - RealPlayer 10, directly powered by the Helix DNA Client, has been released! Support for RealAudio 10 and RealVideo10, debuting in RealPlayer 10, are available to Helix Community members through the Distribution Project (for Win32, Linux (x86), and Mac OS X (mach-o))"

Again, I second/third/fourth/fifth a request for an ebuild, other requests here:
http://forums.gentoo.org/viewtopic.php?t=122325&highlight=ebuild 

Here's someone's test binary Helix build here: 
http://forums.gentoo.org/viewtopic.php?t=100116&highlight=ebuild

Thanks :)
Comment 5 Nicolas ANTONIAZZI 2004-03-09 00:00:19 UTC
This program isn't released under a GPL License, but with RPSL which has been approved by OSI. It would be good to have it in portage since reaplayer and realone is no longer supported on linux.
Comment 6 Nathan Adams 2004-03-22 08:07:37 UTC
Downloading/License Agreement:
The helix download page requires you to click through the license agreement in order to download the source code:
http://forms.helixcommunity.org/helixdnaclient/

So will this work like the Sun Java ebuilds? i.e. the user must go download the files manually before the ebuild will work?

Target:
The "DR5 all_clients" target looks like the best bet for an ebuild, correct?
Comment 7 Lars 2004-04-01 08:42:40 UTC
Well, the newest nightlies seem to be nothing else than
buggy on my gentoo. Won't even play radio streams.
MS2.1 works okay but lags for most users necessary features
and therefore it would be nice to wait for the M3 release
which should be released april 04 hence soon.
Comment 8 Joel Martin (RETIRED) gentoo-dev 2004-04-23 16:18:17 UTC
Created attachment 29931 [details]
First attempt: helixplayer-0.3.0.71.ebuild

Well, the ebuild works for me. Unfortunately, the codec support stinks. Maybe
there is some place to download codec for this sucker. Anyways, it seems pretty

stable though.

If you want a good test page, try this:
http://r4bid.net/page-gen.html
Comment 9 Joel Martin (RETIRED) gentoo-dev 2004-04-23 16:22:43 UTC
If at least one other person will verify that this works for them, then I'll push
this into the tree.
Comment 10 Joel Martin (RETIRED) gentoo-dev 2004-04-26 12:29:54 UTC
Well, by far the easiest way for me to do this was using their latest binary
tarball. So I have submitted to the tree media-video/helixplayer-bin-0.3.0.71.