Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 37301 - "sudo emerge -p rsync" causes an error saying pretend is not available with sync option
Summary: "sudo emerge -p rsync" causes an error saying pretend is not available with s...
Status: RESOLVED DUPLICATE of bug 2365
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-01-05 07:48 UTC by Alex Earl
Modified: 2005-07-17 13:06 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Earl 2004-01-05 07:48:21 UTC
When I try to do a pretend emerge rsync using the command "sudo emerge -p rsync" I get the error:

emerge: the "sync" action does not support "--pretend."

Reproducible: Always
Steps to Reproduce:
1. Open a console
2. Type the command "sudo emerge -p rsync"

Actual Results:  
I get the error stated above.

Expected Results:  
Done a pretend emerge of the rsync package.

Gentoo Base System version 1.4.3.8p1
Portage 2.0.49-r18 (default-x86-1.4, gcc-3.2.3, glibc-2.3.2-r1, 2.4.20-gentoo-r9)
=================================================================
System uname: 2.4.20-gentoo-r9 i686 Mobile Intel(R) Pentium(R) 4 - M CPU 1.80GHz
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-O3 -march=pentium4 -funroll-loops -fprefetch-loop-arrays -pipe"
CHOST="i686-pc-linux-gnu"
COMPILER="gcc3"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3.1/share/config /usr/kde/3/share/config /usr/share/config
/var/qmail/alias /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
CXXFLAGS="-O3 -march=pentium4 -funroll-loops -fprefetch-loop-arrays -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs ccache sandbox"
GENTOO_MIRRORS="http://gentoo.oregonstate.edu
http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X alsa apm arts avi berkdb crypt cups encode esd foomaticdb gdbm gif gnome
gpm gtk gtk2 imap imlib java jpeg kde ldap libg++ libwww mad maildir mikmod
motif mozilla mpeg ncurses nls oggvorbis opengl oss pam pdflib perl png postgres
python qt quicktime readline ruby sdl slang spell ssl svga tcpd truetype x86
xml2 xmms xv zlib"
Comment 1 Daniel Ahlberg (RETIRED) gentoo-dev 2004-01-05 08:22:44 UTC
You have to specify the ebuild when emerging rsync like this:

emerge /usr/portage/net-misc/rsync/rsync-2.6.0.ebuild

emerge rsync is an alias for emerge sync which syncs your portage tree.
Comment 2 Alex Earl 2004-01-05 08:32:47 UTC
This might be something to put into the error message. Something along the lines of "If you were trying to emerge the rsync package, you must specify the ebuild." Thanks for the information though.
Comment 3 SpanKY gentoo-dev 2004-01-05 10:08:26 UTC
wrangler
Comment 4 SpanKY gentoo-dev 2004-01-05 10:08:43 UTC

*** This bug has been marked as a duplicate of 2365 ***