Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 372789 - make repoman warn unknown dependency in || ( ... )
Summary: make repoman warn unknown dependency in || ( ... )
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Repoman (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords: InVCS
: 334837 (view as bug list)
Depends on:
Blocks: 373933 521980
  Show dependency tree
 
Reported: 2011-06-24 09:17 UTC by Peter Volkov (RETIRED)
Modified: 2014-09-14 16:28 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Volkov (RETIRED) gentoo-dev 2011-06-24 09:17:43 UTC
Currently repoman produces no warning in case not existing package or some garbage is mentioned inside || ( ... ) dependency.  I'd like to have option (or make repoman full warn by default) for case when package is mention inside DEPEND="|| ( pkg )" but is missed. This will allow to catch removed packages but still mentioned in virtual/pkgs.
Comment 1 Zac Medico gentoo-dev 2011-06-24 10:24:42 UTC
I've added a "dependency.unknown" warning for this:

http://git.overlays.gentoo.org/gitweb/?p=proj/portage.git;a=commit;h=f57036e346400a0a760668b9bc0e6c84b5d61304
Comment 2 Peter Volkov (RETIRED) gentoo-dev 2011-06-24 10:36:08 UTC
Thank you, Zac!
Comment 3 Zac Medico gentoo-dev 2011-07-01 05:08:40 UTC
This is in 2.2.0_alpha42, but I'll leave this bug open until it's in an unmasked release.
Comment 4 Zac Medico gentoo-dev 2011-07-03 17:34:21 UTC
This is fixed in 2.1.10.4.
Comment 5 Zac Medico gentoo-dev 2011-08-17 00:21:12 UTC
*** Bug 334837 has been marked as a duplicate of this bug. ***