Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 372001 - dev-libs/nss-3.12.9-r1 does not build when running linux-3.0.0-rc3
Summary: dev-libs/nss-3.12.9-r1 does not build when running linux-3.0.0-rc3
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal with 2 votes (vote)
Assignee: Mozilla Gentoo Team
URL:
Whiteboard:
Keywords:
: 375221 376835 377071 388583 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-06-17 09:29 UTC by darkbasic
Modified: 2011-10-26 17:55 UTC (History)
15 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
patch for nss-3.12.10.ebuild to compile with linux-3.x (nss-3.12.10.ebuild.patch,570 bytes, patch)
2011-07-12 16:02 UTC, ron widler
Details | Diff
Patch for using nss with 3.1 kernels (nss-3.12.10_on_3.1_kernel.patch,383 bytes, text/plain)
2011-08-26 19:18 UTC, Pelle
Details

Note You need to log in before you can comment on or make changes to this bug.
Description darkbasic 2011-06-17 09:29:31 UTC
>>> Compiling source in /var/tmp/portage/dev-libs/nss-3.12.9-r1/work/nss-3.12.9
make -j3 -j1 CC=x86_64-pc-linux-gnu-gcc
../coreconf/config.mk:71: ../coreconf/Linux3.0.mk: No such file or directory
make: *** No rule to make target ../coreconf/Linux3.0.mk.  Stop.
make: *** [../coreconf/Linux3.0.mk] Errore 1
emake failed


~ # emerge --info
Portage 2.2.0_alpha41 (default/linux/amd64/10.0/desktop/kde, gcc-4.4.5, glibc-2.12.2-r0, 3.0.0-rc3 x86_64)
=================================================================
System uname: Linux-3.0.0-rc3-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_3800+-with-gentoo-2.0.2
Timestamp of tree: Thu, 16 Jun 2011 16:30:01 +0000
app-shells/bash:          4.1_p9
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.1-r1, 3.1.3-r1
dev-util/cmake:           2.8.4-r1
sys-apps/baselayout:      2.0.2
sys-apps/openrc:          0.8.2-r1
sys-apps/sandbox:         2.4
sys-devel/autoconf:       2.13, 2.65-r1
sys-devel/automake:       1.9.6-r3, 1.11.1
sys-devel/binutils:       2.20.1-r1
sys-devel/gcc:            4.4.5
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.2.10
sys-devel/make:           3.82
sys-kernel/linux-headers: 2.6.36.1 (virtual/os-headers)
sys-libs/glibc:           2.12.2
Repositories: gentoo x11 kde proaudio darkbasic
Installed sets: @kdeadmin-4.6, @kdeartwork-4.6, @kdebase-4.6, @kdeutils-4.6
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA AdobeFlash-10.1"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -O2 -msse3 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=athlon64 -O2 -msse3 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://de-mirror.org/distro/gentoo"
LANG="it_IT.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="it en"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/x11 /var/lib/layman/kde /var/lib/layman/pro-audio /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdr cli consolekit cracklib crypt cups cxx dbus declarative dri dssi dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gdu gif gpm graphite gtk iconv ipv6 jack jpeg kde kipi lcms ldap libnotify lv2 mad mmx mmxext mng modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl nptlonly ogg opengl openmp pam pango pcre pdf perl phonon plasma png policykit ppds pppd pulseaudio python qt3support qt4 readline sdl semantic-desktop session spell sse sse2 sse3 ssl startup-notification svg sysfs tcpd tiff truetype udev unicode usb vorbis x264 xcb xcomposite xinerama xml xorg xscreensaver xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="braindump flow karbon kexi kpresenter krita tables words" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="it en" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Jeroen Roovers gentoo-dev 2011-06-17 15:21:25 UTC
$ ebuild nss-3.12.9-r1.ebuild clean compile
Appending /newaches/gentoo/cvs/gentoo-x86 to PORTDIR_OVERLAY...
 * nss-3.12.9.with.ckbi.1.82.tar.gz RMD160 SHA1 SHA256 size ;-) ...                                                          [ ok ]
 * checking ebuild checksums ;-) ...                                                                                         [ ok ]
 * checking auxfile checksums ;-) ...                                                                                        [ ok ]
 * checking miscfile checksums ;-) ...                                                                                       [ ok ]
 * checking nss-3.12.9.with.ckbi.1.82.tar.gz ;-) ...                                                                         [ ok ]
 * Package:    dev-libs/nss-3.12.9-r1
 * Repository: gentoo
 * Maintainer: mozilla
 * USE:        amd64 elibc_glibc kernel_linux userland_GNU
 * FEATURES:   sandbox userpriv
>>> Unpacking source...
>>> Unpacking nss-3.12.9.with.ckbi.1.82.tar.gz to /var/tmp/portage/dev-libs/nss-3.12.9-r1/work
>>> Source unpacked in /var/tmp/portage/dev-libs/nss-3.12.9-r1/work
>>> Preparing source in /var/tmp/portage/dev-libs/nss-3.12.9-r1/work/nss-3.12.9 ...
 * Applying nss-3.12.5-gentoo-fixups.diff ...                                                                                [ ok ]
 * Applying nss-3.12.6-gentoo-fixup-warnings.patch ...                                                                       [ ok ]
 * Applying nss-3.12.4-solaris-gcc.patch ...                                                                                 [ ok ]
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/dev-libs/nss-3.12.9-r1/work/nss-3.12.9 ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/dev-libs/nss-3.12.9-r1/work/nss-3.12.9 ...
make -j10 -j1 CC=x86_64-pc-linux-gnu-gcc 
../coreconf/config.mk:71: ../coreconf/Linux3.0.mk: No such file or directory
make: *** No rule to make target ../coreconf/Linux3.0.mk.  Stop.
make: *** [../coreconf/Linux3.0.mk] Error 1
emake failed
 * ERROR: dev-libs/nss-3.12.9-r1 failed (compile phase):
 *   coreconf make failed
 * 
 * Call stack:
 *     ebuild.sh, line  56:  Called src_compile
 *   environment, line 2541:  Called die
 * The specific snippet of code:
 *       emake -j1 CC="$(tc-getCC)" || die "coreconf make failed";
 * 
 * If you need support, post the output of 'emerge --info =dev-libs/nss-3.12.9-r1',
 * the complete build log and the output of 'emerge -pqv =dev-libs/nss-3.12.9-r1'.
 * The complete build log is located at '/keeps/gentoo/emergelogs/wieneke/dev-libs:nss-3.12.9-r1:20110617-152013.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-libs/nss-3.12.9-r1/temp/environment'.
 * S: '/var/tmp/portage/dev-libs/nss-3.12.9-r1/work/nss-3.12.9'
jer@wieneke /newaches/gentoo/cvs/gentoo-x86/dev-libs/nss $ cat /proc/version 
Linux version 3.0.0-rc3-JeR (root@wieneke) (gcc version 4.4.5 (Gentoo 4.4.5 p1.2, pie-0.4.5) ) #1 SMP PREEMPT Fri Jun 17 17:10:04 CEST 2011
Comment 2 pat 2011-06-28 18:01:21 UTC
Building system expects to find Linux3.0.mk, which is not included yet. Simple, dirty quick-fix:

1. ebuild nss-3.12.9-r1.ebuild clean configure
2. Edit /var/tmp/portage/dev-libs/nss-3.12.9-r1/work/nss-3.12.9-r1/mozilla/security/coreconf/config.mk, change $(OS_RELEASE) in line 71 to 2.6
3. ebuild nss-3.12.9-r1.ebuild merge
Comment 3 ron widler 2011-07-12 16:02:20 UTC
Created attachment 279891 [details, diff]
patch for nss-3.12.10.ebuild to compile with linux-3.x

copies Linux2.6.mk to Linux3.0.mk in case Linux3.0.mk doesn't exist yet.
everything compiles nicely.
should work with 3.12.9-r1 just as well.
Comment 4 ron widler 2011-07-12 16:12:59 UTC
reported upstream (i hope dev-tech-crypto@lists.mozilla.org is the right place ^^)
Comment 5 Matt Turner gentoo-dev 2011-07-15 04:28:21 UTC
*** Bug 375221 has been marked as a duplicate of this bug. ***
Comment 6 Matt Turner gentoo-dev 2011-07-15 04:30:06 UTC
Patch from Alphat-PC in bug 375221:

https://bugs.gentoo.org/attachment.cgi?id=280083
Comment 7 ron widler 2011-07-15 05:11:15 UTC
bug is known upstream, Linux*.mk will be removed in the next release. 

> https://bugzilla.mozilla.org/show_bug.cgi?id=661609

> Build from the head of the trunk or the 3.12 branch, or wait for the next
> release to get the fix.

there's a reference to 2.6 in Linux.mk as well, which is not addressed by the patches here yet:
http://mxr.mozilla.org/mozilla-central/source/security/coreconf/Linux.mk#172
Comment 8 Matt Turner gentoo-dev 2011-07-26 12:21:33 UTC
So, seriously, can we institute some kind of work-around until upstream fixes this?
Comment 9 Dmitry Suloev 2011-07-26 12:22:42 UTC
In my case helped patch.
Comment 10 Boney McCracker 2011-07-26 23:57:38 UTC
Patch works for me.
Comment 11 Rafał Mużyło 2011-07-29 13:04:10 UTC
*** Bug 376835 has been marked as a duplicate of this bug. ***
Comment 12 Trixtrax 2011-07-30 04:47:04 UTC
Sorry about the duplicate. This patch also works for me 

Linux sparrow 3.0.0-gentoo #1 SMP PREEMPT Mon Jul 25 14:37:18 PDT 2011 i686 AMD Athlon(tm) 64 X2 Dual Core Processor 4600+ AuthenticAMD GNU/Linux
Comment 13 Rafał Mużyło 2011-07-30 16:17:40 UTC
*** Bug 377071 has been marked as a duplicate of this bug. ***
Comment 14 Billy DeVincentis 2011-07-31 13:18:39 UTC
Works for me
Comment 15 Jory A. Pratt gentoo-dev 2011-07-31 14:30:20 UTC
Thanks for reporting, I have committed a slightly different fix. Sorry for the delay.
Comment 16 Pelle 2011-08-26 19:18:59 UTC
Created attachment 284737 [details]
Patch for using nss with 3.1 kernels
Comment 17 Stefan Richter 2011-10-03 09:34:49 UTC
For the record:
build with kernel 3.1 is fixed in dev-libs/nss-3.12.11
Comment 18 Cedric Sodhi 2011-10-26 17:55:15 UTC
*** Bug 388583 has been marked as a duplicate of this bug. ***