Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 371527 - =media-libs/lcms-2.2: tests fail with bus error
Summary: =media-libs/lcms-2.2: tests fail with bus error
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Printing Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: unaligned-access
  Show dependency tree
 
Reported: 2011-06-13 22:07 UTC by Matt Turner
Modified: 2011-08-12 18:29 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matt Turner gentoo-dev 2011-06-13 22:07:11 UTC
lcms-2.2 causes a bus error (due to an unaligned access) and fails the tests on mips (and other architectures as well)


LittleCMS 2.02 test bed Jun 10 2011 20:09:08

Installing debug memory plug-in ... done.
Installing error logger ... done.
Supported intents:
        0 - Perceptual
        1 - Relative colorimetric
        2 - Saturation
        3 - Absolute colorimetric
        10 - Perceptual preserving black ink
        11 - Relative colorimetric preserving black ink
        12 - Saturation preserving black ink
        13 - Perceptual preserving black plane
        14 - Relative colorimetric preserving black plane
        15 - Saturation preserving black plane

Checking Creation of test profiles .../var/tmp/portage/media-libs/lcms-2.2/temp/environment: line 2173:  3511 Bus error               ./testcms
Comment 1 Sergei Trofimovich gentoo-dev 2011-08-12 18:29:58 UTC
Reproduced on sparc32 and tested there patch from upstream.

[ I don't quite like the patch, so asked that one for upstream inclusion:
https://github.com/trofi/Little-CMS/commit/7dc457110798939de2f42488aa14cb8c90128bb5 ]

>  12 Aug 2011; Sergei Trofimovich <slyfox@gentoo.org> lcms-2.2-r1.ebuild,
>  +files/lcms-2.2-fix-test-on-sparc.patch:
>  Fix FEATURES=test SIGBUS failure on sparc32. bug #371527 by Matt Turner,
>  patch is from upstream.

Thanks, Matt!