Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 371387 - net-nds/yp-tools-2.12-r1 - In file included from ypclnt.c:35:0: /usr/include/bits/libc-lock.h:50:29: error: missing binary operator before token "("
Summary: net-nds/yp-tools-2.12-r1 - In file included from ypclnt.c:35:0: /usr/include/...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal with 2 votes (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords: NeedPatch
: 561000 (view as bug list)
Depends on: 570726 570728 595838
Blocks: glibc-rpc
  Show dependency tree
 
Reported: 2011-06-13 10:59 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2017-07-19 08:29 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (yp-tools-2.12:20110612-215909.log,7.17 KB, text/plain)
2011-06-13 10:59 UTC, Diego Elio Pettenò (RETIRED)
Details
Proposed patch to this ebuild (ebuild.patch,1.21 KB, patch)
2016-03-08 21:28 UTC, Gil Kloepfer
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2011-06-13 10:59:41 UTC
Created attachment 276885 [details]
Build log

Portage 2.1.10 (default/linux/x86/10.0, gcc-4.6.0-asneeded, glibc-2.14-r0, 2.6.39 i686)
=================================================================
System uname: Linux-2.6.39-i686-Quad-Core_AMD_Opteron-tm-_Processor_2350-with-gentoo-2.0.2
Timestamp of tree: Mon, 06 Jun 2011 20:30:01 +0000
app-shells/bash:          4.2_p10
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.1-r1, 3.2
dev-util/cmake:           2.8.4-r1
sys-apps/baselayout:      2.0.2
sys-apps/openrc:          0.8.2-r1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1-r1
sys-devel/binutils:       2.21
sys-devel/gcc:            4.6.0
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82
sys-kernel/linux-headers: 2.6.38 (virtual/os-headers)
sys-libs/glibc:           2.14
Repositories: gentoo
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib/tomoyo/conf /usr/share/bufrtables /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/maven-bin-3.0/conf /usr/share/openvpn/easy-rsa /usr/share/qpsmtpd/plugins /var/lib/hsqldb /var/phxd /var/qmail/alias /var/qmail/control /var/yp/Makefile"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/games/angband/edit/ /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe"
DISTDIR="/var/cache/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms split-log strict test test-fail-continue unknown-features-warn unmerge-orphans userfetch userpriv usersandbox"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.wheel.sk/"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu"
MAKEOPTS="-j14"
PKGDIR="/var/spool/portage/packages"
PORTAGE_COMPRESS=""
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/var/cache/portage/tree"
PORTDIR_OVERLAY=""
SYNC="rsync://yamato.home.flameeyes.eu/gentoo-portage"
USE="acl berkdb bzip2 cli cracklib crypt cups cxx dri fortran gdbm gpm iconv ipv6 java5 java6 modules mudflap mysql ncurses nls nostatic nptl nptlonly openmp pam pcre pcsc-lite perl postgres pppd python qt3support readline ruby semantic-desktop session ssl sysfs tcpd unicode vhosts x86 xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias auth_digest cgi" CALLIGRA_FEATURES="braindump flow karbon kexi kpresenter krita tables words" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18 jruby ruby19 ree18" USERLAND="GNU" VIDEO_CARDS="intel radeon nouveau vmware" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Justin Lecher gentoo-dev 2012-06-21 09:41:40 UTC
Should work with all versions of stable glibc-2.14 in the tree
Comment 2 SpanKY gentoo-dev 2012-06-23 22:24:13 UTC
it's still broken.  it needs to be converted to libtirpc, not use the symbols that come from glibc.
Comment 3 Toralf Förster gentoo-dev 2015-08-06 11:27:15 UTC
tree cleaner ?

x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I.. -I. -I.. -DLOCALEDIR=\"/usr/share/locale\"   -W -Wall -Wbad-function-cast -Wcast-align -Winline -Wmissing-declarations -Wmissing-prototypes -Wnested-externs -Wshadow -Wstrict-prototypes -Wundef -march=native -O2 -pipe -c ypwhich.c
x86_64-pc-linux-gnu-gcc -W -Wall -Wbad-function-cast -Wcast-align -Winline -Wmissing-declarations -Wmissing-prototypes -Wnested-externs -Wshadow -Wstrict-prototypes -Wundef -march=native -O2 -pipe  -Wl,-O1 -Wl,--as-needed -o ypwhich ypwhich.o ../lib/libyptools.a -lnsl 
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I.. -I. -I.. -DLOCALEDIR=\"/usr/share/locale\"   -W -Wall -Wbad-function-cast -Wcast-align -Winline -Wmissing-declarations -Wmissing-prototypes -Wnested-externs -Wshadow -Wstrict-prototypes -Wundef -march=native -O2 -pipe -c ypmatch.c
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I.. -I. -I.. -DLOCALEDIR=\"/usr/share/locale\"   -W -Wall -Wbad-function-cast -Wcast-align -Winline -Wmissing-declarations -Wmissing-prototypes -Wnested-externs -Wshadow -Wstrict-prototypes -Wundef -march=native -O2 -pipe -c ypclnt.c
In file included from ypclnt.c:35:0:
/usr/include/bits/libc-lock.h:50:29: error: missing binary operator before token "("
 #if defined _LIBC && (IS_IN (libc) || IS_IN (libpthread))
                             ^
/usr/include/bits/libc-lock.h:63:29: error: missing binary operator before token "("
 #if defined _LIBC && (IS_IN (libc) || IS_IN (libpthread))
                             ^
/usr/include/bits/libc-lock.h:81:29: error: missing binary operator before token "("
 #if defined _LIBC && (IS_IN (libc) || IS_IN (libpthread))
                             ^
/usr/include/bits/libc-lock.h:89:29: error: missing binary operator before token "("
 #if defined _LIBC && (IS_IN (libc) || IS_IN (libpthread))
                             ^
/usr/include/bits/libc-lock.h:106:29: error: missing binary operator before token "("
 #if defined _LIBC && (IS_IN (libc) || IS_IN (libpthread))
                             ^
/usr/include/bits/libc-lock.h:131:29: error: missing binary operator before token "("
 #if defined _LIBC && (IS_IN (libc) || IS_IN (libpthread))
                             ^
ypclnt.c: In function ‘__ypclnt_call’:
ypclnt.c:284:28: warning: unused parameter ‘domain’ [-Wunused-parameter]
 __ypclnt_call (const char *domain, u_long prog, xdrproc_t xargs,
                            ^
ypclnt.c: At top level:
ypclnt.c:788:1: warning: no previous prototype for ‘yp_maplist’ [-Wmissing-prototypes]
 yp_maplist (const char *indomain, struct ypmaplist **outmaplist)
 ^
Makefile:397: recipe for target 'ypclnt.o' failed
make[2]: *** [ypclnt.o] Error 1
make[2]: Leaving directory '/var/tmp/portage/net-nds/yp-tools-2.12-r1/work/yp-tools-2.12/src'
Makefile:280: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/var/tmp/portage/net-nds/yp-tools-2.12-r1/work/yp-tools-2.12'
Makefile:219: recipe for target 'all' failed
make: *** [all] Error 2
 * ERROR: net-nds/yp-tools-2.12-r1::gentoo failed (compile phase):
 *   emake failed
 * 
 * If you need support, post the output of `emerge --info '=net-nds/yp-tools-2.12-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=net-nds/yp-tools-2.12-r1::gentoo'`.
 * The complete build log is located at '/var/log/portage/net-nds:yp-tools-2.12-r1:20150805-222246.log'.
 * For convenience, a symlink to the build log is located at '/var/tmp/portage/net-nds/yp-tools-2.12-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-nds/yp-tools-2.12-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/net-nds/yp-tools-2.12-r1/work/yp-tools-2.12'
 * S: '/var/tmp/portage/net-nds/yp-tools-2.12-r1/work/yp-tools-2.12'

  -----------------------------------------------------------------

  This is an unstable amd64 chroot image (named amd64-desktop-unstable_20150802-115040/) at a hardened host acting as a tinderbox.

Portage 2.2.20 (python 3.4.3-final-0, default/linux/amd64/13.0/desktop, gcc-4.9.3, glibc-2.21-r1, 4.0.8-hardened x86_64)
=================================================================
Comment 4 Alex Xu (Hello71) 2015-09-27 17:46:29 UTC
*** Bug 561000 has been marked as a duplicate of this bug. ***
Comment 5 Michael O. Distler 2015-11-25 18:27:37 UTC
This is what worked for me:

Comment out line 35 in yp-tools-2.12/src/ypclnt.c
/* #include <bits/libc-lock.h> */

Compile and merge using 'ebuild':
ebuild /usr/portage/net-nds/yp-tools/yp-tools-2.12-r1.ebuild merge
Comment 6 Michael O. Distler 2015-11-25 18:36:22 UTC
# emerge --info
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
Portage 2.2.20.1 (python 3.4.3-final-0, default/linux/amd64/13.0, gcc-4.8.5, glibc-2.21-r1, 4.1.12-gentoo x86_64)
=================================================================
System uname: Linux-4.1.12-gentoo-x86_64-Intel-R-_Core-TM-_i7-4790_CPU_@_3.60GHz-with-gentoo-2.2
KiB Mem:    16419616 total,    547228 free
KiB Swap:  100663284 total,  98842404 free
Timestamp of repository gentoo: Wed, 25 Nov 2015 15:15:02 +0000
sh bash 4.3_p39
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
distcc 3.2rc1 x86_64-pc-linux-gnu [disabled]
ccache version 3.1.9 [disabled]
app-shells/bash:          4.3_p39::gentoo
dev-java/java-config:     2.2.0::gentoo
dev-lang/perl:            5.20.2::gentoo
dev-lang/python:          2.7.10::gentoo, 3.4.3::gentoo
dev-util/ccache:          3.1.9-r4::gentoo
dev-util/cmake:           3.3.1-r1::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.17::gentoo
sys-apps/sandbox:         2.6-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.10.3-r1::gentoo, 1.11.6-r1::gentoo, 1.13.4::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.7.4::gentoo, 4.8.5::gentoo, 4.9.3::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 3.18::gentoo (virtual/os-headers)
sys-libs/glibc:           2.21-r1::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.europe.gentoo.org/gentoo-portage
    priority: -1000

science
    location: /usr/portage/local/layman/science
    masters: gentoo
    priority: 2

a1
    location: /usr/portage/local/layman/a1
    masters: gentoo
    priority: 3

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=corei7 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/stunnel/stunnel.conf /usr/share/config /usr/share/gnupg/qualified.txt /var/bind /var/lib/hsqldb /var/spool/torque /var/yp/Makefile"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.6/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=corei7 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildpkg config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.halifax.rwth-aachen.de/gentoo http://ftp.uni-erlangen.de/pub/mirrors/gentoo http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/data/kpha1/gentoo/corei7"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/lost+found"
PORTAGE_TMPDIR="/var/tmp"
USE="X Xaw3d a52 aac aalib acl ads alsa amd64 android ao apache2 apng autoipd avahi bbdb berkdb bluetooth bluray bzip2 cairo calendar caps cdda cddb cdio cdr cgi chappa clang cli client cmake compat cracklib crypt cups curl cvs cxx data dawn dbus declarative device-mapper dga dhclient djvu dlz dot dri dts dv dvb dvd eds egl emacs encode evdev examples exif extensions extra extras fbcon ffmpeg flac fontconfig foomaticdb fortran fpx fuse gcj gd gdbm gdml geant3 ggi gif gimp git gles2 glib gmp gnome gnome-keyring gnuplot gphoto2 gpm graph graphviz gsl gstreamer gtk gtk3 gudev gui hdri howl-compat iconv icu imagemagick imlib introspection ios iptables ipv6 jack jadetex java javamail javascript jbig jpeg jpeg2k kde kdrive kerberos kmod kpathsea lapack latex lcms ldap libatomic libcaca libsamplerate libxml2 lirc live lock lua lzma lzo mad math matplotlib mbox md5sum mdnsresponder-compat midi minizip mjpeg mmx mmxext mng mod modemmanager modplug modules mongodb mono motif mp3 mpeg multilib musepack mysql nas ncurses netboot network networkmanager new-login nfsidmap nfsv4 nfsv41 nls nptl nsplugin nss ntfs ntfsprogs octave offensive ogg openal opencv openexr opengl openldap openmp openssl oracle orc oss pam pam_ssh pango pcre pcre16 pdf pdo perl playlist plotutils png pnm policykit portaudio postgres postproc ppds printsupport pulseaudio pythia6 python qt3support qt4 qt5 quicktime quvi rar raytracerx readline rpc rplay ruby samba sbcl scanner script scripts sdl seccomp secure-delete server session sid sip sipim skey slang slp sndfile sockets speex spell sql sqlite sse sse2 ssl subversion svg systemd t1lib tcl tcmalloc tcpd theora threads tiff timidity tk tracker truetype udev udisks unicode upnp-av usb uvm v4l vala valgrind vcd vhosts vorbis vrml wav wavpack webkit widgets wifi winbind wmf wxwidgets x264 xanim xattr xcomposite xetex xext xinerama xinetd xkb xml xmlreader xmp xpm xscreensaver xv xvfb xvid xvmc zeitgeist zeroconf zlib zvbi" ABI_X86="32 64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="actions alias asis auth_basic auth_digest authn_anon authn_core authn_dbd authn_dbm authn_default authn_file authz_core authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cern_meta cgi dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info lbmethod_byrequests log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so socache_shmcb slotmem_shm speling status unique_id unixd userdir usertrack vhost_alias" APACHE2_MPMS="worker" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2 sse3 ssse3" CURL_SSL="nss" DRACUT_MODULES="mdraid lvm syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="pc efi-64" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de en en_GB en_US fr it es" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" QEMU_SOFTMMU_TARGETS="arm i386 ppc ppc64 x86_64" QEMU_USER_TARGETS="arm i386 ppc ppc64 x86_64" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="radeon ati nv nouveau nvidia intel mga i810 vesa fbdev v4l modesetting" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 7 Octavian 2015-12-28 22:13:16 UTC
(In reply to Michael O. Distler from comment #5)
> This is what worked for me:
> 
> Comment out line 35 in yp-tools-2.12/src/ypclnt.c
> /* #include <bits/libc-lock.h> */
> 
> Compile and merge using 'ebuild':
> ebuild /usr/portage/net-nds/yp-tools/yp-tools-2.12-r1.ebuild merge

a fast trick is to 
FEATURES="keepwork" emerge yp-tools -v
Comment 8 Gil Kloepfer 2016-03-08 21:28:14 UTC
Created attachment 427780 [details, diff]
Proposed patch to this ebuild

Attached is a patch to this ebuild that implements the fix proposed by Michael O. Distler that worked for him, and it also worked for me as well.  Hopefully this will help move the fix to this ebuild along.

There is some discussion about this problem on the 'net with regard to whether _LIBC being defined or not causing IS_IN (part of /usr/include/bits/libc-lock.h from glibc) to be defined or not (this is what causes the compile to fail).  It seems, though, that yp-tools:src/ypclnt.c does not appear to need to include bits/libc-lock.h.  So rather than wait for whatever is appropriate with libc to get resolved, this is likely the proper fix for the ebuild anyway.
Comment 9 Pacho Ramos gentoo-dev 2016-03-12 09:42:30 UTC
Thanks

Are you willing to proxy maintain this package? 
http://www.linux-nis.org/download/yp-tools/

It seems that we are shipping a really old version because of this being orphaned :(
http://www.linux-nis.org/download/yp-tools/
Comment 10 Gil Kloepfer 2016-05-10 01:16:36 UTC
I've never done any package maintenance in an official capacity for Gentoo, but am willing to try.

It seems RedHat 7 is using yp-tools 2.14 (latest in the 2.x train), and that version ported nicely from the source at www.linux-nis.org to Gentoo, and also fixes the problem reported in this bug.

I did try going to 4.2 (latest) a few weeks ago, but that had some issues (I can't remember the exact ones, since I got pulled away from it due to some urgent issues at work).  I'm not sure if going to 4.x is actually necessary, though.

I would be happy to contribute my ebuild of 2.14 and be the (proxy) maintainer of this package.  I will need to read-over all the responsibilities first to make sure I'm not trying to take-on more than I can handle.  We do use NIS extensively where I work, and my primary system is running Gentoo, so anything I submit will get pretty thoroughly tested.
Comment 11 Pacho Ramos gentoo-dev 2016-05-21 12:41:31 UTC
I will CC proxy maintainers people then , thanks :)
Comment 12 Ian Delaney (RETIRED) gentoo-dev 2016-05-22 08:26:25 UTC
(In reply to Gil Kloepfer from comment #10)
> I've never done any package maintenance in an official capacity for Gentoo,
> but am willing to try.
> 
> I would be happy to contribute my ebuild of 2.14 and be the (proxy)
> maintainer of this package.  I will need to read-over all the
> responsibilities first to make sure I'm not trying to take-on more than I
> can handle.  We do use NIS extensively where I work, and my primary system
> is running Gentoo, so anything I submit will get pretty thoroughly tested.

I suggest you read over https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers
and consider joining the IRC channel cited within that link.
Comment 13 Pacho Ramos gentoo-dev 2016-08-21 12:36:11 UTC
Any news on this? :/
Comment 14 Preston Crow 2017-05-31 19:29:52 UTC
I solved this for myself by bumping the version to 2.14.  Just clone the ebuild into a local repository, rename it to -2.14.ebuild, and change the SRC_URI to http://www.linux-nis.org/download/yp-tools/yp-tools-2.14.tar.bz2.

I haven't tested the result, but it seems like the correct solution is to take the upstream update instead of patching the old version.
Comment 15 Pacho Ramos gentoo-dev 2017-07-19 08:29:34 UTC
[master 3810c4ac9d8] net-nds/yp-tools: Version bump
 2 files changed, 32 insertions(+)
 create mode 100644 net-nds/yp-tools/yp-tools-4.2.2.ebuild