Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 370697 - emerge --autounmask-write: It is not defined where the configuration changes are written.
Summary: emerge --autounmask-write: It is not defined where the configuration changes ...
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core (show other bugs)
Hardware: All Linux
: Normal minor (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords: InVCS
Depends on:
Blocks: autounmask 381649
  Show dependency tree
 
Reported: 2011-06-08 16:18 UTC by Johannes Rauh
Modified: 2011-09-19 13:58 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Johannes Rauh 2011-06-08 16:18:01 UTC
With respect to emerge --autounmask-write the manual states that "changes are written to config files."  It does not specify which files exactly.  Also emerge itself does not give more information, even with the verbose option.


Reproducible: Always




It seems to me that, for example, changes to packages.keywords are written to the "last" file (in the alpha-numerical sense) in this directory (if this is a directory), but this is just a guess.

It would be great if it would be configurable where the changes end up.  Probably a specific file (e.g. packages.keywords/autounmask) would be a good default.  At least this behaviour should be documented.  Furthermore, emerge itself should tell which files are to be changed (at least with the --verbose switch).
Comment 1 Zac Medico gentoo-dev 2011-06-08 16:28:46 UTC
If the file is a directory, then it traverses in lexical order and chooses the last file found. So, you could create a file called something like zzz-autounmask if you the changes to go there.

I've just realized that the current code writes package.keywords, which could be annoying for people that are using the new package.accept_keywords name. We should fix it to use package.accept_keywords if it exists.
Comment 2 Zac Medico gentoo-dev 2011-06-08 17:08:00 UTC
(In reply to comment #1)
> I've just realized that the current code writes package.keywords, which could
> be annoying for people that are using the new package.accept_keywords name. We
> should fix it to use package.accept_keywords if it exists.

This issue is fixed in git:

http://git.overlays.gentoo.org/gitweb/?p=proj/portage.git;a=commit;h=c36d3ea4dec51781f0a1a3f45c3d2565e9ca2f95
Comment 3 Thomas Kahle (RETIRED) gentoo-dev 2011-06-23 11:29:00 UTC
So the behaviour of choosing the last file in /etc/portage/package.keywords is a feature, not a bug?
If this is the case, then please document in the man pages.
Thanks.
Comment 4 Zac Medico gentoo-dev 2011-06-23 21:38:51 UTC
(In reply to comment #3)
> So the behaviour of choosing the last file in /etc/portage/package.keywords is
> a feature, not a bug?

Right. For example, if one of the files has "foo/bar -*", then any new settings that override it have to be appended to the same file or a later one. The simplest thing to do is to append all changes to the last file.

> If this is the case, then please document in the man pages.
> Thanks.

Ok, will do.
Comment 6 Zac Medico gentoo-dev 2011-09-19 13:58:41 UTC
This is fixed in 2.1.10.19 and 2.2.0_alpha59.