Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 370053 - x11-drivers/ati-drivers: xorg doesn't exit on shutdown
Summary: x11-drivers/ati-drivers: xorg doesn't exit on shutdown
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo X packagers
URL: http://forums.gentoo.org/viewtopic.ph...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-04 17:42 UTC by Alexey Korepanov
Modified: 2015-07-10 17:16 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
lspci (lspci,2.59 KB, text/plain)
2011-06-04 17:50 UTC, Alexey Korepanov
Details
part of multiseat config - gdm's custom.conf (etc.X11.gdm.custom.conf,3.55 KB, text/plain)
2011-06-04 17:51 UTC, Alexey Korepanov
Details
current "emerge --info ati-drivers gentoo-sources" (now-emerge.--info.ati-drivers.gentoo-sources,5.73 KB, application/octet-stream)
2011-06-04 17:52 UTC, Alexey Korepanov
Details
old (when I system would hang) emerge --info (old-emerge.--info,4.42 KB, application/octet-stream)
2011-06-04 17:53 UTC, Alexey Korepanov
Details
message in /var/log/messages about ASIC hang (old-var.log.messages,8.58 KB, application/octet-stream)
2011-06-04 17:53 UTC, Alexey Korepanov
Details
current "emerge --info ati-drivers gentoo-sources" (now-emerge.--info.ati-drivers.gentoo-sources,5.73 KB, text/plain)
2011-06-04 17:54 UTC, Alexey Korepanov
Details
old (when I system would hang) emerge --info (old-emerge.--info,4.42 KB, application/octet-stream)
2011-06-04 17:55 UTC, Alexey Korepanov
Details
message in /var/log/messages about ASIC hang (old-var.log.messages,8.58 KB, text/plain)
2011-06-04 17:55 UTC, Alexey Korepanov
Details
old (when I system would hang) emerge --info (old-emerge.--info,4.42 KB, text/plain)
2011-06-04 17:56 UTC, Alexey Korepanov
Details
old (when I system would hang) emerge --info (old-emerge.--info,4.42 KB, text/plain)
2011-06-04 17:57 UTC, Alexey Korepanov
Details
part of multiseat configuration - file in /etc/X11/xorg.conf.d/ (xorg.conf,2.48 KB, text/plain)
2011-06-04 17:58 UTC, Alexey Korepanov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Korepanov 2011-06-04 17:42:21 UTC
Hi all,

When I shutdown the system, at the very end it says "cannot remount / readonly
because we are using it". By adding into /etc/init.d/mount-ro command ps -Af
it was found out that the cause is likely to be Xorg process that didn't quit.

HISTORY:
I had an issue with computer hanging on shutdown right after "removing addresses" for net.eth0. If I would wait for about 3 minutes (long time to wait!), shutdown would continue, and after booting up again I see in /var/log/messages a long output of issue with fglrx, something about ASCI hang. Back
then I was running kernel 2.6.37-r4 and ati-drivers 11.3. I have upgraded to
~amd64 versions and it stopped hanging but I'm having this bug.

HARDWARE:
I have 2 ati radeon 4000 series video cards, and the machine serves 2 
workplaces by multiseat.

Reproducible: Sometimes

Steps to Reproduce:
1. turn computer on
2. shut it down
3. profit

sometimes doesn't happen, can't tell what could be different.
Actual Results:  
message
"cannot remount / readonly because we are using it"
right before shutdown

Expected Results:  
success in remounting / readonly

I will attach logs in a second
Comment 1 Alexey Korepanov 2011-06-04 17:50:54 UTC
Created attachment 275817 [details]
lspci
Comment 2 Alexey Korepanov 2011-06-04 17:51:32 UTC
Created attachment 275819 [details]
part of multiseat config - gdm's custom.conf
Comment 3 Alexey Korepanov 2011-06-04 17:52:30 UTC
Created attachment 275821 [details]
current "emerge --info ati-drivers gentoo-sources"
Comment 4 Alexey Korepanov 2011-06-04 17:53:05 UTC
Created attachment 275823 [details]
old (when I system would hang) emerge --info
Comment 5 Alexey Korepanov 2011-06-04 17:53:59 UTC
Created attachment 275825 [details]
message in /var/log/messages about ASIC hang
Comment 6 Alexey Korepanov 2011-06-04 17:54:57 UTC
Created attachment 275827 [details]
current "emerge --info ati-drivers gentoo-sources"
Comment 7 Alexey Korepanov 2011-06-04 17:55:26 UTC
Created attachment 275829 [details]
old (when I system would hang) emerge --info
Comment 8 Alexey Korepanov 2011-06-04 17:55:57 UTC
Created attachment 275831 [details]
message in /var/log/messages about ASIC hang
Comment 9 Alexey Korepanov 2011-06-04 17:56:27 UTC
Created attachment 275833 [details]
old (when I system would hang) emerge --info
Comment 10 Alexey Korepanov 2011-06-04 17:57:12 UTC
Created attachment 275835 [details]
old (when I system would hang) emerge --info
Comment 11 Alexey Korepanov 2011-06-04 17:58:06 UTC
Created attachment 275837 [details]
part of multiseat configuration - file in /etc/X11/xorg.conf.d/
Comment 12 Enrico Tagliavini 2011-06-08 07:22:13 UTC
Nasty bug :(. I'm sorry i have no clue about it, i never used two video cards on the same machine.

But it sounds like an upstream bug. It might be worth to open a bug also in the unofficial fglrx bugzilla http://ati.cchtml.com/ and also asking in phoronix forum http://phoronix.com/forums/ since AMD developers occasionaly read them. If you do so, pls post the links here to so i can easly follow them. Thank you.

May be you can also try removing ati-drivers reboot with radeon, remove /etc/ati/amdpcsdb (worth to backup first) and reinstall fglrx, but be aware this might cause you more trouble then benefit, couse fglrx will loose all settings this way (but that's the point, if the bug is related to a bad config you can spot it).
Comment 13 Alexey Korepanov 2011-06-15 17:58:46 UTC
Filed a bug at ati.cchtml.com:
http://ati.cchtml.com/show_bug.cgi?id=168
Comment 14 Alexey Korepanov 2011-09-09 00:54:14 UTC
With gentoo-sources-3.0.3 and ati-drivers-11.8 the issue is back - I have to wait a long time on shutdown.
Comment 15 Manuel Rüger gentoo-dev 2015-07-10 17:16:10 UTC
Closing this bug, as 11.8 is not available in tree anymore. Please reopen, if you can reproduce with a recent version.