Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 369277 - games-kids/gmult-5.3 should depend on dev-perl/XML-Parser
Summary: games-kids/gmult-5.3 should depend on dev-perl/XML-Parser
Status: RESOLVED DUPLICATE of bug 41124
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-30 09:33 UTC by Piotr Szymaniak
Modified: 2013-12-19 15:26 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
gmult-5.3:20110530-101350.log (games-kids:gmult-5.3:20110530-101350.log,3.57 KB, text/x-log)
2011-05-30 09:33 UTC, Piotr Szymaniak
Details
gmult-5.3-config.log (games-kids:gmult-5.3-config.log,19.64 KB, text/x-log)
2011-05-30 09:33 UTC, Piotr Szymaniak
Details
emerge --info =games-kids/gmult-5.3 (gmult-5.3-emerge--info,4.04 KB, application/octet-stream)
2011-05-30 09:34 UTC, Piotr Szymaniak
Details
emerge -pqv =games-kids/gmult-5.3 (gmult-5.3-emerge-pqv,4.47 KB, application/octet-stream)
2011-05-30 09:34 UTC, Piotr Szymaniak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr Szymaniak 2011-05-30 09:33:21 UTC
(…)
checking dependency style of x86_64-pc-linux-gnu-gcc... gcc3
checking for x86_64-pc-linux-gnu-g++... x86_64-pc-linux-gnu-g++
checking whether we are using the GNU C++ compiler... yes
checking whether x86_64-pc-linux-gnu-g++ accepts -g... yes
checking dependency style of x86_64-pc-linux-gnu-g++... gcc3
checking for a BSD-compatible install... /usr/bin/install -c
checking whether make sets $(MAKE)... (cached) yes
checking for perl... /usr/bin/perl
checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool


After installing dev-perl/XML-Parser gmult installs fine.

Reproducible: Always
Comment 1 Piotr Szymaniak 2011-05-30 09:33:41 UTC
Created attachment 275097 [details]
gmult-5.3:20110530-101350.log
Comment 2 Piotr Szymaniak 2011-05-30 09:33:54 UTC
Created attachment 275099 [details]
gmult-5.3-config.log
Comment 3 Piotr Szymaniak 2011-05-30 09:34:17 UTC
Created attachment 275101 [details]
emerge --info =games-kids/gmult-5.3
Comment 4 Piotr Szymaniak 2011-05-30 09:34:33 UTC
Created attachment 275103 [details]
emerge -pqv =games-kids/gmult-5.3
Comment 5 Rafał Mużyło 2011-05-30 14:38:07 UTC
Were you unmerging build dependencies ?
intltool depends on dev-perl/XML-Parser unconditionally.
Comment 6 Piotr Szymaniak 2011-05-30 15:08:17 UTC
(In reply to comment #5)
> Were you unmerging build dependencies ?

No. But I can see what's the reason for this. Looks like this is caused by forgotten --with-bdeps=y when part of the stuff is installed from packages (--usepkg). So this is ivalid then, sorry. (:
Comment 7 Jeroen Roovers gentoo-dev 2013-12-19 15:26:44 UTC

*** This bug has been marked as a duplicate of bug 41124 ***