Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 369105 - media-sound/orpheus - vcedit.o:vcedit.c:function _v_writestring: error: undefined reference to 'oggpack_write'
Summary: media-sound/orpheus - vcedit.o:vcedit.c:function _v_writestring: error: undef...
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Sound Team
URL:
Whiteboard:
Keywords: PATCH
: 536186 (view as bug list)
Depends on:
Blocks: tinfo underlinking
  Show dependency tree
 
Reported: 2011-05-28 23:51 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2016-02-18 19:59 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (orpheus-1.6-r2:20110528-223131.log,37.70 KB, text/plain)
2011-05-28 23:51 UTC, Diego Elio Pettenò (RETIRED)
Details
files/orpheus-1.6-tinfo.patch (orpheus-1.6-tinfo.patch,360 bytes, patch)
2014-12-22 08:42 UTC, Jeroen Roovers
Details | Diff
files/orpheus-1.6-libogg.patch (orpheus-1.6-libogg.patch,234 bytes, patch)
2014-12-22 08:42 UTC, Jeroen Roovers
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2011-05-28 23:51:26 UTC
Created attachment 274961 [details]
Build log

Hello there!

You're getting this bug because the package in Summary failed to build in my tinderbox using the gold link editor from binutils. Before closing the bug as INVALID let me explain why this is still important!

The gold link editor does not support underlinking of shared objects, which is something I have described in my blog post:

http://blog.flameeyes.eu/2010/11/26/it-s-not-all-gold-that-shines-why-underlinking-is-a-bad-thing

Even the basic link editor (ld.bfd) has an option to support this but it is a heck to enable and get passed, so linking with gold is simply quicker.

Fixing underlinking provides optimized --as-needed builds (because the "softer" version no longer need to recover libraries that are underlinked), so it is a Good Thing To Do.

Thank you very much for the attention!
Comment 1 Jeroen Roovers gentoo-dev 2014-12-22 08:42:05 UTC
Created attachment 392212 [details, diff]
files/orpheus-1.6-tinfo.patch
Comment 2 Jeroen Roovers gentoo-dev 2014-12-22 08:42:22 UTC
Created attachment 392214 [details, diff]
files/orpheus-1.6-libogg.patch
Comment 3 Jeroen Roovers gentoo-dev 2015-01-11 11:49:37 UTC
*** Bug 536186 has been marked as a duplicate of this bug. ***
Comment 4 Pacho Ramos gentoo-dev 2016-02-18 19:59:17 UTC
It looks to build with orpheus-1.6-r2.ebuild