Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 368901 - portage disrespects append-flags and similar if *FLAGS are defined in /etc/portage/env/CAT/PKG
Summary: portage disrespects append-flags and similar if *FLAGS are defined in /etc/po...
Status: RESOLVED DUPLICATE of bug 365439
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core - Ebuild Support (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-27 14:40 UTC by Justin Lecher (RETIRED)
Modified: 2011-05-28 07:47 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Justin Lecher (RETIRED) gentoo-dev 2011-05-27 14:40:27 UTC
If I place FLAGS in the /etc/portage/env... the flag-o-matic functions for appending flags do not work anymore. That shouldn't be.
Comment 1 Zac Medico gentoo-dev 2011-05-27 21:34:20 UTC
This might be related to bug 365439. For setting environment variables, /etc/portage/package.env is the preferred approach, since it behaves more like normal make.conf settings. On the other hand, /etc/portage/env/CAT/PKG is a form of bashrc which is both powerful and dangerous because it can override practically *anything* (including functions) inside the ebuild environment.
Comment 2 Zac Medico gentoo-dev 2011-05-28 07:47:20 UTC

*** This bug has been marked as a duplicate of bug 365439 ***