Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 368623 - kde-base/kdelibs-4.6.2-r3: emerge of binary package fails
Summary: kde-base/kdelibs-4.6.2-r3: emerge of binary package fails
Status: RESOLVED DUPLICATE of bug 366939
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: Normal major (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-24 19:23 UTC by nilje
Modified: 2011-05-24 21:59 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nilje 2011-05-24 19:23:12 UTC
We use to update our boxes from binary packages built by our build-server. AFAIK inherit() should not be called during install of a binary package. So I suppose this being a bug. The install fails just after downloading the tar-file.

* ERROR: kde-base/kdelibs-4.6.2-r3 failed (pretend phase):
 *   kde4-base.eclass could not be found by inherit()
 * 
 * Call stack:
 *                 ebuild.sh, line 1998:  Called source '/tmp/tmp2UWxh5/kde-base/kdelibs-4.6.2-r3/build-info/kdelibs-4.6.2-r3.ebuild'
 *   kdelibs-4.6.2-r3.ebuild, line   12:  Called inherit 'kde4-base' 'fdo-mime' 'toolchain-funcs'
 *                 ebuild.sh, line 1379:  Called die
 * The specific snippet of code:
 *              [ ! -e "$location" ] && die "${1}.eclass could not be found by inherit()"
 * 
 * If you need support, post the output of 'emerge --info =kde-base/kdelibs-4.6.2-r3',
 * the complete build log and the output of 'emerge -pqv =kde-base/kdelibs-4.6.2-r3'.
 * The complete build log is located at '/tmp/tmp2UWxh5/portage/kde-base/kdelibs-4.6.2-r3/temp/build.log'.
 * The ebuild environment file is located at '/tmp/tmp2UWxh5/portage/kde-base/kdelibs-4.6.2-r3/temp/die.env'.
 * S: '/tmp/tmp2UWxh5/portage/kde-base/kdelibs-4.6.2-r3/work/kdelibs-4.6.2'
Portage 2.1.9.42 (binclient, gcc-4.4.5, libc-0-r0, 2.6.34-gentoo-r201102072015 i686)                                                                                                                                                         
=================================================================                                                                                                                                                                            
                        System Settings                                                                                                                                                                                                      
=================================================================                                                                                                                                                                            
System uname: Linux-2.6.34-gentoo-r201102072015-i686-Intel-R-_Pentium-R-_4_CPU_2.80GHz-with-gentoo-1.12.14                                                                                                                                   
Timestamp of tree: Unknown                                                                                                                                                                                                                   
app-shells/bash:     4.1_p9                                                                                                                                                                                                                  
dev-java/java-config: 2.1.11-r3                                                                                                                                                                                                              
dev-lang/python:     2.7.1-r1, 3.1.3-r1                                                                                                                                                                                                      
sys-apps/baselayout: 1.12.14-r1                                                                                                                                                                                                              
sys-apps/sandbox:    2.4                                                                                                                                                                                                                     
sys-devel/autoconf:  2.65-r1                                                                                                                                                                                                                 
sys-devel/automake:  1.11.1                                                                                                                                                                                                                  
sys-devel/binutils:  2.20.1-r1                                                                                                                                                                                                               
sys-devel/gcc:       4.4.5                                                                                                                                                                                                                   
sys-devel/gcc-config: 1.4.1-r1                                                                                                                                                                                                               
sys-devel/libtool:   2.2.10                                                                                                                                                                                                                  
sys-devel/make:      3.81-r2                                                                                                                                                                                                                 
sys-kernel/linux-headers: 2.6.36.1                                                                                                                                                                                                           
sys-libs/glibc:      2.11.3                                                                                                                                                                                                                  
virtual/os-headers:  0
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="de_DE.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa berkdb bluetooth branding bzip2 cairo cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gdu gif gpm gtk iconv ipv6 jpeg kde lcms ldap libnotify mad mng modules mp3 mp4 mpeg mudflap ncurses nls nptl nptlonly ogg opengl openmp pam pango pcre pdf perl png policykit ppds pppd python qt3support qt4 readline sdl session spell ssl startup-notification svg sysfs tcpd tiff truetype udev unicode usb vorbis x264 x86 xcb xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="braindump flow karbon kexi kpresenter krita tables words" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, MAKEOPTS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY






Reproducible: Always

Steps to Reproduce:
1.emerge -Dugq --rebuilt-binaries y kde-base/kdelibs (called from a script though) 
2. fail happens after download of tarball
3.
Actual Results:  
see description

Expected Results:  
should install binary package without complaining

We are trying to make a major update of all packages necessary by the upgrade of python from 2.6 to 2.7 (reinstalling the whole system)
We are running some 80+ boxes with gentoo. On the boxes a script is run which does the binary update. The binaries get compiled (script driven) on our build-server which, when a emerge world is completely successfully compiled, are distributed by ftp. Our "packages-update" is running fine but we are not able to update such many boxes by compiling the system locally. So this bug keeps us from updating our client boxes.
Comment 1 Tomáš Chvátal (RETIRED) gentoo-dev 2011-05-24 19:39:20 UTC
This is all handled by eclasses.

And it is inherited properly.

Maybe the system in the name has broken cache... could you try to delete it? (metadata cache i am speaking about).
Comment 2 nilje 2011-05-24 19:42:47 UTC
(In reply to comment #1)
> This is all handled by eclasses.
> 
> And it is inherited properly.
> 
> Maybe the system in the name has broken cache... could you try to delete it?
> (metadata cache i am speaking about).

Thanks for the hint. I will try this tomorrow
Comment 3 Zac Medico gentoo-dev 2011-05-24 21:59:03 UTC

*** This bug has been marked as a duplicate of bug 366939 ***