Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 368 - kde-base/kdebase fails to build
Summary: kde-base/kdebase fails to build
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Dan Armak (RETIRED)
Depends on:
Reported: 2002-01-27 16:24 UTC by Daniel Nielsen
Modified: 2003-02-04 19:42 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Nielsen 2002-01-27 16:24:06 UTC
kdebase fails to build. It bombs with this:
g++ -DHAVE_CONFIG_H -I. -I. -I.. -I/usr/kde/2/include/arts -I/usr/kde/2/include
-I/usr/qt/2/include -I/usr/X11R6/include -DNDEBUG -O2 -mcpu=i686 -march=i686 -Os
-pipe -fno-exceptions -fno-check-new -DQT_CLEAN_NAMESPACE -DQT_NO_COMPAT
/bin/sh ../libtool --mode=link --tag=CXX g++  -DNDEBUG -O2 -mcpu=i686
-march=i686 -Os -pipe -fno-exceptions -fno-check-new -DQT_CLEAN_NAMESPACE
libkonqsound_la_closure.lo -L/usr/X11R6/lib -L/usr/qt/2/lib -L/usr/kde/2/lib 
-avoid-version -module -no-undefined -R /usr/kde/2/lib -R /usr/qt/2/lib -R
/usr/X11R6/lib konq_sound.lo -lsoundserver_idl -lartskde 
libtool: link: cannot find the library
make[3]: *** [] Error 1
make[3]: Leaving directory
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/kdebase-2.2.2-r2/work/kdebase-2.2.2'
make: *** [all-recursive-am] Error 2

!!! ERROR: The ebuild did not complete successfully.
!!! Function kde_src_compile, Line 10, Exitcode 2
!!! (no error message)

!!! emerge aborting on  /usr/portage/kde-base/kdebase/kdebase-2.2.2-r2.ebuild .

The Audiofile installed is:
Comment 1 Dan Armak (RETIRED) gentoo-dev 2002-01-29 16:11:45 UTC
No on else has rerpored this. It looks like some kind of makefile trouble 
(trying to access the audiofile library inside ${WORKDIR}).

Please tell me what your USE flags are (as a comment here).

If you haven't yet, please try remerging audiofile and then try kdebase 

If you have, or once you do (and it fails again), could you please send me 
files to
Comment 2 Daniel Nielsen 2002-01-30 07:47:08 UTC
My USE var is:USE="slang readline gpm berkdb gdbm tcpd pam libwww ssl alsa nls mitshm perl python gif sdl vorbis ogg gtk X qt kde motif opengl mozilla objprelink 3dnow java"And yes. I've tried remerging audiofiles, unmerging, merging... the lots! Nothing works... Same error!
Comment 3 Daniel Nielsen 2002-01-31 08:07:02 UTC
It seems another user has reported this as well...
On gentoo-user mailing list.... 

A posting with subject:
[gentoo-user] help with gentoo desktop

So it looks like it's not only me with difficulties....
Comment 4 Dan Armak (RETIRED) gentoo-dev 2002-02-01 01:53:21 UTC
OK, please give me your /var/tmp/.../libkonq/ and your 

If the first one is faulty I'll try to trace any problems with its generation 
(difficult unless I can reproduce the problem, so far I haven't). If the second 
one is, it's a libaudiofile problem not a kdebase one.

I hope we can resolve this soon.
Comment 5 Dan Armak (RETIRED) gentoo-dev 2002-02-12 12:27:13 UTC
Since there's been no new info for nearly two weeks, and the bug appears 
to have been a libaudiofile one not a kde one, I'm closing this. Reopen if 
still relevant.