Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 367821 - app-admin/sysstat-10.0.0: initscript not completely openrc compatible
Summary: app-admin/sysstat-10.0.0: initscript not completely openrc compatible
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Jeroen Roovers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 367793
  Show dependency tree
 
Reported: 2011-05-17 21:22 UTC by Robert Trace
Modified: 2011-05-18 02:22 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Remove svc_(start|stop) and make openrc compatible (initd-openrc.patch,299 bytes, patch)
2011-05-17 21:24 UTC, Robert Trace
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Trace 2011-05-17 21:22:44 UTC
Initscript uses svc_(start|stop).  These functions don't appear to be supported
in openrc.


Reproducible: Always
Comment 1 Robert Trace 2011-05-17 21:24:13 UTC
Created attachment 273723 [details, diff]
Remove svc_(start|stop) and make openrc compatible

Just remove the custom restart() function as its not providing much value and openrc's default of calling stop() & start() is going to provide the same functionality.
Comment 2 Jeroen Roovers gentoo-dev 2011-05-18 00:20:13 UTC
Apart from their probably obsolete mention in a comment, how does that comment's presence do anything in openrc? How does removing the restart function help?
Comment 3 Robert Trace 2011-05-18 00:46:16 UTC
Dead code elimination, removal of a misleading function.... that's about it.

Does it help/hinder anything under openrc?  Functionally, not really since openrc is going to ignore it anyway, but removing the appearance of functionality is probably a good thing.  Before today, I assumed that openrc _didn't_ ignore restart() since several scripts still implemented it.
Comment 4 Jeroen Roovers gentoo-dev 2011-05-18 02:22:09 UTC
OK, that makes sense. Removed. Thanks for reporting.