Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 367351 - sys-devel/crossdev causes miscompilation of dev-libs/glib on 32-bit platform (config.site misreports glib_cv_sizeof_gmutex)
Summary: sys-devel/crossdev causes miscompilation of dev-libs/glib on 32-bit platform ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Embedded Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-15 12:19 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2011-06-10 07:01 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2011-05-15 12:19:09 UTC
/usr/share/crossdev/include/site/linux reports

glib_cv_sizeof_gmutex=40

but the variable should rather be 24 at least on i386; the size it reports is the size of pthread_mutex_t which is arch-dependent.

The problem is that since this is overridden when crossdev is installed, you have a nastily broken glib that, among other things, would make VMware crash (as reported by PaX Team).

The value should probably be moved to x86_64-linux-gnu, rather than linux only, and separated for other platforms.

@GNOME: you _might_ want to add a blocker on the current version of crossdev for glib, just to be on the safe side.
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2011-05-15 14:27:24 UTC
Fixed this on the crossdev git repository, Mike can you please take care of the release?
Comment 2 Johan Ymerson 2011-06-10 07:01:40 UTC
Why is this bug marked resolved?
It is _not_ resolved. There is no new ebuild in portage.
A new, clean, install of Gentoo with crossdev still get this problem.