Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 367281 - www-plugins/adobe-flash- video displays even when window is backgrounded
Summary: www-plugins/adobe-flash- video displays even when window is backg...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Jim Ramsay (lack) (RETIRED)
Depends on:
Reported: 2011-05-14 18:34 UTC by tman
Modified: 2012-03-29 10:14 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description tman 2011-05-14 18:34:29 UTC
if i run it in firefox e.g.: a youtube video so i can see it as background in the xterm console, even if this xtermial is on other virtal desktop

Reproducible: Always

Portage 2.2.0_alpha33_p1 (default/linux/amd64/10.0/desktop, gcc-4.5.2, glibc-2.13-r2, 2.6.38-gentoo-r5 x86_64)
System uname: Linux-2.6.38-gentoo-r5-x86_64-Intel-R-_Core-TM-2_Duo_CPU_P9700_@_2.80GHz-with-gentoo-2.0.2
Timestamp of tree: Sat, 14 May 2011 18:00:01 +0000
ccache version 3.1.4 [enabled]
app-shells/bash:          4.2_p10
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.1-r1, 3.1.3-r1, 3.2
dev-util/ccache:          3.1.4
dev-util/cmake:           2.8.4-r1
sys-apps/baselayout:      2.0.2
sys-apps/openrc:          0.8.2-r1::poly-c
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1-r1
sys-devel/binutils:       2.21
sys-devel/gcc:            4.5.2
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82
sys-kernel/linux-headers: 2.6.38 (virtual/os-headers)
sys-libs/glibc:           2.13-r2
Repositories: gentoo amielke-overlay emacs gnome lorelei-overlay hwoarang java-overlay lxde mellon mgorny mpd nikai poly-c qting-edge roslin scarabeus_local_overlay science wirelay Techwolf bleeding-edge x-local-overlay
Installed sets: 
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-march=core2 -O2 -pipe"
Comment 1 Robin 2011-05-15 15:07:15 UTC
Same here.
See for some help.
Comment 2 Jim Ramsay (lack) (RETIRED) gentoo-dev 2011-05-15 16:58:37 UTC
Please include information about your video card and driver.
Comment 3 tman 2011-05-15 17:56:30 UTC
01:00.0 VGA compatible controller: nVidia Corporation GT200 [GeForce GTX 260M] (rev a2)

[I] media-gfx/nvidia-cg-toolkit
     Available versions:  2.1.0012!s (~)2.1.0016!s (~)2.1.0017!s (~)2.1.0017!s[2] (~)3.0.0016!s{tbz2}[2] {doc examples multilib}
     Installed versions:  3.0.0016!s{tbz2}[2](02:28:13 02.05.2011)(multilib -doc -examples)
     Description:         NVIDIA's C graphics compiler toolkit

[I] media-video/nvidia-settings
     Available versions:  (~)173.14.25 (~)173.14.27 (~)173.14.30 (~)185.18.36 (~)190.53 195.36.24 (~)195.36.31 (~)256.44 (~)256.52 (~)260.19.04[3] 260.19.29 (~)260.19.36 (~)260.19.44 (~)270.41.03 (~)270.41.06{tbz2}
     Installed versions:  270.41.06{tbz2}(06:02:09 12.05.2011)
     Description:         NVIDIA Linux X11 Settings Utility

[I] x11-drivers/nvidia-drivers
     Available versions:  96.43.19!s 173.14.28!s (~)173.14.30!s (~)256.53!s (~)256.53!s[1] (~)260.19.04!s[3] 260.19.36!s (~)260.19.44!s (~)270.41.03!s (~)270.41.06!s{tbz2} {acpi custom-cflags gtk kernel_linux multilib}
     Installed versions:  270.41.06!s{tbz2}(19:13:20 11.05.2011)(acpi gtk kernel_linux multilib -custom-cflags)
Comment 4 Jim Ramsay (lack) (RETIRED) gentoo-dev 2011-05-16 12:48:01 UTC
Nvidia drivers with odd screen artifacts is may be duplicate of bug #355191.

Try disabling hardware acceleration and see if the problem persists:

-> Go to any running flash applet
-> Right-click and choose 'Settings..."
-> In the first pane that appears, un-check the "Enable Hardware Acceleration" box
-> Restart firefox and see if the problem persists
Comment 5 Tomáš Chvátal (RETIRED) gentoo-dev 2011-05-16 14:57:30 UTC
(In reply to comment #4)
> Nvidia drivers with odd screen artifacts is may be duplicate of bug #355191.
> Try disabling hardware acceleration and see if the problem persists:
> -> Go to any running flash applet
> -> Right-click and choose 'Settings..."
> -> In the first pane that appears, un-check the "Enable Hardware Acceleration"
> box
> -> Restart firefox and see if the problem persists

Seems like this flicker can be reproduced with mesa code if composite extension is used (on r600g and r300g code at minimal)... :(
Comment 6 Jim Ramsay (lack) (RETIRED) gentoo-dev 2011-05-16 15:15:38 UTC
Okay, since this exhibits on more video hardware than just nvidia, it is *not* a duplicate of bug #355191.

Disabling hardware acceleration may clean up some of the video issues at the cost of your videos becoming more laggy.

You may want to report this upstream:
Comment 7 peng shao 2011-05-22 12:54:11 UTC
(In reply to comment #0)
> if i run it in firefox e.g.: a youtube video so i can see it as background in
> the xterm console, even if this xtermial is on other virtal desktop

I have exactly the same problem. It even crashes my system several times so now I have to mask I am using nvidia-drivers-270.41.06
Comment 8 kaszynek 2011-05-27 12:34:20 UTC
I have also the same problem.
Also my flash sometimes is hanging on. (Maybe it is somehow related)
I have some strange error in firefox like this:

*** NSPlugin Viewer  *** WARNING: unhandled variable 18 (<unknown variable>) in NPN_GetValue()
*** NSPlugin Wrapper *** ERROR: NPP_WriteReady() wait for reply: Message timeout

link to output
Comment 9 kaszynek 2011-06-02 18:51:35 UTC
with nspluginwrapper-1.4.0-r1  I have the same problem :/ 
it can be somehow related: but it is from 2008...
Comment 10 tman 2011-06-20 12:18:01 UTC
it does solve with nspluginwrapper-1.4.2.

the problem is still exist
Comment 11 tman 2011-06-21 09:53:42 UTC
woah really annoying, now flash crash and let whole system freeze
Comment 12 Fab 2011-10-30 19:01:52 UTC
Happens since a few days (or weeks?) under Xfce on a stable x86 system with :
 * (testing) firefox-7.0.1-r1
 * (stable) adobe-flash-
 * (stable) nvidia-drivers-275.09.07

Upgrading to testing adobe-flash- beta version seems to solve the problem.
Comment 13 Jim Ramsay (lack) (RETIRED) gentoo-dev 2011-12-25 03:46:10 UTC
Now that 11.1 has been officially released, can those who were experiencing this problem please test with the latest version?
Comment 14 Fab 2011-12-30 09:53:03 UTC
(In reply to comment #13)
> Now that 11.1 has been officially released, can those who were experiencing
> this problem please test with the latest version?

Works fine for me since a while.
Comment 15 Jim Ramsay (lack) (RETIRED) gentoo-dev 2012-01-01 23:56:31 UTC
I think this has probably been resolved with 11.1 : Marking as fixed Upstream.
Comment 16 Siim Ainsaar 2012-03-29 10:14:57 UTC
I have not seen this bug for a while, up to www-plugins/adobe-flash- everything has been fine. But now I am seeing it again with both and I have tried x11-drivers/nvidia-drivers-290.10-r2 and 295.33, both show the problem. I am using www-client/firefox-11.0-r1 in x11-wm/fluxbox-1.3.2. 

To reproduce, pause any Youtube video on one virtual desktop and look at another virtual desktop. Black pixels are not black there, but show the paused video frame instead. In addition, all the colors in the video are too blue!

 $ emerge --info nvidia-drivers adobe-flash
Portage (default/linux/amd64/10.0/desktop, gcc-4.5.3, glibc-2.13-r4, 3.0.26-tuxonice x86_64)
                        System Settings
System uname: Linux-3.0.26-tuxonice-x86_64-Intel-R-_Core-TM-2_Duo_CPU_P8700_@_2.53GHz-with-gentoo-2.0.3
Timestamp of tree: Wed, 28 Mar 2012 19:45:01 +0000
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.2.2
dev-util/cmake:           2.8.6-r4
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo x-portage sunrise esteid
CFLAGS="-march=core2 -mcx16 -msahf -msse4.1 --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=3072 -O2 -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=core2 -mcx16 -msahf -msse4.1 --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=3072 -O2 -pipe -fomit-frame-pointer"
EMERGE_DEFAULT_OPTS="--with-bdeps y --autounmask"
FEATURES="assume-digests binpkg-logs collision-protect compress-build-logs distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync webrsync-gpg xattr"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/usr/local/portage /var/lib/layman/sunrise /var/lib/layman/esteid"
USE="3dnow 3dnowext 64bit X a52 aac aalib ace acpi alac alsa amd64 amr animgif apng archive ares artworkextra asf aspell ass asyncdns asyncns atlas audacious autotrace bash-completion berkdb bidi binary-drivers blas bluetooth boost bs2b bzip2 cairo caps cblas-external cdda cddb cdparanoia cdr cdrom cg chardet chm cjk cleartype cli cln colord colordiff compress consolekit corefonts cpio cracklib crypt cscope css cuda cue cups cxx dbus dell dga dirac djbfft djvu doc double-precision dri dts dv dvd dvdnav dvdr dvi dvipdfm ebook ee emboss emf enca encode equalizer exceptions exif expat fasttrack fat fbcon ffmpeg fftw firefox firefox3 fits flac flash fontconfig fortran ftp gcj gd gdbm gdu geoip geolocation gif gimp gkrellm glib glitz glut gmail gmp gnome gnuplot gnutella gopher gpm gpu grammar graphicsmagick graphviz gs gsl gtalk gtk gucharmap handbook hardcoded-tables hdf hdf5 hdri highlight history hpijs hpn iconv icu id3 id3tag idn ieee1394 image-cache imagemagick imlib inkjar ipv6 irc iso14755 jabber java java6 javascript jbig jemalloc jpeg jpeg2k kate kde keyscrub kpathsea kqemu ladspa lame lapack lapack-atlas laptop largeterminal lasi latex lcdfilter lcms ldap lensfun libcaca libnl libnotify libsamplerate libssh2 libvisual live lm_sensors lzma lzo mac mad matroska mbox mbrola memlimit metric mime mjpeg mkl mmx mmxext mng models modules monolithic-build mp3 mp4 mpeg mplayer msn mudflap multilib multiprocess multiuser musepack music nautilus ncurses netpbm network-cron nls nntp nocd nodrm nptl nptlonly ntfs ntp ntpd nvidia offlinehelp ogg ogg123 ogm okteta okular opencv openexr opengl openmp openssl openstreetmap openvg optimization optimize-cflags optimized-qmake pam pango pch pcmcia pcre pdf pdfimport pgf phonon pidgin pkcs11 pm-utils png pnm policykit postproc postscript povray ppds pppd prediction ps pstoedit pulseaudio qt3support qt4 quesoglc quicktime rar raw readline reiserfs replaygain rle romio rpm rtc sbcl scanner schroedinger screen sdl session sftp sha512 shaders sift skype smp sndfile solver sound sounds sox speex spell srt sse sse2 sse3 sse4_1 ssh ssl ssse3 startup-notification static-ppds subtitles svg sysfs syslog system-sqlite szip t1lib taglib tcpd templates themes theora thesaurus thin-splines threads threadsafe thumbnail tiff timezone timidity truetype twolame type3 udev umfpack unicode usb userlocales utempter uuencode v4l v4l2 vaapi vamp vcd vcdx videos vim vim-pager vim-syntax vorbis vpx wav wavpack webcam wifi wma wmf wps wv2 x264 xattr xcb xcf xcomposite xext xinerama xml xmp xorg xosd xpm xrandr xrender xscreensaver xulrunner xv xvid xvmc youtube zip zlib" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse synaptics evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" PHP_TARGETS="php5-3" QEMU_SOFTMMU_TARGETS="x86_64 i386" QEMU_USER_TARGETS="x86_64 i386" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

                        Package Settings

x11-drivers/nvidia-drivers-290.10-r2 was built with the following:
USE="acpi (multilib) -custom-cflags -gtk"

www-plugins/adobe-flash- was built with the following:
USE="64bit kde (multilib) -32bit -vdpau"