Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 366893 - sys-fs/udev: Coldplugging USB mass storage devices fails
Summary: sys-fs/udev: Coldplugging USB mass storage devices fails
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: Normal normal (vote)
Assignee: udev maintainers
URL: http://forums.gentoo.org/viewtopic-t-...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-11 15:16 UTC by basti
Modified: 2013-01-28 12:00 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description basti 2011-05-11 15:16:15 UTC
Since approx. half a year my USB HDD isn’t detected anymore if it is connected while booting. Disconnecting and connecting helps. After some trying I see that compiling “usb-storage“ into the Kernel helps solving that problem.

I think openrc should coldplug the device at booting even if usb-storage is just a module, it should load that module if that’s necessary.

Reproducible: Always

Steps to Reproduce:
1.compile “usb-storage“ as module
2. connect any USB mass storage device like an HDD or stick
Actual Results:  
device just shows up in “lsusb“, no device files like /dev/sdb1 are created.

Expected Results:  
openrc should “coldplug“ the device at boot.
Comment 1 Jeroen Roovers gentoo-dev 2011-05-13 00:43:42 UTC
I think this would be a udev thing, not openrc in particular.
Comment 2 Christian Ruppert (idl0r) archtester Gentoo Infrastructure gentoo-dev Security 2011-09-18 14:55:07 UTC
OpenRC has nothing to do with it.
Comment 3 Samuli Suominen gentoo-dev 2013-01-28 12:00:12 UTC
Try with recent kernel, latest openrc and udev-197 (or higher). If the problem is still there, attach your `dmesg` output here (plug-in, plug-out if you can)
Thanks