Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 366757 - =media-libs/gegl-0.1.6 - ff-load.c:79: error: duplicate case value
Summary: =media-libs/gegl-0.1.6 - ff-load.c:79: error: duplicate case value
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: Normal normal (vote)
Assignee: Sebastian Pipping
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-10 13:12 UTC by Raphael Mankin
Modified: 2013-04-27 01:12 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log for gegl-0.1.6 (build.log,80.36 KB, text/plain)
2011-05-10 13:14 UTC, Raphael Mankin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Raphael Mankin 2011-05-10 13:12:39 UTC
When buklding gegl-0.1.6 I get a 'duplicate case value' error in ff-load.c at lines 72 and 79.

Without gegl I cannot build gimp.

Reproducible: Always

Steps to Reproduce:
1. emerge gegl
2.
3.
Actual Results:  
See attached log file


I have recently done a major upgrade of xorg-x11 and gnome and am now trying to recover from all the broken linkages.


/usr/portage # emerge --info
Portage 2.1.9.42 (default/linux/x86/10.0/desktop/gnome, gcc-4.3.4, unavailable, 2.6.30-gentoo-r8 i686)
=================================================================
System uname: Linux-2.6.30-gentoo-r8-i686-Pentium_III_-Katmai-with-gentoo-1.12.14
Timestamp of tree: Mon, 02 May 2011 23:00:01 +0000
app-shells/bash:     4.1_p9
dev-java/java-config: 2.1.11-r3
dev-lang/python:     2.6.6-r2, 2.7.1-r1, 3.1.3-r1
dev-util/cmake:      2.8.4-r1
sys-apps/baselayout: 1.12.14-r1
sys-apps/sandbox:    2.4
sys-devel/autoconf:  2.13::<unknown repository>, 2.65-r1
sys-devel/automake:  1.9.6-r2::<unknown repository>, 1.10.2, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.1.1-r3::<unknown repository>, 4.3.4, 4.4.5
sys-devel/gcc-config: 1.4.1-r1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81::<unknown repository>
sys-kernel/linux-headers: 2.6.36.1
sys-libs/glibc:      2.11.3
virtual/os-headers:  0
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA PUEL"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://gentoo.mirrors.pair.com/ ftp://gentoo.mirrors.pair.com/ ftp://ftp.kaist.ac.kr/gentoo/ http://ftp.fi.muni.cz/pub/linux/gentoo/ http://mirrors.ludost.net/gentoo/"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_GB en_US he"
MAKEOPTS="-j3 "
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X X509 a52 aac acl acpi alsa apache apache1 asf automount bash-completion berkdb bidi bindist bluetooth branding bzip2 cairo cdparanoia cdr cdrom chroot cli consolekit cracklib crypt css cups cvs cvsgraph cxx dbus devfs26 devmap dga dnsdb dri dts dv dvd dvdnav eds emboss encode evo evolution exif exim exiscan exiscan-acl extensions fam fat ffmpeg firefox flac fontconfig fortran ftp gdbm gdu gif gnome gnome-keyring gpm gstreamer gtk iconv innodb java java5 java6 jpeg lcms libnotify mad midi mng modules mozilla mp3 mp4 mpeg mudflap mysql mysqli nautilus ncurses nls nntp nptl nptlonly nsplugin ogg opengl openmp pam pango pcre pdf perl png policykit ppds pppd python qt3support rc5 readline realmedia samba sdl session sndfile sound spamassassin spell spf sqlite srs ssl startup-notification static-libs subversion svg sysfs tcpd tiff tk truetype udev unicode usb vncviewer vorbis widescreen x264 x86 xcb xfs xml xorg xulrunner xv xvid xvmc zlib" ALSA_CARDS="usb-audio emu10k1" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="mouse keyboard evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_GB en_US he" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" SANE_BACKENDS="hp" USERLAND="GNU" VIDEO_CARDS="ati radeon mach64 vesa fbdev" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Raphael Mankin 2011-05-10 13:14:05 UTC
Created attachment 272739 [details]
Build log for gegl-0.1.6
Comment 2 Jeroen Roovers gentoo-dev 2011-05-10 21:22:37 UTC
Please post the output of `emerge -vpq media-video/ffmpeg' too.
Comment 3 Raphael Mankin 2011-05-11 08:40:52 UTC
I have worked around this by reverting both gegl and babl to 0.0.22. Mixing and matching the versions (gegl-0.1.6, babl-0.1.4), -0.0.22) does not work. The dependencies in the ebuilds should really be updated, but I don't suppose that it is terribly urgent.


Ouput for ffmpeg, as requested, below:


emerge -vpq media-video/ffmpeg
[ebuild   R   ] media-video/ffmpeg-0.6_p25767  USE="3dnow 3dnowext X alsa bindist bzip2 encode hardcoded-tables mmx mmxext mp3 sdl ssse3 static-libs* vorbis x264 xvid zlib (-altivec) -amr -cpudetection -custom-cflags -debug -dirac -doc -faac -frei0r -gsm -ieee1394 -jack -jpeg2k -network -oss -pic -qt-faststart -rtmp -schroedinger -speex -test -theora -threads -v4l -v4l2 -vaapi -vdpau -vpx" VIDEO_CARDS="-nvidia"
Comment 4 Sebastian Pipping gentoo-dev 2013-04-27 01:12:22 UTC
I cannot reproduce the issue.  If it still matters, please compile and run this tiny C program 

============================================================
#include <stdio.h>
#include <errno.h>
#include <libavutil/error.h>

int main() {
	printf("AVERROR(EDOM)    %d\n", AVERROR(EDOM));
	printf("AVERROR(EINVAL)  %d\n", AVERROR(EINVAL));
	return 0;
}
============================================================

and share it's output.  Mine is:


============================================================
# gcc -o 366757{,.c} && ./366757
AVERROR(EDOM)    -33
AVERROR(EINVAL)  -22
============================================================


Closing until I hear back.  Thanks!