Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 366675 - dev-lang/ruby-1.9.2 only builds with -fPIC
Summary: dev-lang/ruby-1.9.2 only builds with -fPIC
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Ruby Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-10 00:55 UTC by Robin Kauffman
Modified: 2013-03-28 22:14 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log for Ruby 1.9.2 (ruby-1.9.2_build.log.gz,22.99 KB, application/x-gzip)
2011-05-10 00:55 UTC, Robin Kauffman
Details
emerge --info output (without -fPIC in CFLAGS) (emerge_info.txt,17.38 KB, text/plain)
2011-05-10 00:56 UTC, Robin Kauffman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robin Kauffman 2011-05-10 00:55:43 UTC
Created attachment 272689 [details]
build.log for Ruby 1.9.2

When merging Ruby 1.9.2, the compilation fails unless -fPIC is in my CFLAGS.  I believe my error is:
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.2/../../../../x86_64-pc-linux-gnu/bin/ld: dln.o: relocation R_X86_64_32 against `.rodata.str1.1' can not be used when making a shared object; recompile with -fPIC
dln.o: could not read symbols: Bad value

It may be in part an issue with my toolchain or libc, but I believe it's a problem with the Ruby 1.9.2 build process.  I'll attach my build log (gzipped), and any feedback as to what I may be doing wrong would be greatly appreciated.

Also attached is my emerge --info
Comment 1 Robin Kauffman 2011-05-10 00:56:46 UTC
Created attachment 272691 [details]
emerge --info output (without -fPIC in CFLAGS)
Comment 2 Hans de Graaff gentoo-dev 2012-04-30 08:28:50 UTC
Ruby 1.9.2 is no longer in the tree. Does this still happen for you with ruby 1.9.3? I can't reproduce this for ruby 1.9.3.