Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 366151 - net-analyzer/hping: Add a suid USE flag
Summary: net-analyzer/hping: Add a suid USE flag
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Netmon Herd
URL: http://wiki.hping.org/50
Whiteboard:
Keywords: EBUILD, PATCH
Depends on:
Blocks:
 
Reported: 2011-05-05 22:54 UTC by Hank Leininger
Modified: 2014-07-12 13:51 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Add a 'suid' USE flag to hping-3_pre20051105-r3.ebuild (hping-3-ebuild-suid.patch,843 bytes, patch)
2011-05-05 22:55 UTC, Hank Leininger
Details | Diff
Modify hping so that it allows all functionality when setuid (hping-3_pre20051105-allow-when-suid.patch,6.62 KB, patch)
2011-05-05 22:56 UTC, Hank Leininger
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Hank Leininger 2011-05-05 22:54:12 UTC
hping by design disables certain functionality when setuid root.

I trust me, but I'd rather be able to run hping without su/sudo.

So, here are patches to hping and to the ebuild to add a 'suid' USE flag.

As written, hping will be installed root:wheel mode 4110 (setuid root, but only runnable by members of group wheel).  Perhaps a dedicated group should be used instead.

Reproducible: Always
Comment 1 Hank Leininger 2011-05-05 22:55:35 UTC
Created attachment 272245 [details, diff]
Add a 'suid' USE flag to hping-3_pre20051105-r3.ebuild
Comment 2 Hank Leininger 2011-05-05 22:56:31 UTC
Created attachment 272247 [details, diff]
Modify hping so that it allows all functionality when setuid