Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 365311 - New package: x11-misc/lightdm
Summary: New package: x11-misc/lightdm
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal enhancement with 1 vote (vote)
Assignee: Markos Chandras (RETIRED)
URL: https://bugs.launchpad.net/lightdm/+b...
Whiteboard:
Keywords: EBUILD, InVCS
Depends on:
Blocks:
 
Reported: 2011-04-29 14:53 UTC by Marco Paolone
Modified: 2011-09-17 13:47 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Ebuild changes for lightdm-0.3.2 (ebuild.diff,1007 bytes, patch)
2011-04-29 14:53 UTC, Marco Paolone
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Marco Paolone 2011-04-29 14:53:37 UTC
Created attachment 271559 [details, diff]
Ebuild changes for lightdm-0.3.2

As above. I've made a couple of small changes into ebuild:

Fixed GTK+ dep, since themes require at least GTK+ >= 2.24.3 (as told in /var/log/lightdm/:0-greeter.log once tested this new ebuild).

Added vala USE flag with a couple of variables (extracted from config.log) to let it be correctly found.

It also seems to compile fine with gobject-introspection-0.10.2 (latest stable).
Comment 1 Samuli Suominen (RETIRED) gentoo-dev 2011-04-29 15:04:50 UTC
(this is an automated message based on filtering criteria that matched this
bug)

Hello, The Gentoo Team would like to firstly thank you for your ebuild
submission. We also apologize for not being able to accomendate you on a timely
manor. There are simply too many new packages.

Allow me to use this opportunity to introduce you to Gentoo Sunrise. The
sunrise
overlay[1] is a overlay for Gentoo which we allow trusted users to commit to
and
all users can have ebuilds reviewed by Gentoo devs for entry into the overlay.
So, the sunrise team is suggesting that you look into this and submit your
ebuild to the overlay where even *you* can commit to. =)

Because this is a mass message, we are also asking you to be patient with us.
We
anticipate a large number of requests in a short time. 

Thanks,
On behalf of the Gentoo Sunrise Team,
Jeremy.

[1]: http://www.gentoo.org/proj/en/sunrise/
[2]: http://overlays.gentoo.org/proj/sunrise/wiki/SunriseFaq
Comment 2 Nathan Phillip Brink (binki) (RETIRED) gentoo-dev 2011-04-29 18:35:47 UTC
Please ignore the comment 1 which is invalid because lightdm is in portage.
Comment 3 Kacper Kowalik (Xarthisius) (RETIRED) gentoo-dev 2011-04-29 18:43:20 UTC
(In reply to comment #2)
> Please ignore the comment 1 which is invalid because lightdm is in portage.
No it's not. It was punted ~4h ago, cause it didn't receive deeply needed care and love.
See $URL
Comment 4 Christoph Junghans gentoo-dev 2011-07-27 17:14:19 UTC
lightdm-0.9.2 was released yesterday. I will give it an another try soon as Ubuntu is switching from GDM to LightDM.
Comment 5 Klaus Kusche 2011-08-06 10:00:11 UTC
Another vote for lightdm.
Comment 6 Christoph Junghans gentoo-dev 2011-08-24 19:19:34 UTC
I added lightdm-0.9.2 to my overlay, but it is also available from 
calculate and betagarden overlay:
<http://gpo.zugaina.org/x11-misc/lightdm>
Comment 7 Markos Chandras (RETIRED) gentoo-dev 2011-09-13 15:35:09 UTC
I will take it
Comment 8 Markos Chandras (RETIRED) gentoo-dev 2011-09-13 16:50:11 UTC
(In reply to comment #6)
Could you please explain me why you need the gtk patch? Did you try to contact upstream about this patch?
Comment 9 Christoph Junghans gentoo-dev 2011-09-13 17:54:35 UTC
(In reply to comment #8)
> (In reply to comment #6)
> Could you please explain me why you need the gtk patch? Did you try to contact
> upstream about this patch?
Two reasons:
-support >=gtk-2.0 instead of gtk-3.0 only
-allow to disable gtk greeter even if gtk is installed (in the case one only wants qt4 greeter)
Comment 10 Markos Chandras (RETIRED) gentoo-dev 2011-09-13 22:20:42 UTC
Ok but I think the patch is not complete. A variable named $compile_liblightdm_gtk should also be defined so it can be used in the final $echo message in configure.ac. 

Did you try to talk to upstream about your patch?
Comment 11 Christoph Junghans gentoo-dev 2011-09-14 07:57:09 UTC
(In reply to comment #10)
> Ok but I think the patch is not complete. A variable named
> $compile_liblightdm_gtk should also be defined so it can be used in the final
> $echo message in configure.ac.
No, there is already "GTK+ Greeter: yes/no" in the output. For qt4 one can build the lightdm-qt lib without building the qt4 greeter (even if I don't know if this combination makes sense). For gtk there is only the greeter.
 
> Did you try to talk to upstream about your patch?
No, as I didn't change anything in the "real code" and making gtk+ optional is more a gentoo thing, so I didn't want to bother them. If we are planing to keep the patch I will send it to them.
Comment 12 Markos Chandras (RETIRED) gentoo-dev 2011-09-14 08:02:46 UTC
(In reply to comment #11)
Yes you are right. Well yes I plan to keep the patch around so if you want to talk to them that would be great :)
Comment 13 Christoph Junghans gentoo-dev 2011-09-14 13:44:02 UTC
(In reply to comment #12)
> (In reply to comment #11)
> Yes you are right. Well yes I plan to keep the patch around so if you want to
> talk to them that would be great :)
Done:
<https://bugs.launchpad.net/lightdm/+bug/849980>
Comment 14 Markos Chandras (RETIRED) gentoo-dev 2011-09-14 15:37:52 UTC
Currently there is this bug [1] that prevents me from committing this to portage tree. Moreover, I am working on a better gtk-greeter configuration ( possibly a gentoo background )

[1] https://bugs.launchpad.net/lightdm/+bug/818852
Comment 15 Markos Chandras (RETIRED) gentoo-dev 2011-09-14 15:45:12 UTC
(In reply to comment #13)

There is a minor issue with your patch. >= gtk+-2.0 has to be replaced with gtk+-2.0 >= 2.0 :)
Comment 16 Christoph Junghans gentoo-dev 2011-09-14 18:15:14 UTC
(In reply to comment #15)
> (In reply to comment #13)
> 
> There is a minor issue with your patch. >= gtk+-2.0 has to be replaced with
> gtk+-2.0 >= 2.0 :)

Actually the problem is slightly more complicated as gtk+-3.0 comes with a different pkg-config file than gtk+-2.0.

I updated the patch in cj-overlay.
Comment 17 Markos Chandras (RETIRED) gentoo-dev 2011-09-17 13:47:53 UTC
0.9.7 is now in CVS but it will remain masked until the $URL bug is resolved. Thank you all