Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 364475 - net-im/skype-2.2.0.25 - skype download URL is slow
Summary: net-im/skype-2.2.0.25 - skype download URL is slow
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal minor (vote)
Assignee: Gentoo net-im Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-22 11:28 UTC by Max Steel
Modified: 2011-05-06 05:32 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Max Steel 2011-04-22 11:28:40 UTC
--2011-04-22 13:08:38--  (Try: 3)  http://download.skype.com/linux/skype-2.2.0.25.tar.bz2
Connecting to download.skype.com|212.72.53.130|:80... connect.
HTTP requestion sended, waiting for Answer... 
Read error (Connection timed out) at header.


After i surfed to skype.com and choose download the next download-try is succes.

--2011-04-22 13:09:38--  http://download.skype.com/linux/skype-2.2.0.25.tar.bz2
Auflösen des Hostnamen »download.skype.com«.... 78.141.179.2
Verbindungsaufbau zu download.skype.com|78.141.179.2|:80... verbunden.
HTTP Anforderung gesendet, warte auf Antwort... 200 OK
Länge: 23057633 (22M) [application/octet-stream]
In »»/usr/portage/distfiles/skype-2.2.0.25.tar.bz2«« speichern.

100%[=================================================================================================================================>] 23.057.633  5,02M/s   in 4,5s    

2011-04-22 13:09:54 (4,86 MB/s) - »»/usr/portage/distfiles/skype-2.2.0.25.tar.bz2«« gespeichert [23057633/23057633]

So the Ebuild needs fetch-restriction.

Reproducible: Always

Steps to Reproduce:
1.emerge -a skype
2.surfing to http://www.skype.com/intl/de/get-skype/on-your-computer/linux/
3.Press download, but not download it
4.emerge -a skype
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2011-04-22 14:27:27 UTC
cvs/gentoo-x86/net-im/skype $ GENTOO_MIRRORS= ebuild skype-2.2.0.25.ebuild fetch 
Appending /newaches/gentoo/cvs/gentoo-x86 to PORTDIR_OVERLAY...
>>> Downloading 'http://download.skype.com/linux/skype-2.2.0.25.tar.bz2'
--2011-04-22 16:26:30--  http://download.skype.com/linux/skype-2.2.0.25.tar.bz2
Resolving download.skype.com... 130.117.72.44
Connecting to download.skype.com|130.117.72.44|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 23057633 (22M) [application/octet-stream]
Saving to: `/aches/distfiles/skype-2.2.0.25.tar.bz2'

100%[==========================================================================================>] 23,057,633  5.67M/s   in 3.7s    

2011-04-22 16:26:34 (6.02 MB/s) - `/aches/distfiles/skype-2.2.0.25.tar.bz2' saved [23057633/23057633]

 * skype-2.2.0.25.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                                    [ ok ]
 * checking ebuild checksums ;-) ...                                                                                         [ ok ]
 * checking auxfile checksums ;-) ...                                                                                        [ ok ]
 * checking miscfile checksums ;-) ...                                                                                       [ ok ]

Works for me straight away, oddly.
Comment 2 Max Steel 2011-04-23 11:04:48 UTC
straight.



$ LC_ALL=C GENTOO_MIRRORS= ebuild /usr/portage/net-im/skype/skype-2.2.0.25.ebui
>>> Downloading 'http://download.skype.com/linux/skype-2.2.0.25.tar.bz2'                                                                                       
--2011-04-23 12:50:16--  http://download.skype.com/linux/skype-2.2.0.25.tar.bz2                                                                                
Resolving download.skype.com (download.skype.com)... 130.117.72.45                                                                                             
Connecting to download.skype.com (download.skype.com)|130.117.72.45|:80... connected.                                                                          
HTTP request sent, awaiting response... Read error (Connection timed out) in headers.                                                                          
Retrying.


--2011-04-23 12:51:17--  (try: 2)  http://download.skype.com/linux/skype-2.2.0.25.tar.bz2
Connecting to download.skype.com (download.skype.com)|130.117.72.45|:80... connected.    
HTTP request sent, awaiting response... Read error (Connection timed out) in headers.
Retrying.
                                                                   
--2011-04-23 12:52:20--  (try: 3)  http://download.skype.com/linux/skype-2.2.0.25.tar.bz2
Connecting to download.skype.com (download.skype.com)|130.117.72.45|:80... connected.    
HTTP request sent, awaiting response... Read error (Connection timed out) in headers.
Giving up.

!!! Couldn't download 'skype-2.2.0.25.tar.bz2'. Aborting.

straight, The skype server is very slow for downloading (to slow for wget).
Comment 3 Max Steel 2011-04-23 11:05:29 UTC
with firefox (and a cup of tee) i can download it.
Comment 4 SpanKY gentoo-dev 2011-05-06 05:32:51 UTC
nothing we can do about poor service connections to the server.  we cant mirror the file.  simply try again later, find another d/l location yourself, or dont use skype.  if you dont like these options, complain to skype.

fwiw, wget works just fine for me on first try:
$ wget http://download.skype.com/linux/skype-2.2.0.25.tar.bz2 -P /usr/portage/distfiles/
--2011-05-06 01:34:26--  http://download.skype.com/linux/skype-2.2.0.25.tar.bz2
Resolving download.skype.com... 130.117.72.44
Connecting to download.skype.com|130.117.72.44|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 23057633 (22M) [application/octet-stream]
Saving to: “/usr/portage/distfiles/skype-2.2.0.25.tar.bz2”

100%[==========================================>] 23,057,633   696K/s   in 35s

2011-05-06 01:35:02 (650 KB/s) - “/usr/portage/distfiles/skype-2.2.0.25.tar.bz2” saved [23057633/23057633]