Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 364431 - Disable preserve-libs or provide special handling for downgrades
Summary: Disable preserve-libs or provide special handling for downgrades
Status: RESOLVED DUPLICATE of bug 373341
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Enhancement/Feature Requests (show other bugs)
Hardware: All All
: Normal normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on: 373341
Blocks: preserve-libs 364425
  Show dependency tree
 
Reported: 2011-04-22 02:57 UTC by Zac Medico
Modified: 2012-04-29 07:51 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zac Medico gentoo-dev 2011-04-22 02:57:27 UTC
When a library is downgraded, it's expected for new builds to link a preserved library with a version that is newer than the one that we are trying to downgrade to. Therefore, it might make sense to have FEATURES=preserve-libs skip library preservation during downgrades, or provide some other form(s) of special handling.
Comment 1 Zac Medico gentoo-dev 2011-06-28 14:10:43 UTC
Hopefully we can solve this as described in bug 373341 by making sure that the soname symlinks point to the desired version to link against.
Comment 2 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2012-04-29 07:21:24 UTC
(In reply to comment #1)
> Hopefully we can solve this as described in bug 373341 by making sure that
> the soname symlinks point to the desired version to link against.

I may be wrong but I think it fixed it indeed.
Comment 3 Zac Medico gentoo-dev 2012-04-29 07:51:31 UTC

*** This bug has been marked as a duplicate of bug 373341 ***