Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 364099 - IRQ 16 unexpected disabling
Summary: IRQ 16 unexpected disabling
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Doug Goldstein (RETIRED)
Depends on:
Reported: 2011-04-19 07:03 UTC by Andrey
Modified: 2012-07-14 20:09 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

kernel config (kernel,79.89 KB, text/plain)
2011-04-19 07:03 UTC, Andrey
xorg.conf (xorg,1.64 KB, text/plain)
2011-04-19 07:04 UTC, Andrey
dmesg output just loaded system (dmesg,61.20 KB, text/plain)
2011-05-01 07:14 UTC, Andrey

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey 2011-04-19 07:03:15 UTC
I got strange problem when playing video files, any formats.
Video playing goes very slowly, freezing. And this behavior occurs sometimes, when
system just loaded it used to play normally. Then usually after sometime, randomly,
video starting plays slowly. And when player window on screen - all gnome interface
freezing- windows moving, folders opening, menu browsing all slow, but when player
window hides everything becomes normal. Movies plays same in 3 players - vlc,
mplayer, totem. I tried disable vdpau and use xv- no effect.
I took a screenshot and it shows that - when movie plays X root consuming 100% of
CPU, and system monitor shows that one cpu periodically consumes 100%, so only
one core loaded.
 And this is live-time shooting

Reproducible: Always

Steps to Reproduce:
1. Leave system idle for some time

snich@localhost ~ $ emerge --info
Portage (default/linux/amd64/10.0/desktop/gnome, gcc-4.4.5, glibc-2.11.3-r0, 2.6.38-gentoo-r1 x86_64)
System uname: Linux-2.6.38-gentoo-r1-x86_64-Intel-R-_Core-TM-_i7-2600K_CPU_@_3.40GHz-with-gentoo-2.0.2
Timestamp of tree: Sun, 10 Apr 2011 20:30:01 +0000
app-shells/bash:     4.1_p9
dev-lang/python:     2.6.6-r1, 2.7.1-r1, 3.1.3-r1
dev-util/cmake:      2.8.4
sys-apps/baselayout: 2.0.2
sys-apps/openrc:     0.8.0
sys-apps/sandbox:    2.4
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.5
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers: (sys-kernel/linux-headers)
CFLAGS="-O2 -march=native -mno-avx -pipe"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=native -mno-avx -pipe"
FEATURES="assume-digests binpkg-logs distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="ru en"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/var/lib/layman/ohnobinki /var/lib/layman/sunrise /var/lib/layman/poly-c"
USE="64bit X a52 aac acl acpi alsa amd64 avi bluetooth branding bzip2 cairo cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr eds emboss encode evo exif fam firefox flac fortran gdbm gdu gif gnome gnome-keyring gpm gstreamer gtk iconv jpeg lcms ldap libnotify mad mikmod mmx mng modules mp3 mp4 mpeg mudflap multilib nautilus ncurses networkmanager nls nptl nptlonly nvidia ogg opengl openmp pam pango pcre pdf perl pmu png policykit ppds pppd python qt3support readline samba sdl session slang smp spell sse sse2 sse3 ssl startup-notification svg sysfs tcpd tiff truetype udev unicode usb userlocales utf8 v4l2 vorbis wifi x264 xcb xcomposite xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="ru en" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" SANE_BACKENDS="pixma" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Comment 1 Andrey 2011-04-19 07:03:54 UTC
Created attachment 270485 [details]
kernel config
Comment 2 Andrey 2011-04-19 07:04:58 UTC
Created attachment 270487 [details]
Comment 3 Andrey 2011-04-19 07:07:12 UTC
Video card: Asus Nvidia GTX 570 connects via HDMI to Monitor FX2490HD
Driver: 260.19.44
Comment 4 Jeroen Roovers (RETIRED) gentoo-dev 2011-04-19 13:34:21 UTC
Is it just vlc that's doing this? How about mplayer or xine? It would be nice to pinpoint the software that's failing here - kernel/nvidia-drivers/?
Comment 5 Andrey 2011-04-19 20:05:17 UTC
I found one interesting thing- just for test i have installed all gstreamer plugins and tried play movies in totem and they were played fine, but when same movies opened in vlc, mplayer - slowdowns. Ok, let say it is players issue, but one thing brake it - when i start Windows games in Wine - menus and overall games slow, slides. As i said before if i restart system all becomes normal again. Seems like it happens after some idle period because when i'm using PC it not used to arise. Maybe it is somehow related to CPU scaling.
Comment 6 Jeroen Roovers (RETIRED) gentoo-dev 2011-04-21 02:58:18 UTC
OK, let's blame Nvidia again. :-P
Comment 7 Andrey 2011-05-01 06:59:08 UTC
After long fighting seems like i found this thing which cause this trouble- SSD hard drive!
 How i found- I have installed Ubuntu 11.04 and proprietary Nvidia drivers, then left PC idle for night. After opened some video files and everything was ok, but when i oppenned /boot partion where is Gentoo kernel live- PC became slow, of course i tested video- slow same like in Gentoo.
 And dmesg output shows this: 
[28697.852920] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)
[28730.150690] irq 16: nobody cared (try booting with the "irqpoll" option)
[28730.150692] Pid: 0, comm: swapper Tainted: P            2.6.38-8-generic #42-Ubuntu
[28730.150693] Call Trace:
[28730.150694]  <IRQ>  [<ffffffff810d511b>] ? __report_bad_irq.clone.2+0x2b/0xa0
[28730.150700]  [<ffffffff810d551a>] ? note_interrupt+0x19a/0x1e0
[28730.150701]  [<ffffffff810d640d>] ? handle_fasteoi_irq+0xdd/0x110
[28730.150703]  [<ffffffff8100e9c2>] ? handle_irq+0x22/0x40
[28730.150706]  [<ffffffff815caebd>] ? do_IRQ+0x5d/0xe0
[28730.150707]  [<ffffffff815c3213>] ? ret_from_intr+0x0/0x15
[28730.150708]  <EOI>  [<ffffffff814a3af6>] ? poll_idle+0x46/0x80
[28730.150711]  [<ffffffff814a3ac3>] ? poll_idle+0x13/0x80
[28730.150713]  [<ffffffff814a4e89>] ? menu_select+0x149/0x340
[28730.150714]  [<ffffffff814a3bda>] ? cpuidle_idle_call+0xaa/0x1b0
[28730.150717]  [<ffffffff8100a266>] ? cpu_idle+0xa6/0xf0
[28730.150718]  [<ffffffff815a9205>] ? rest_init+0x75/0x80
[28730.150721]  [<ffffffff81acac8b>] ? start_kernel+0x3f5/0x400
[28730.150723]  [<ffffffff81aca388>] ? x86_64_start_reservations+0x132/0x136
[28730.150724]  [<ffffffff81aca253>] ? zap_identity_mappings+0x3e/0x41
[28730.150726]  [<ffffffff81aca458>] ? x86_64_start_kernel+0xcc/0xdb
[28730.150726] handlers:
[28730.150727] [<ffffffffa007d020>] (rtl8169_interrupt+0x0/0x250 [r8169])
[28730.150733] [<ffffffffa05fce90>] (nv_kern_isr+0x0/0x80 [nvidia])
[28730.150818] Disabling IRQ #16
[28877.369428] EXT4-fs (sda3): mounted filesystem with ordered data mode. Opts: (null)
sda - is Intel SSD hard drive
before its mounts video played fine.
Comment 8 Andrey 2011-05-01 07:12:29 UTC
some related info from dmesg when system boots:
[   11.668623] ata1: COMRESET failed (errno=-16)
[   11.973263] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[   11.973608] ata1.00: ATA-7: INTEL SSDSA2M080G2GC, 2CV102HD, max UDMA/133
[   11.973610] ata1.00: 156301488 sectors, multi 16: LBA48 NCQ (depth 31/32)
[   11.973934] ata1.00: configured for UDMA/133
[   11.974017] scsi 0:0:0:0: Direct-Access     ATA      INTEL SSDSA2M080 2CV1 PQ: 0 ANSI: 5
[   11.974129] sd 0:0:0:0: [sda] 156301488 512-byte logical blocks: (80.0 GB/74.5 GiB)
[   11.974150] sd 0:0:0:0: [sda] Write Protect is off
[   11.974151] sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
[   11.974157] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
Comment 9 Andrey 2011-05-01 07:14:39 UTC
Created attachment 271719 [details]
dmesg output just loaded system
Comment 10 Andrey 2011-05-01 07:19:36 UTC
Forgot to say:
 Gentoo installed on SSD hard drive
 Ubuntu installed on separate not SSD hard drive
Comment 11 Andrey 2011-05-01 09:48:19 UTC
I caught almost same output on gentoo, after that video slow:
    [ 6386.385383] irq 16: nobody cared (try booting with the "irqpoll" option)
    [ 6386.385385] Pid: 0, comm: swapper Tainted: P            2.6.38-gentoo-r3 #3
    [ 6386.385386] Call Trace:
    [ 6386.385387]  <IRQ>  [<ffffffff8108ff66>] ? __report_bad_irq+0x26/0xa0
    [ 6386.385391]  [<ffffffff8109016c>] ? note_interrupt+0x18c/0x1d0
    [ 6386.385393]  [<ffffffff81090add>] ? handle_fasteoi_irq+0xad/0xe0
    [ 6386.385395]  [<ffffffff8100555d>] ? handle_irq+0x1d/0x30
    [ 6386.385396]  [<ffffffff81004a78>] ? do_IRQ+0x58/0xe0
    [ 6386.385398]  [<ffffffff8174c793>] ? ret_from_intr+0x0/0xe
    [ 6386.385398]  <EOI>  [<ffffffff81450065>] ? acpi_hw_read_multiple+0x2a/0x63
    [ 6386.385402]  [<ffffffff8145fa81>] ? acpi_idle_do_entry+0x36/0x57
    [ 6386.385403]  [<ffffffff8145faf2>] ? acpi_idle_enter_c1+0x50/0x99
    [ 6386.385405]  [<ffffffff8157a4a2>] ? menu_select+0x142/0x350
    [ 6386.385407]  [<ffffffff81579502>] ? cpuidle_idle_call+0x82/0xf0
    [ 6386.385408]  [<ffffffff81001ee9>] ? cpu_idle+0xa9/0x100
    [ 6386.385410]  [<ffffffff8173704d>] ? rest_init+0x6d/0x80
    [ 6386.385412]  [<ffffffff81a3ed7e>] ? start_kernel+0x3a7/0x3b2
    [ 6386.385414]  [<ffffffff81a3e321>] ? x86_64_start_reservations+0x131/0x135
    [ 6386.385415]  [<ffffffff81a3e417>] ? x86_64_start_kernel+0xf2/0xf9
    [ 6386.385416] handlers:
    [ 6386.385417] [<ffffffff81502c80>] (usb_hcd_irq+0x0/0x70)
    [ 6386.385420] [<ffffffffa0084bc0>] (rtl8169_interrupt+0x0/0x3a0 [r8169])
    [ 6386.385423] [<ffffffffa05e3d40>] (nv_kern_isr+0x0/0x80 [nvidia])
    [ 6386.385481] Disabling IRQ #16
Comment 12 Doug Goldstein (RETIRED) gentoo-dev 2012-07-14 19:21:26 UTC
Your chipset has some IRQ problems. Have you tried to add irqpoll to your boot line as suggested? That might fix the issue. Also a newer kernel and a newer version of nvidia-drivers might improve some things. But at the end of the day, your system has IRQ problems. You might have some hard wired IRQs in your BIOS or some such as well along with a non-PnP OS set in the BIOS.
Comment 13 Andrey 2012-07-14 20:09:15 UTC
(In reply to comment #12)
> Your chipset has some IRQ problems. Have you tried to add irqpoll to your
> boot line as suggested? That might fix the issue. Also a newer kernel and a
> newer version of nvidia-drivers might improve some things. But at the end of
> the day, your system has IRQ problems. You might have some hard wired IRQs
> in your BIOS or some such as well along with a non-PnP OS set in the BIOS.

 I got rid this buggy B2 rev chipset 6 months ago, because after few days of using SATA 3 controller stop working at all(not only me many people had same issue). Now i have Asus P8Z68 B3 rev motherboard+ 3.3.6-zen kernel+ nvidia 302.11 no any problems.

Off:Too pity that so famous brand sometimes releases raw products without proper testing in order to get faster income!