Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 363675 - [ICE] sys-devel/gcc-4.4.5 - emake failed with bootstrap-lean
Summary: [ICE] sys-devel/gcc-4.4.5 - emake failed with bootstrap-lean
Status: RESOLVED DUPLICATE of bug 256766
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Toolchain Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-15 09:15 UTC by Marc Richter
Modified: 2011-07-05 06:24 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
The bzip2 compressed buildlog of the failed compile (build.log.bz2,86.60 KB, application/x-bzip2)
2011-04-15 09:20 UTC, Marc Richter
Details
Bzip'ed tar of build log, system environment, etc. (build.tar.bz2,82.01 KB, application/octet-stream)
2011-05-31 16:06 UTC, Willard Dawson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Richter 2011-04-15 09:15:53 UTC
When emerging sys-devel/gcc-4.4.5 , it fails with the lines, described in the Field "Actual Results".

Reproducible: Always

Steps to Reproduce:
Nothing, besides "emerge sys-devel/gcc-4.4.5".
Actual Results:  
/var/tmp/portage/sys-devel/gcc-4.4.5/work/build/./prev-gcc/xgcc -B/var/tmp/portage/sys-devel/gcc-4.4.5/work/build/./prev-gcc/ -B/usr/x86_64-pc-linux-gnu/bin/ -c -DEFAULT_PIE_SSP -DEFAULT_RELRO -DEFAULT_BIND_NOW   -O2 -pipe -march=core2 -DIN_GCC   -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -Wcast-qual -Wold-style-definition -Wc++-compat -Wmissing-format-attribute -pedantic -Wno-long-long -Wno-variadic-macros -Wno-overlength-strings   -DHAVE_CONFIG_H -I. -I. -I/var/tmp/portage/sys-devel/gcc-4.4.5/work/gcc-4.4.5/gcc -I/var/tmp/portage/sys-devel/gcc-4.4.5/work/gcc-4.4.5/gcc/. -I/var/tmp/portage/sys-devel/gcc-4.4.5/work/gcc-4.4.5/gcc/../include -I/var/tmp/portage/sys-devel/gcc-4.4.5/work/gcc-4.4.5/gcc/../libcpp/include  -I/var/tmp/portage/sys-devel/gcc-4.4.5/work/gcc-4.4.5/gcc/../libdecnumber -I/var/tmp/portage/sys-devel/gcc-4.4.5/work/gcc-4.4.5/gcc/../libdecnumber/bid -I../libdecnumber    /var/tmp/portage/sys-devel/gcc-4.4.5/work/gcc-4.4.5/gcc/cfgbuild.c -o cfgbuild.o                                                                      {standard input}: Assembler messages:                                                                       {standard input}:73965: Warning: end of file not at end of a line; newline inserted                                                                        {standard input}:73986: Error: no such instruction: `mo'                                                                            {standard input}:73986: Error: open CFI at the end of file; missing .cfi_endproc directive                                                                       xgcc: Internal error: Killed (program cc1)                               

Expected Results:  
gcc should compile and install fine.

jb-gen2-0001 ~ # emerge --info
Portage 2.1.9.42 (hardened/linux/amd64, gcc-4.4.4, glibc-2.11.3-r0, 2.6.38.2-jb1 x86_64)
=================================================================
System uname: Linux-2.6.38.2-jb1-x86_64-Intel-R-_Xeon-R-_CPU_L5630_@_2.13GHz-with-gentoo-1.12.14
Timestamp of tree: Fri, 15 Apr 2011 07:45:01 +0000
app-shells/bash:     4.1_p9
dev-lang/python:     2.6.6-r2, 2.7.1-r1, 3.1.3-r1
dev-util/cmake:      2.8.4
sys-apps/baselayout: 1.12.14-r1
sys-apps/sandbox:    2.4
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.4-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
sys-kernel/linux-headers: 2.6.36.1
virtual/os-headers:  0
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA dlj-1.1"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=core2"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=core2"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv"
FFLAGS=""
GENTOO_MIRRORS="http://ftp-stud.hs-esslingen.de/pub/Mirrors/gentoo/ http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ http://ftp.uni-erlangen.de/pub/mirrors/gentoo/"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de en"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
USE="acl amd64 apache2 bash-completion bcmath berkdb bzip2 cli cracklib crypt ctype cups curl cxx dri exif fam ftp gd-external gdbm gif gnutls gpm gzip hardened hash iconv imap imlib inifile innodb jadetex jpeg jpeg2k justify lame latex libwww lzo maildir mhash mime mmx mmxext mng modules mp3 mp4 mpeg mudflap multilib mysql mysqli ncurses netpbm nls nptl nptlonly ogg openmp pae pam pcre pdf pdo perl php plotutils png posix pppd python readline rss sasl session snmp soap sockets sse sse2 ssl subversion suhosin sysfs syslog szip tcpd threads tidy tiff truetype unicode urandom vhosts vim-syntax vorbis wmf xattr xml xmlreader xmlrpc xmlwriter xorg zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default auth_digest authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id usertrack vhost_alias" APACHE2_MPMS="prefork" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de en" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY

jb-gen2-0001 ~ # emerge -pqv =sys-devel/gcc-4.4.5
[ebuild     U ] sys-devel/gcc-4.4.5 [4.4.4-r2] USE="hardened* mudflap (multilib) nls nptl openmp (-altivec) -bootstrap -build -doc (-fixed-point) -fortran* -gcj -graphite -gtk (-libffi) -multislot (-n32) (-n64) -nocxx -nopie -nossp -objc -objc++ -objc-gc -test -vanilla"

I will attach the build.log later.
Comment 1 Marc Richter 2011-04-15 09:20:03 UTC
Created attachment 270039 [details]
The bzip2 compressed buildlog of the failed compile
Comment 2 Marc Richter 2011-05-06 07:46:38 UTC
Hi there,
I don't want to hustle anyone, but has there been any progress or is there any further information needed to clarify this bug? I can provide you with a login to my server, if that helps, since it is a virtual machine without any sensitive information on it.
Comment 3 Marc Richter 2011-05-17 14:08:28 UTC
Hello everybody,

I'm a little afraid that this bug is out of focus, since I'm the only one who adds anything to it's log for over a month now.
A Major feature is broken on a productive server in a way that we cannot make a required sysupdate. It would be nice if someone confirms that he/she can reproduce the error or ask for further information if not.

Thank you.
Comment 4 Willard Dawson 2011-05-31 16:02:49 UTC
(In reply to comment #3)
> Hello everybody,
> 
> I'm a little afraid that this bug is out of focus, since I'm the only one who
> adds anything to it's log for over a month now.
> A Major feature is broken on a productive server in a way that we cannot make a
> required sysupdate. It would be nice if someone confirms that he/she can
> reproduce the error or ask for further information if not.
> 
> Thank you.

I am also having this issue.  I'll attach my build log and other info momentarily.
Comment 5 Willard Dawson 2011-05-31 16:06:36 UTC
Created attachment 275379 [details]
Bzip'ed tar of build log, system environment, etc.
Comment 6 Marc Richter 2011-05-31 18:01:46 UTC
This issue is now reported for 1,5 months. gcc is indeed one of the most important applications in a sourcecode based operating system. I provided not only a complete log of the build process, but also offered a root login to a system where this is reproduceable happening.
I have to say that I'm very disappointed of this bugs history, since noone seems to even ask for further details.
Comment 7 Marc Richter 2011-05-31 19:34:52 UTC
Since noone seems to know what this might be, I reported this issue to the GCC developers at http://gcc.gnu.org/bugzilla/show_bug.cgi?id=49245
Comment 8 Marc Richter 2011-05-31 22:32:32 UTC
Hi there,
since nobody felt responsible for this issue for more then 1,5 months now, I asked the gcc developers for help.
I'm still _very_ unhappy with how the Gentoo community has (or better: has not) handled this issue. This is a blocking error in one of the most important core applications of Gentoo Linux and _no one_ even asked for further details on it or even tried to have a look at for more then 1,5 months now! At last, it seems like this from the bug's history.

In the opposite, the guys at gcc even _solved_ this issue after 3 minutes 42 seconds! Not reacted to: SOLVED! This even increased my disappointment in Gentoo. No one can expect to have everything solved right in time, but I think one might expect that someone cares at last after such a long time.
If you want to have a look at the resolved issue, please have a look at http://gcc.gnu.org/bugzilla/show_bug.cgi?id=49245 .

The reason for this to happen is, that my machine seems to ran out of memory and the OOM killer kicked in. Since I'm not a developer, that is something I couldn't see from the provided logs  and output.
The solution is to simply remove the "-pipe" from the CFLAGS.

I hope this helps the other ones, also having this issue.
Comment 9 Francisco Blas Izquierdo Riera gentoo-dev 2011-06-28 16:25:17 UTC
(In reply to comment #8)
> I hope this helps the other ones, also having this issue.
It helped a lot, thanks :D
Comment 10 SpanKY gentoo-dev 2011-07-05 06:24:17 UTC
(In reply to comment #8)

it's a volunteer system.  if you dont like how it works, then step up and help.  expecting people to help you isnt how things work.

*** This bug has been marked as a duplicate of bug 256766 ***