Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 363313 - [gnome-overlay] app-misc/tracker hangs with nautilus-3
Summary: [gnome-overlay] app-misc/tracker hangs with nautilus-3
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Freedesktop bugs
URL:
Whiteboard:
Keywords: InVCS
: 361209 (view as bug list)
Depends on:
Blocks: gnome3
  Show dependency tree
 
Reported: 2011-04-12 16:05 UTC by Lorenzo Cabrini
Modified: 2012-02-12 14:11 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (emerge-info,4.72 KB, text/plain)
2011-04-13 12:11 UTC, Lorenzo Cabrini
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lorenzo Cabrini 2011-04-12 16:05:41 UTC
I am running Gnome3, and it seems libnautilus-tracker-tags is built against _both_ gtk2 and gtk3. I'm not sure if this is the cause of the problem, but I found https://bugzilla.redhat.com/show_bug.cgi?id=662798 which suggests that it may be.

Reproducible: Always

Steps to Reproduce:
1. Open Nautilus
2. Right-click on any object
3. Select "Propertà" (Properties) or "Tags" from context menu
Actual Results:  
Nautilus freezes. Clicking the close button will bring up dialog to force close nautilus.

Starting nautilus from shell doesn't report anything unusual.

Expected Results:  
The properties or tags dialog should pop up.

Notice: I am running gnome3 from the gnome overlay. 

Partial output of ldd:
        libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0x00007f2579a3f000)
	libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0x00007f257978d000)
	(0x00007f2579583000)
	libgtk-3.so.0 => /usr/lib/libgtk-3.so.0 (0x00007f2578f8e000)
	libgdk-3.so.0 => /usr/lib/libgdk-3.so.0 (0x00007f2578d14000)
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2011-04-12 18:53:17 UTC
1) Please post your `emerge --info' too.
2) strace output or a gdb backtrace from the running program would be nice.
Comment 2 Lorenzo Cabrini 2011-04-13 12:11:13 UTC
Created attachment 269803 [details]
emerge --info
Comment 3 Lorenzo Cabrini 2011-04-13 12:25:39 UTC
Sorry, I read the "this is where you put emerge --info" only *after* having uploaded as an attachment.

gdb doesn't really give anything out of the ordinary. I'm not very familiar with strace, but I emerged it and ran it. When I try to select "tags" or "properties" from the nautilus context menu for an object, strace output freezes at:
futex(0x19d2084, FUTEX_WAIT_PRIVATE, 1, NULL

strace gives a lot of output. I can attach it, but how much output? Should I attach all the output or just a part?

I should also add that moving libnautilus-tracker-tags.so out of /usr/lib/nautilus/extensions-3.0 makes nautilus behave well (but obviously without tagging).
Comment 4 Jeroen Roovers (RETIRED) gentoo-dev 2011-04-13 16:03:11 UTC
(In reply to comment #3)
> Sorry, I read the "this is where you put emerge --info" only *after* having
> uploaded as an attachment.

It's mentioned in the bug reporting guide[1] which the bugzilla front page links to[2]. :)

> gdb doesn't really give anything out of the ordinary. I'm not very familiar
> with strace, but I emerged it and ran it. When I try to select "tags" or
> "properties" from the nautilus context menu for an object, strace output
> freezes at:
> futex(0x19d2084, FUTEX_WAIT_PRIVATE, 1, NULL
> 
> strace gives a lot of output. I can attach it, but how much output? Should I
> attach all the output or just a part?

Just everything? Compress the file if it exceeds the bugzilla limit.

> I should also add that moving libnautilus-tracker-tags.so out of
> /usr/lib/nautilus/extensions-3.0 makes nautilus behave well (but obviously
> without tagging).

[1] http://www.gentoo.org/doc/en/bugzilla-howto.xml
[2] https://bugzilla.gentoo.org/
Comment 5 Gilles Dartiguelongue gentoo-dev 2011-04-13 16:36:05 UTC
this is to be expected. Don't mix up plugins for gtk2 and gtk3 apps.
Comment 6 Gilles Dartiguelongue gentoo-dev 2011-04-14 12:06:26 UTC
*** Bug 361209 has been marked as a duplicate of this bug. ***
Comment 7 Gilles Dartiguelongue gentoo-dev 2011-04-14 12:28:59 UTC
+  14 Apr 2011; Gilles Dartiguelongue <eva@gentoo.org> tracker-0.8.17.ebuild,
+  -tracker-0.10.5.ebuild, -tracker-0.10.6.ebuild, tracker-0.10.8.ebuild:
+  Restrict nautilus version, bug #363313.

Thanks for reporting.