Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 363283 - [science overlay] sci-chemistry/mgltools-1.5.4 doesn't work with Python 2.7 (__debug__ assignment)
Summary: [science overlay] sci-chemistry/mgltools-1.5.4 doesn't work with Python 2.7 (...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All All
: Normal normal (vote)
Assignee: Gentoo Science Related Packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: python-2.7
  Show dependency tree
 
Reported: 2011-04-12 12:10 UTC by urcindalo
Modified: 2011-04-13 09:19 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description urcindalo 2011-04-12 12:10:51 UTC
After the upgrade to pyhton-2.7 on my amd64 box and the removal of python-2.6 mgltools-autodocktools-1.5.4-r2 refuses to launch. I reported the problem upstream in the forums.
Would it be possible to use python-2.6 for the whole mgltools package? It was working beautifully with python-2.6.

===
$ runAdt
Run AutoDockTools from /usr/lib64/python2.7/site-packages/AutoDockTools
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/AutoDockTools/__init__.py", line 370, in runADT
    from Pmv.moleculeViewer import MoleculeViewer
  File "/usr/lib64/python2.7/site-packages/Pmv/moleculeViewer.py", line 21, in <module>
    from ViewerFramework.VF import ViewerFramework, GeomContainer
  File "/usr/lib64/python2.7/site-packages/ViewerFramework/VF.py", line 263
    self.__debug__ = 0
SyntaxError: cannot assign to __debug__
hit enter to continue
===

Reproducible: Always
Comment 1 urcindalo 2011-04-12 13:34:46 UTC
The problem is gone and the program launches after commenting with a # the 263th line in /usr/lib64/python2.7/site-packages/ViewerFramework/VF.py

Is it possible to include a patch for this?
Even better, is it possible to update also the ebuilds so that they install the latest 1.5.4 revision 28 instead of the current revision 24?
Comment 2 Justin Lecher gentoo-dev 2011-04-12 14:21:50 UTC
Thanks for your effort. Do we have access to some sort of VCS of upstream? or are they willed to release a new version?
Comment 3 Justin Lecher gentoo-dev 2011-04-12 14:22:34 UTC
Writting that in an eclass is on my todo. Probably, we should restrict py 2.7 here first.
Comment 4 Justin Lecher gentoo-dev 2011-04-12 16:13:22 UTC
I bumped to latest version. You have to reemerge all packages. But still the py2.7 is there.
Comment 5 Justin Lecher gentoo-dev 2011-04-12 16:43:47 UTC
+*mgltools-viewer-framework-1.5.4-r2 (12 Apr 2011)
+
+  12 Apr 2011; Justin Lecher <jlec@gentoo.org>
+  -mgltools-viewer-framework-1.5.4-r1.ebuild,
+  +mgltools-viewer-framework-1.5.4-r2.ebuild:
+  Make working with py-2.7
+

py 2.7 is also fixed
Comment 6 urcindalo 2011-04-13 07:42:59 UTC
Thanks a lot, Justin. I can't express with words how much I appreciate your hard work and dedication to make Gentoo the best possible Linux option for scientists.
Comment 7 Justin Lecher gentoo-dev 2011-04-13 08:00:26 UTC
Isn't it fixed now?
Comment 8 urcindalo 2011-04-13 09:18:37 UTC
Yes, it is indeed :)
Comment 9 Justin Lecher gentoo-dev 2011-04-13 09:19:22 UTC
Okay closing then