Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 363253 - sys-apps/portage-2.1.9.42: InvalidDependString: malformed syntax:
Summary: sys-apps/portage-2.1.9.42: InvalidDependString: malformed syntax:
Status: RESOLVED DUPLICATE of bug 363073
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal minor (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-12 07:24 UTC by Toralf Förster
Modified: 2011-04-12 14:45 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2011-04-12 07:24:19 UTC
After an 
$>emerge --nospinner --newuse --update --ask --deep --tree --with-bdeps=y world

I got today :
Calculating dependencies  . ..... ...... done!

!!! All ebuilds that could satisfy ">=net-libs/libbluedevil-1.8.1" have been masked.
!!! One of the following masked packages is required to complete your request:
- net-libs/libbluedevil-1.8.1 (masked by: ~x86 keyword)

Traceback (most recent call last):
  File "/usr/bin/emerge", line 43, in <module>
    retval = emerge_main()
  File "/usr/lib/portage/pym/_emerge/main.py", line 1732, in emerge_main
    myopts, myaction, myfiles, spinner)
  File "/usr/lib/portage/pym/_emerge/actions.py", line 301, in action_build
    mydepgraph.display_problems()
  File "/usr/lib/portage/pym/_emerge/depgraph.py", line 5064, in display_problems
    self._show_unsatisfied_dep(*pargs, **kwargs)
  File "/usr/lib/portage/pym/_emerge/depgraph.py", line 2799, in _show_unsatisfied_dep
    dep_chain = self._get_dep_chain(myparent, atom)
  File "/usr/lib/portage/pym/_emerge/depgraph.py", line 2312, in _get_dep_chain
    node.metadata[dep_str], target_atom))
  File "/usr/lib/portage/pym/portage/dep/__init__.py", line 2402, in extract_affecting_use
    _("malformed syntax: '%s'") % mystr)
InvalidDependString: malformed syntax: '>=net-libs/libbluedevil-1.8.1 x11-misc/shared-mime-info !net-wireless/kbluetooth app-mobilephone/obexd[-server] app-mobilephone/obex-data-server >=kde-base/oxygen-icons-4.4[aqua=] >=kde-base/kde-l10n-4.4[aqua=,linguas_ca(+)?,linguas_ca@valencia(+)?,linguas_cs(+)?,linguas_da(+)?,linguas_de(+)?,linguas_en_GB(+)?,linguas_eo(+)?,linguas_es(+)?,linguas_et(+)?,linguas_eu(+)?,linguas_fr(+)?,linguas_ga(+)?,linguas_hu(+)?,linguas_it(+)?,linguas_ja(+)?,linguas_ko(+)?,linguas_lt(+)?,linguas_mai(+)?,linguas_ms(+)?,linguas_nb(+)?,linguas_nds(+)?,linguas_nl(+)?,linguas_pa(+)?,linguas_pl(+)?,linguas_pt(+)?,linguas_pt_BR(+)?,linguas_ro(+)?,linguas_ru(+)?,linguas_sk(+)?,linguas_sl(+)?,linguas_sv(+)?,linguas_th(+)?,linguas_tr(+)?,linguas_uk(+)?,linguas_zh_TW(+)?] dev-lang/perl >=x11-libs/qt-core-4.6.3:4[qt3support,ssl] >=x11-libs/qt-gui-4.6.3:4[accessibility,dbus] >=x11-libs/qt-qt3support-4.6.3:4[accessibility,kde] >=x11-libs/qt-script-4.6.3:4 >=x11-libs/qt-sql-4.6.3:4[qt3support] >=x11-libs/qt-svg-4.6.3:4 >=x11-libs/qt-test-4.6.3:4 !aqua? ( x11-libs/libXext x11-libs/libXt x11-libs/libXxf86vm ) >=kde-base/kdelibs-4.4[aqua=]'


Reproducible: Always




n22 ~ # emerge --info portage
Portage 2.1.9.42 (default/linux/x86/10.0/desktop/kde, gcc-4.4.5, glibc-2.11.3-r0, 2.6.38.2 i686)                        
=================================================================                                                       
                        System Settings                                                                                 
=================================================================                                                       
System uname: Linux-2.6.38.2-i686-Intel-R-_Core-TM-2_Duo_CPU_P8600_@_2.40GHz-with-gentoo-1.12.14                        
Timestamp of tree: Tue, 12 Apr 2011 06:45:01 +0000                                                                      
ccache version 2.4 [enabled]                                                                                            
app-shells/bash:     4.1_p9                                                                                             
dev-java/java-config: 2.1.11-r3                                                                                         
dev-lang/python:     2.6.6-r2, 3.1.3-r1                                                                                 
dev-util/ccache:     2.4-r9                                                                                             
dev-util/cmake:      2.8.1-r2                                                                                           
sys-apps/baselayout: 1.12.14-r1                                                                                         
sys-apps/sandbox:    2.4                                                                                                
sys-devel/autoconf:  2.13, 2.65-r1                                                                                      
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1                                                                           
sys-devel/binutils:  2.20.1-r1                                                                                          
sys-devel/gcc:       4.4.5                                                                                              
sys-devel/gcc-config: 1.4.1                                                                                             
sys-devel/libtool:   2.2.10                                                                                             
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.36.1 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=native -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs ccache compress-build-logs distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://mirror.netcologne.de/gentoo/ http://mirror.cambrium.nl/pub/os/linux/gentoo/ http://mirror.opteamax.de/gentoo/ http://91.121.124.139/gentoo-distfiles/"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_GB"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://linux.rz.ruhr-uni-bochum.de/gentoo-portage"
USE="X a52 aac acl acpi alsa apache2 berkdb bluetooth branding bzip2 cairo cdda cdr classic cli consolekit cracklib crypt css cups cxx dbus dri dts dvb dvd dvdr emboss encode exif fam fastbuild fat ffmpeg firefox flac fortran gdbm gdu gif git gmp gphoto2 gpm gtk hyphenation iconv ipv6 java jpeg kde kqemu lastfm lcms ldap libnotify logrotate mad mbox mikmod mmx mng modules mp3 mp4 mpeg mudflap mysql ncurses nls nptl nptlonly nsplugin ntfs ogg opengl openmp pam pango pcre pdf perl png policykit ppds pppd python qt3support qt4 rdesktop readline sdl session sieve spell sse sse2 sse3 ssl ssse3 startup-notification svg sysfs tcpd test thinkpad tiff tk truetype udev unicode usb vaapi vim-syntax vorbis wmf x264 x86 xcb xcomposite xinerama xml xorg xpm xscreensaver xulrunner xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard evdev mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_GB" LIRC_DEVICES="devinput inputlirc" PHP_TARGETS="php5-3" QEMU_SOFTMMU_TARGETS="i386" QEMU_USER_TARGETS="i386" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

sys-apps/portage-2.1.9.42 was built with the following:
USE="(ipc) test -build -doc -epydoc -python2 -python3 (-selinux)" LINGUAS="-pl"
CFLAGS="-O2 -march=native -pipe -fomit-frame-pointer -mfpmath=sse"
CXXFLAGS="-O2 -march=native -pipe -fomit-frame-pointer -mfpmath=sse"
Comment 1 Toralf Förster gentoo-dev 2011-04-12 11:15:15 UTC
FWIW:

n22 /etc/portage/package.keywords # grep blue *
misc:~net-libs/libbluedevil-1.8
misc:~net-wireless/bluedevil-1.0.3 


but nevertheless the Traceback shouldn't irritate the user, isn't it ?
Comment 2 Jeremy Olexa (darkside) (RETIRED) archtester gentoo-dev Security 2011-04-12 14:45:53 UTC

*** This bug has been marked as a duplicate of bug 363073 ***