Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 361281 - www-client/epiphany-2.30.6 crashes accessing several web sites due vlc plugin
Summary: www-client/epiphany-2.30.6 crashes accessing several web sites due vlc plugin
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-30 12:32 UTC by Juergen Rose
Modified: 2014-05-30 19:03 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Juergen Rose 2011-03-30 12:32:31 UTC
If I start epiphany and select, that epiphany should not restore windows and tabs, then epiphany crashes:

rose@orca:/home/rose(11)$ epiphany http://www.brothersoft.com/downloads/wget-for-windows-gui.html
** (epiphany:31493): DEBUG: NP_Initialize
** (epiphany:31493): DEBUG: NP_Initialize succeeded



1301488037.569725: FreeWRL plugin: NPP_Initialize
1301488037.569751: FreeWRL plugin: NPP_GetValue
1301488037.569758: FreeWRL plugin: NPP_GetValue
1301488037.569765: FreeWRL plugin: NPP_GetMIMEDescription
** (epiphany:31493): DEBUG: NP_Initialize
** (epiphany:31493): DEBUG: NP_Initialize succeeded
1301488037.571170: FreeWRL plugin: NPP_Initialize
1301488037.571181: FreeWRL plugin: NPP_GetValue
1301488037.571186: FreeWRL plugin: NPP_GetValue
1301488037.571192: FreeWRL plugin: NPP_GetMIMEDescription
** (epiphany:31493): DEBUG: NP_Initialize
** (epiphany:31493): DEBUG: NP_Initialize succeeded
djview: QDjViewPlugin::exec() begin
** (epiphany:31493): DEBUG: NP_Initialize
** (epiphany:31493): DEBUG: NP_Initialize succeeded
** (epiphany:31493): DEBUG: NP_Initialize
** (epiphany:31493): DEBUG: NP_Initialize succeeded
** (epiphany:31493): DEBUG: NP_Initialize
** (epiphany:31493): DEBUG: NP_Initialize succeeded
1301488037.587713: FreeWRL plugin: NPP_Initialize
1301488037.587729: FreeWRL plugin: NPP_GetValue
1301488037.587735: FreeWRL plugin: NPP_GetValue
1301488037.587741: FreeWRL plugin: NPP_GetMIMEDescription
** (epiphany:31493): DEBUG: NP_Initialize
** (epiphany:31493): DEBUG: NP_Initialize succeeded
** (epiphany:31493): DEBUG: NP_Initialize
** (epiphany:31493): DEBUG: NP_Initialize succeeded
** (epiphany:31493): DEBUG: NP_Initialize
** (epiphany:31493): DEBUG: NP_Initialize succeeded
Inconsistency detected by ld.so: dl-close.c: 736: _dl_close: Assertion `map->l_init_called' failed!
djview: QDjViewPlugin::exec() end code=0


Reproducible: Always




root@orca:/root(53)# emerge --info
Portage 2.1.9.45 (default/linux/amd64/10.0/desktop, gcc-4.5.2, glibc-2.13-r2, 2.6.37-gentoo-r1 x86_64)
=================================================================
System uname: Linux-2.6.37-gentoo-r1-x86_64-Intel-R-_Xeon-R-_CPU_W3520_@_2.67GHz-with-gentoo-2.0.2
Timestamp of tree: Wed, 30 Mar 2011 11:30:01 +0000
app-shells/bash:     4.2_p8
dev-java/java-config: 2.1.11-r3
dev-lang/python:     2.7.1-r1, 3.1.3-r1
dev-util/cmake:      2.8.4
sys-apps/baselayout: 2.0.2
sys-apps/openrc:     0.8.0
sys-apps/sandbox:    2.5
sys-devel/autoconf:  2.13, 2.68
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.21
sys-devel/gcc:       4.4.5, 4.5.2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.4-r1
sys-devel/make:      3.82
virtual/os-headers:  2.6.38 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA PUEL dlj-1.1 skype-eula googleearth AdobeFlash-10.1 cadsoft"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -msse4 -mcx16 -msahf -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/maven-bin-3.0/conf /usr/share/openvpn/easy-rsa /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.2/ext-active/ /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.2/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.2/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=core2 -msse4 -mcx16 -msahf -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de fr"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/x11 /var/lib/layman/java-overlay /var/lib/layman/sunrise /var/lib/layman/arcon /var/lib/layman/science /usr/local/portage /var/lib/cpan /var/lib/g-octave"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="64bit R X Xaw3d a52 aac abiword acl acpi admin afs alsa amd64 ao apache2 applet archive arpack asf aspell assistant audacious audiofile automap automount bash-completion berkdb blas blast bluetooth boo boost branding bzip2 cairo cdda cddb cdf cdio cdparanoia cdr cg cgi chm cli consolekit corba cracklib crypt css cuda cups curl cxx daap db dbase dbi dbm dbus declarative designer devhelp device-mapper dga dia djvu doc dri ds2490 ds9097 ds9097u dts dv dvb dvd dvdr dvi dynamicplugin eds elf emacs emboss emf empathy encode epiphany evo examples exif expat extensions extra extras fam fame ffmpeg fftw firefox fits flac fltk fontconfig foomaticdb fortran fortran95 fpx fts3 fuse galago gcj gd gdal gdbm gdu gedit geoip geolocation geos gfortran gif gimp ginac git glade glib gml gmp gmtsuppl gnokii gnome gnome-keyring gnome-print gnuplot gnutls gphoto2 gpm grammar graphics graphtft graphviz grass gs gsl gsm gstreamer gtk guile harness hddtemp hdf hdf5 hdri http httpd hvm iconv icq icu id3 ide imagemagick imap innodb inotify ipod ipv6 ithreads jabber jadetex java java5 java6 jbig john jpeg jpeg2k kdrive kerberos kpathsea kqemu kvm ladspa lame lapack latex latex3 lcms ldap lensfun libffi libgda libnotify libsamplerate lm_sensors lua lzo mad mail maildir mailwrapper mapnik math matroska mikmod mkl mmx mmxext mng modules mono moonlight motif mozilla mp3 mp4 mpeg mpi mplayer mtp mudflap multilib musicbrainz mysql mysqli nautilus ncurses neXt netcdf netpbm network networking networkmanager nfs nls nntp nptl nptlonly nsplugin ntfs ntp numpy nvidia obex objc ocaml octave odbc ogdi ogg ole openexr opengl openmp overview pae pam pango pcre pda pdf perl plotutils plugins png podcast policykit posix postgres postscript ppds pppd preview-latex proj projectx pstricks pulseaudio pymol python python-bindings q16 q32 qemu qhull qt3support qt4 quicktime readline reiserfs reports rle romio rpc rrdcgi rrdtool samba sasl science sdl secure-delete semantic-desktop server session sip slang slp smbclient smp sms sndfile snmp soup sox speex spell sql sqlite sse sse2 ssl startup-notification stlport subtitles subversion suexec svg svm swig sysfs szip t1lib tcl tcpd tex tex4ht texmacs tgif theora thinkpad threads thunderbird tidy tiff tk tntc tools truetype udev unicode usb userlocales utempter v4l2 virtualbox vorbis wav webdav webdav-serf webkit wmf wxwidgets x264 xattr xcb xemacs xext xine xml xmlreader xmlrpc xorg xpm xulrunner xv xvid xvmc yaml zlib zvbi" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgid dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CAMERAS="canon" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de fr" NETBEANS_MODULES="apisupport cnd dlight enterprise ergonomics groovy gsf harness ide identity j2ee java mobility nb php profiler ruby websvccommon xml" PHP_TARGETS="php5-3" QEMU_SOFTMMU_TARGETS="i386 ppc ppc64 x86_64" QEMU_USER_TARGETS="arm i386 x86_64" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nv nvidia nouveau vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

root@orca:/root(55)# emerge -pv1 epiphany

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] www-client/epiphany-2.30.6  USE="doc networkmanager nss -avahi -debug (-introspection) -test" 0 kB
Comment 1 Juergen Rose 2011-03-30 13:09:17 UTC
Could it be, that this bug due to new installed xul libraries (net-libs/xulrunner-2.0)? 
And therefore connected with Bug 361289?
Comment 2 Gilles Dartiguelongue gentoo-dev 2011-03-31 09:04:05 UTC
epiphany-2.30 does not use xulrunner, it uses webkit-gtk. I can't check from a gentoo box right now, but this url works just fine with webkit-1.2.7 and epiphany-2.30.6 on my debian workstation.

Could you get a backtrace with gdb ?
Comment 3 Juergen Rose 2011-03-31 10:32:05 UTC
I compiled epiphany again with:

CFLAGS="-march=core2 -msse4 -mcx16 -msahf -O2 -pipe -ggdb"
FEATURES="fixpackages splitdebug noclean"

If I then run epiphany under gdb I get the following messages
rose@orca:/home/rose(1)$ gdb epiphany
GNU gdb (Gentoo 7.2 p1) 7.2
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-pc-linux-gnu".
For bug reporting instructions, please see:
<http://bugs.gentoo.org/>...
Reading symbols from /usr/bin/epiphany...Reading symbols from /usr/lib64/debug/usr/bin/epiphany.debug...done.
done.
(gdb) run
Starting program: /usr/bin/epiphany 
[Thread debugging using libthread_db enabled]
Traceback (most recent call last):
  File "/usr/share/gdb/auto-load/usr/lib64/gcc/x86_64-pc-linux-gnu/4.5.2/libstdc++.so.6.0.14-gdb.py", line 59, in <module>
    from libstdcxx.v6.printers import register_libstdcxx_printers
ImportError: No module named libstdcxx.v6.printers
[New Thread 0x7fffe4f37700 (LWP 26195)]
[New Thread 0x7fffd708f700 (LWP 26202)]
[New Thread 0x7fffd678e700 (LWP 26203)]
[New Thread 0x7fffd5325700 (LWP 26204)]
[Thread 0x7fffd5325700 (LWP 26204) exited]
[New Thread 0x7fffd5325700 (LWP 26205)]
[New Thread 0x7fffd43bf700 (LWP 26206)]
[New Thread 0x7fffd3bbe700 (LWP 26207)]
[New Thread 0x7fffd33bd700 (LWP 26208)]
[New Thread 0x7fffd2bbc700 (LWP 26209)]
[New Thread 0x7fffd23bb700 (LWP 26210)]
[New Thread 0x7fffd1bba700 (LWP 26211)]
[New Thread 0x7fffd13b9700 (LWP 26212)]
[New Thread 0x7fffd0bb8700 (LWP 26213)]
[Thread 0x7fffd43bf700 (LWP 26206) exited]
[Thread 0x7fffd5325700 (LWP 26205) exited]
[Thread 0x7fffd23bb700 (LWP 26210) exited]
[Thread 0x7fffd3bbe700 (LWP 26207) exited]
[Thread 0x7fffd1bba700 (LWP 26211) exited]
[Thread 0x7fffd33bd700 (LWP 26208) exited]
[Thread 0x7fffd13b9700 (LWP 26212) exited]
[Thread 0x7fffd0bb8700 (LWP 26213) exited]
[Thread 0x7fffd2bbc700 (LWP 26209) exited]
[New Thread 0x7fffd2bbc700 (LWP 26214)]
[Thread 0x7fffd2bbc700 (LWP 26214) exited]
[New Thread 0x7fffd2bbc700 (LWP 26215)]
[Thread 0x7fffd2bbc700 (LWP 26215) exited]
[New Thread 0x7fffd2bbc700 (LWP 26216)]
[Thread 0x7fffd2bbc700 (LWP 26216) exited]
[New Thread 0x7fffd2bbc700 (LWP 26218)]
[Thread 0x7fffd2bbc700 (LWP 26218) exited]
[New Thread 0x7fffd2bbc700 (LWP 26219)]
[Thread 0x7fffd2bbc700 (LWP 26219) exited]
[New Thread 0x7fffd2bbc700 (LWP 26220)]
[Thread 0x7fffd2bbc700 (LWP 26220) exited]
[New Thread 0x7fffd2bbc700 (LWP 26221)]
[Thread 0x7fffd2bbc700 (LWP 26221) exited]
[New Thread 0x7fffd2bbc700 (LWP 26222)]
[Thread 0x7fffd2bbc700 (LWP 26222) exited]
[New Thread 0x7fffd2bbc700 (LWP 26223)]
[Thread 0x7fffd2bbc700 (LWP 26223) exited]
[New Thread 0x7fffd2bbc700 (LWP 26224)]
[Thread 0x7fffd2bbc700 (LWP 26224) exited]
[New Thread 0x7fffd2bbc700 (LWP 26225)]
[Thread 0x7fffd2bbc700 (LWP 26225) exited]
[New Thread 0x7fffd2bbc700 (LWP 26226)]
[Thread 0x7fffd2bbc700 (LWP 26226) exited]
[New Thread 0x7fffd2bbc700 (LWP 26227)]
[Thread 0x7fffd2bbc700 (LWP 26227) exited]
[New Thread 0x7fffd2bbc700 (LWP 26228)]
[Thread 0x7fffd2bbc700 (LWP 26228) exited]
[New Thread 0x7fffd2bbc700 (LWP 26229)]
[Thread 0x7fffd2bbc700 (LWP 26229) exited]
[New Thread 0x7fffd2bbc700 (LWP 26230)]
[Thread 0x7fffd2bbc700 (LWP 26230) exited]
[New Thread 0x7fffd2bbc700 (LWP 26231)]
[Thread 0x7fffd2bbc700 (LWP 26231) exited]
[New Thread 0x7fffd2bbc700 (LWP 26232)]
[Thread 0x7fffd2bbc700 (LWP 26232) exited]
[New Thread 0x7fffd2bbc700 (LWP 26233)]
[Thread 0x7fffd2bbc700 (LWP 26233) exited]
[New Thread 0x7fffd2bbc700 (LWP 26234)]
[Thread 0x7fffd2bbc700 (LWP 26234) exited]
[New Thread 0x7fffd2bbc700 (LWP 26235)]
[Thread 0x7fffd2bbc700 (LWP 26235) exited]
[New Thread 0x7fffd2bbc700 (LWP 26236)]
[Thread 0x7fffd2bbc700 (LWP 26236) exited]
[New Thread 0x7fffd2bbc700 (LWP 26237)]
[Thread 0x7fffd2bbc700 (LWP 26237) exited]
[New Thread 0x7fffd2bbc700 (LWP 26238)]
[Thread 0x7fffd2bbc700 (LWP 26238) exited]
[New Thread 0x7fffd2bbc700 (LWP 26239)]
[Thread 0x7fffd2bbc700 (LWP 26239) exited]
[New Thread 0x7fffd2bbc700 (LWP 26240)]
[Thread 0x7fffd2bbc700 (LWP 26240) exited]
[New Thread 0x7fffd2bbc700 (LWP 26244)]
[Thread 0x7fffd2bbc700 (LWP 26244) exited]
[New Thread 0x7fffd2bbc700 (LWP 26245)]
[Thread 0x7fffd2bbc700 (LWP 26245) exited]
[New Thread 0x7fffd2bbc700 (LWP 26246)]
[Thread 0x7fffd2bbc700 (LWP 26246) exited]
[New Thread 0x7fffd2bbc700 (LWP 26305)]
[Thread 0x7fffd2bbc700 (LWP 26305) exited]
[New Thread 0x7fffd2bbc700 (LWP 26313)]
[Thread 0x7fffd2bbc700 (LWP 26313) exited]
[New Thread 0x7fffd2bbc700 (LWP 26319)]
[New Thread 0x7fffd0bb8700 (LWP 26320)]
[Thread 0x7fffd0bb8700 (LWP 26320) exited]
[Thread 0x7fffd2bbc700 (LWP 26319) exited]
** (epiphany:26189): DEBUG: NP_Initialize
** (epiphany:26189): DEBUG: NP_Initialize succeeded
1301567197.278561: FreeWRL plugin: NPP_Initialize
1301567197.278585: FreeWRL plugin: NPP_GetValue
1301567197.278591: FreeWRL plugin: NPP_GetValue
1301567197.278598: FreeWRL plugin: NPP_GetMIMEDescription
** (epiphany:26189): DEBUG: NP_Initialize
** (epiphany:26189): DEBUG: NP_Initialize succeeded
1301567197.286664: FreeWRL plugin: NPP_Initialize
1301567197.286673: FreeWRL plugin: NPP_GetValue
1301567197.286678: FreeWRL plugin: NPP_GetValue
1301567197.286684: FreeWRL plugin: NPP_GetMIMEDescription
** (epiphany:26189): DEBUG: NP_Initialize
** (epiphany:26189): DEBUG: NP_Initialize succeeded
djview: QDjViewPlugin::exec() begin
** (epiphany:26189): DEBUG: NP_Initialize
** (epiphany:26189): DEBUG: NP_Initialize succeeded
** (epiphany:26189): DEBUG: NP_Initialize
** (epiphany:26189): DEBUG: NP_Initialize succeeded
** (epiphany:26189): DEBUG: NP_Initialize
** (epiphany:26189): DEBUG: NP_Initialize succeeded
1301567197.370558: FreeWRL plugin: NPP_Initialize
1301567197.370577: FreeWRL plugin: NPP_GetValue
1301567197.370583: FreeWRL plugin: NPP_GetValue
1301567197.370590: FreeWRL plugin: NPP_GetMIMEDescription
** (epiphany:26189): DEBUG: NP_Initialize
** (epiphany:26189): DEBUG: NP_Initialize succeeded
** (epiphany:26189): DEBUG: NP_Initialize
** (epiphany:26189): DEBUG: NP_Initialize succeeded
** (epiphany:26189): DEBUG: NP_Initialize
** (epiphany:26189): DEBUG: NP_Initialize succeeded
Inconsistency detected by ld.so: dl-close.c: 736: _dl_close: Assertion `map->l_init_called' failed!
[Thread 0x7fffd708f700 (LWP 26202) exited]
[Thread 0x7fffe4f37700 (LWP 26195) exited]
[Thread 0x7fffd678e700 (LWP 26203) exited]

djview: QDjViewPlugin::exec() end code=0
Program exited with code 0177.
(gdb) bt
No stack.
(gdb) 

Is this the information you want?
Comment 4 Gilles Dartiguelongue gentoo-dev 2011-03-31 14:50:05 UTC
hum, what nsplugins do you have installed ?
Check /usr/lib/nsbrowser/plugins/, /usr/lib/xulrunner-2.0/plugins/, /usr/lib/mozilla/plugins/...
Comment 5 Juergen Rose 2011-04-01 06:19:26 UTC
root@orca:/root(2)# ll /usr/lib/nsbrowser/plugins/
total 1160
-rwxr-xr-x 1 root root  98088 Nov 14 16:27 gecko-mediaplayer-dvx.so*
-rwxr-xr-x 1 root root  98088 Nov 14 16:27 gecko-mediaplayer-qt.so*
-rwxr-xr-x 1 root root  98088 Nov 14 16:27 gecko-mediaplayer-rm.so*
-rwxr-xr-x 1 root root 102184 Nov 14 16:27 gecko-mediaplayer.so*
-rwxr-xr-x 1 root root  98088 Nov 14 16:27 gecko-mediaplayer-wmp.so*
lrwxrwxrwx 1 root root     31 Jan  3 10:28 gxineplugin.so -> /usr/lib64/gxine/gxineplugin.so*
lrwxrwxrwx 1 root root     60 Feb 21 13:54 javaplugin.so -> //usr/share/java-config-2/nsplugin/sun-jdk-1.6-javaplugin.so*
-rwxr-xr-x 1 root root  31000 Nov  5 21:39 libFreeWRLplugin.so*
-rwxr-xr-x 1 root root   1080 Mar 29 14:03 librhythmbox-itms-detection-plugin.la*
-rwxr-xr-x 1 root root   5904 Mar 29 14:03 librhythmbox-itms-detection-plugin.so*
-rwxr-xr-x 1 root root 114656 Feb  7 09:46 libtotem-cone-plugin.so*
-rwxr-xr-x 1 root root 119360 Feb  7 09:46 libtotem-gmp-plugin.so*
-rwxr-xr-x 1 root root  81520 Feb  7 09:46 libtotem-mully-plugin.so*
-rwxr-xr-x 1 root root  90200 Feb  7 09:46 libtotem-narrowspace-plugin.so*
-rwxr-xr-x 1 root root   1122 Mar 29 14:37 libvlcplugin.la*
-rwxr-xr-x 1 root root 132128 Mar 29 14:37 libvlcplugin.so*
-rw-r--r-- 1 root root  47680 Mar 30 14:52 nsdejavu.so


root@orca:/root(3)# ll /usr/lib/xulrunner-2.0/plugins/
total 0


root@orca:/root(5)# ll /usr/lib/mozilla/plugins/
total 0
Comment 6 Pacho Ramos gentoo-dev 2011-04-03 15:55:34 UTC
http://www.brothersoft.com/downloads/wget-for-windows-gui.html opens ok for me on epiphany, please retry on a new created user account. I would also try without plugins.
Comment 7 Pacho Ramos gentoo-dev 2011-04-12 10:53:48 UTC
(In reply to comment #6)
> http://www.brothersoft.com/downloads/wget-for-windows-gui.html opens ok for me
> on epiphany, please retry on a new created user account. I would also try
> without plugins.

ping
Comment 8 Juergen Rose 2011-04-13 16:02:41 UTC
I created a new user rose_test. But epiphany crashes again.

At the first attempt I started epiphany, entered "chemical cytometry" as a search term for google, got a hit list, selected http://www.springerlink.com/index/k6018700g8822216.pdf and epiphany crashed.

If I select http://www.ncbi.nlm.nih.gov/pubmed/14580565, epiphany does not have any problems.

'epiphany http://www.brothersoft.com/downloads/wget-for-windows-gui.html' crashes immediately with 

rose_test@orca ~ $ epiphany http://www.brothersoft.com/downloads/wget-for-windows-gui.html
** (epiphany:32368): DEBUG: NP_Initialize
** (epiphany:32368): DEBUG: NP_Initialize succeeded
** (epiphany:32368): DEBUG: NP_Initialize
** (epiphany:32368): DEBUG: NP_Initialize succeeded
** (epiphany:32368): DEBUG: NP_Initialize
** (epiphany:32368): DEBUG: NP_Initialize succeeded
** (epiphany:32368): DEBUG: NP_Initialize
** (epiphany:32368): DEBUG: NP_Initialize succeeded
** (epiphany:32368): DEBUG: NP_Initialize
** (epiphany:32368): DEBUG: NP_Initialize succeeded
** (epiphany:32368): DEBUG: NP_Shutdown
** (epiphany:32368): DEBUG: NP_Initialize
** (epiphany:32368): DEBUG: NP_Initialize succeeded
** (epiphany:32368): DEBUG: NP_Initialize
** (epiphany:32368): DEBUG: NP_Initialize succeeded
djview: QDjViewPlugin::exec() begin
** (epiphany:32368): DEBUG: NP_Initialize
** (epiphany:32368): DEBUG: NP_Initialize succeeded
** (epiphany:32368): DEBUG: NP_Initialize
** (epiphany:32368): DEBUG: NP_Initialize succeeded
** (epiphany:32368): DEBUG: NP_Initialize
** (epiphany:32368): DEBUG: NP_Initialize succeeded
Inconsistency detected by ld.so: dl-close.c: 736: _dl_close: Assertion `map->l_init_called' failed!
djview: QDjViewPlugin::exec() end code=0
Comment 9 Juergen Rose 2011-04-13 16:10:42 UTC
If I disable Plugins under:
   Edit
	Preferences
		Privacy

epiphany does not crash accessing http://www.brothersoft.com/downloads/wget-for-windows-gui.html for user rose and user rose_test, as well.
Comment 10 Juergen Rose 2011-04-13 16:13:12 UTC
Perhaps I should add that I am working on orca in a ssh-session. If I run epiphany locally with enabled plugins, I see the following messages:

rose@moose:/home/rose(7)$ epiphany  http://www.brothersoft.com/downloads/wget-for-windows-gui.html
** (epiphany:10272): DEBUG: NP_Initialize
** (epiphany:10272): DEBUG: NP_Initialize succeeded
** (epiphany:10272): DEBUG: NP_Initialize
** (epiphany:10272): DEBUG: NP_Initialize succeeded
** (epiphany:10272): DEBUG: NP_Initialize
** (epiphany:10272): DEBUG: NP_Initialize succeeded
** (epiphany:10272): DEBUG: NP_Initialize
** (epiphany:10272): DEBUG: NP_Initialize succeeded
** (epiphany:10272): DEBUG: NP_Initialize
** (epiphany:10272): DEBUG: NP_Initialize succeeded
** (epiphany:10272): DEBUG: NP_Initialize
** (epiphany:10272): DEBUG: NP_Initialize succeeded
/var/tmp/portage/dev-java/icedtea-web-1.0.2/work/icedtea-web-1.0.2/plugin/icedteanp/IcedTeaNPPlugin.cc:2031: thread 0xb39320: Error: Invalid plugin function table.
Gtk-Message: Failed to load module "canberra-gtk-module": libcanberra-gtk-module.so: Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden
Gtk-Message: Failed to load module "gnomesegvhandler": libgnomesegvhandler.so: Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden
Gtk-Message: Failed to load module "canberra-gtk-module": libcanberra-gtk-module.so: Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden
Gtk-Message: Failed to load module "gnomesegvhandler": libgnomesegvhandler.so: Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden
djview: QDjViewPlugin::exec() begin
** (epiphany:10272): DEBUG: NP_Initialize
** (epiphany:10272): DEBUG: NP_Initialize succeeded
** (epiphany:10272): DEBUG: NP_Initialize
** (epiphany:10272): DEBUG: NP_Initialize succeeded
/var/tmp/portage/dev-java/icedtea-web-1.0.2/work/icedtea-web-1.0.2/plugin/icedteanp/IcedTeaNPPlugin.cc:2031: thread 0xb39320: Error: Invalid plugin function table.
** (epiphany:10272): DEBUG: NP_Initialize
** (epiphany:10272): DEBUG: NP_Initialize succeeded
Inconsistency detected by ld.so: dl-close.c: 736: _dl_close: Assertion `map->l_init_called' failed!
rose@moose:/home/rose(8)$ djview: QDjViewPlugin::exec() end code=0
Comment 11 Pacho Ramos gentoo-dev 2011-04-13 16:41:41 UTC
(In reply to comment #8)
> Inconsistency detected by ld.so: dl-close.c: 736: _dl_close: Assertion
> `map->l_init_called' failed!
> djview: QDjViewPlugin::exec() end code=0

-> Here looks to be the problem, do you have any plugin involving djview?
Comment 12 Gilles Dartiguelongue gentoo-dev 2011-04-14 14:46:11 UTC
Try moving the java, libfreewl and nsdejavu out of the folders I mentionned earlier one by one to see which might be the case ? If that's not enough, go through rhythmbox/totem plugins.
Comment 13 Pacho Ramos gentoo-dev 2011-05-06 17:00:28 UTC
Any news here?
Comment 14 Juergen Rose 2011-05-06 19:53:17 UTC
Now epiphany does not crash more with http://www.brothersoft.com/downloads/wget-for-windows-gui.html, but it still crashes with:
http://www.springerlink.com/content/k6018700g8822216/fulltext.pdf and I see:

** (epiphany:29307): DEBUG: NP_Initialize succeeded
Inconsistency detected by ld.so: dl-close.c: 736: _dl_close: Assertion `map->l_init_called' failed!
djview: QDjViewPlugin::exec() end code=0

in the terminal window where I started epiphany. Several plugins are new compared with my last posting:

rose@orca:/home/rose(1)$ ll /usr/lib/nsbrowser/plugins/
insgesamt 1132
-rwxr-xr-x 1 root root  98064 26. Apr 11:54 gecko-mediaplayer-dvx.so*
-rwxr-xr-x 1 root root  98064 26. Apr 11:54 gecko-mediaplayer-qt.so*
-rwxr-xr-x 1 root root  98064 26. Apr 11:54 gecko-mediaplayer-rm.so*
-rwxr-xr-x 1 root root 102160 26. Apr 11:54 gecko-mediaplayer-wmp.so*
-rwxr-xr-x 1 root root 102160 26. Apr 11:54 gecko-mediaplayer.so*
lrwxrwxrwx 1 root root     31  3. Jan 10:28 gxineplugin.so -> /usr/lib64/gxine/gxineplugin.so*
lrwxrwxrwx 1 root root     60 21. Feb 13:54 javaplugin.so -> //usr/share/java-config-2/nsplugin/sun-jdk-1.6-javaplugin.so*
-rwxr-xr-x 1 root root   1080 29. Mär 14:03 librhythmbox-itms-detection-plugin.la*
-rwxr-xr-x 1 root root   5904 29. Mär 14:03 librhythmbox-itms-detection-plugin.so*
-rwxr-xr-x 1 root root 114656 12. Apr 14:45 libtotem-cone-plugin.so*
-rwxr-xr-x 1 root root 119360 12. Apr 14:45 libtotem-gmp-plugin.so*
-rwxr-xr-x 1 root root  81520 12. Apr 14:45 libtotem-mully-plugin.so*
-rwxr-xr-x 1 root root  90200 12. Apr 14:45 libtotem-narrowspace-plugin.so*
-rwxr-xr-x 1 root root   1122 28. Apr 19:15 libvlcplugin.la*
-rwxr-xr-x 1 root root 132152 28. Apr 19:15 libvlcplugin.so*
-rw-r--r-- 1 root root  47680 30. Mär 14:52 nsdejavu.so


nsdejavu.so is not new. But even if I remove it epiphany still crashes.
Comment 15 Pacho Ramos gentoo-dev 2011-05-06 20:18:16 UTC
Start then removing more plugins until find the culprit
Comment 16 Juergen Rose 2011-05-07 09:37:21 UTC
It looks, if the vlc plugin is the culprit. After removing
libvlcplugin.la and libvlcplugin.so from the /usr/lib/nsbrowser/plugins directory I could access both web sites without crashing epiphany. After reemerging vlc (emerge -C vlc;   emerge -uvDN vlc) epiphany crashes again accessing http://www.springerlink.com/content/k6018700g8822216/fulltext.pdf. vlc was emerged with the following USE flags:



root@orca:/root(2)# emerge -pvD vlc

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] media-video/vlc-1.1.9  USE="X a52 aac aalib alsa cdda cddb dbus dts dvb dvd fbcon ffmpeg flac fontconfig gcrypt ggi gnome gnutls httpd kde libnotify lirc lua matroska mmx mp3 mpeg mtp ncurses nsplugin ogg opengl oss png pulseaudio pvr qt4 samba sdl speex sqlite sse svg theora truetype udev v4l v4l2 vlm vorbis x264 xcb xml xv zvbi (-altivec) -atmo -avahi -bidi -dc1394 -debug -dirac -directfb -fluidsynth -gme -id3tag -ieee1394 -jack -kate -libass -libcaca -libproxy -libtiger -libv4l -libv4l2 -live -modplug -musepack -optimisememory -projectm -remoteosd -rtsp -run-as-root -schroedinger -sdl-image -shine -shout -skins -stream (-svga) -taglib -twolame -upnp -vaapi -vcdx (-win32codecs) -wma-fixed -xosd" 0 kB
Comment 17 Pacho Ramos gentoo-dev 2011-05-07 10:25:02 UTC
You will need to recompile vlc also with debugging symbols to get a more complete backtrace I guess
Comment 18 Juergen Rose 2011-05-07 11:19:55 UTC
I added the debug USE flag to epiphany and vlc, changed CFLAGS to CFLAGS="-march=core2 -msse4 -mcx16 -msahf -O2 -pipe -ggdb"
and FEATURES="fixpackages splitdebug noclean" and run 
gdb epiphany 2>&1 | tee gdb_epiphany.log.
In the started epiphany I entered http://www.springerlink.com/content/k6018700g8822216/fulltext.pdf.
I got the following output:

rose@orca:/home/rose(22)$ gdb  epiphany 2>&1 | tee gdb_epiphany.log
GNU gdb (Gentoo 7.2 p1) 7.2
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-pc-linux-gnu".
For bug reporting instructions, please see:
<http://bugs.gentoo.org/>...
Reading symbols from /usr/bin/epiphany...Reading symbols from /usr/lib64/debug/usr/bin/epiphany.debug...done.
done.
(gdb) run
Starting program: /usr/bin/epiphany 
[Thread debugging using libthread_db enabled]
Traceback (most recent call last):
  File "/usr/share/gdb/auto-load/usr/lib64/gcc/x86_64-pc-linux-gnu/4.5.2/libstdc++.so.6.0.14-gdb.py", line 59, in <module>
    from libstdcxx.v6.printers import register_libstdcxx_printers
ImportError: No module named libstdcxx.v6.printers
[New Thread 0x7fffe5732700 (LWP 644)]
[New Thread 0x7fffd7bc7700 (LWP 645)]
[New Thread 0x7fffd72ae700 (LWP 646)]
[New Thread 0x7fffd55b9700 (LWP 647)]
[Thread 0x7fffd55b9700 (LWP 647) exited]
[New Thread 0x7fffd55b9700 (LWP 651)]
[New Thread 0x7fffd463f700 (LWP 652)]
[New Thread 0x7fffd3e3e700 (LWP 653)]
[New Thread 0x7fffd363d700 (LWP 654)]
[New Thread 0x7fffd2e3c700 (LWP 655)]
[New Thread 0x7fffd263b700 (LWP 656)]
[New Thread 0x7fffd1e3a700 (LWP 657)]
[New Thread 0x7fffd1639700 (LWP 658)]
[Thread 0x7fffd3e3e700 (LWP 653) exited]
[Thread 0x7fffd263b700 (LWP 656) exited]
[Thread 0x7fffd363d700 (LWP 654) exited]
[Thread 0x7fffd55b9700 (LWP 651) exited]
[Thread 0x7fffd1e3a700 (LWP 657) exited]
[Thread 0x7fffd1639700 (LWP 658) exited]
[Thread 0x7fffd463f700 (LWP 652) exited]
[Thread 0x7fffd2e3c700 (LWP 655) exited]
[New Thread 0x7fffd2e3c700 (LWP 662)]
[Thread 0x7fffd2e3c700 (LWP 662) exited]
[New Thread 0x7fffd2e3c700 (LWP 663)]
[Thread 0x7fffd2e3c700 (LWP 663) exited]
[New Thread 0x7fffd2e3c700 (LWP 664)]
[Thread 0x7fffd2e3c700 (LWP 664) exited]
[New Thread 0x7fffd2e3c700 (LWP 665)]
[Thread 0x7fffd2e3c700 (LWP 665) exited]
[New Thread 0x7fffd2e3c700 (LWP 666)]
[Thread 0x7fffd2e3c700 (LWP 666) exited]
[New Thread 0x7fffd2e3c700 (LWP 672)]
[Thread 0x7fffd2e3c700 (LWP 672) exited]
[New Thread 0x7fffd2e3c700 (LWP 674)]
[Thread 0x7fffd2e3c700 (LWP 674) exited]
[New Thread 0x7fffd2e3c700 (LWP 675)]
[Thread 0x7fffd2e3c700 (LWP 675) exited]
djview: QDjViewPlugin::exec() begin
Inconsistency detected by ld.so: dl-close.c: 736: _dl_close: Assertion `map->l_init_called' failed!
[Thread 0x7fffd7bc7700 (LWP 645) exited]
[Thread 0x7fffe5732700 (LWP 644) exited]
[Thread 0x7fffd72ae700 (LWP 646) exited]

Program exited with code 0177.
djview: QDjViewPlugin::exec() end code=0
(gdb) tb
No default breakpoint address now.
(gdb) quit


What next can I do?
Comment 19 Pacho Ramos gentoo-dev 2011-05-07 13:55:51 UTC
Try to follow:
http://www.gentoo.org/proj/en/qa/backtraces.xml

for running gdb, also installing bug-buddy could help to get a proper backtrace
Comment 20 Juergen Rose 2011-05-13 18:48:05 UTC
Hi Pacho,

Bug-buddy is installed. I thought, that I mainly followed http://www.gentoo.org/proj/en/qa/backtraces.xml.

I set the CFLAGS with "-O2 -ggdb", I enabled splitdebug in FEATURES. I am running epiphany under gdb.

What I am doing wrong?

Regards
Juergen
Comment 21 Pacho Ramos gentoo-dev 2011-05-14 08:24:24 UTC
(In reply to comment #18)
[...] 
> Program exited with code 0177.
> djview: QDjViewPlugin::exec() end code=0
> (gdb) tb
> No default breakpoint address now.
[...]

Is "tb" command equivalent to "bt"? (I am not sure :-/)
Comment 22 Juergen Rose 2011-06-01 18:40:33 UTC
I tried once more to locate the epiphany issue with the url http://www.springerlink.com/content/k6018700g8822216/fulltext.pdf.

If I remove the vlc plugin I can access the url. With the vlc plugin epiphany crashes. Under gdb I get the following output:

rose@orca:/home/rose(16)$ gdb epiphany
GNU gdb (Gentoo 7.2 p1) 7.2
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-pc-linux-gnu".
For bug reporting instructions, please see:
<http://bugs.gentoo.org/>...
Reading symbols from /usr/bin/epiphany...Reading symbols from /usr/lib64/debug/usr/bin/epiphany.debug...done.
done.
(gdb) run
Starting program: /usr/bin/epiphany 
[Thread debugging using libthread_db enabled]
Traceback (most recent call last):
  File "/usr/share/gdb/auto-load/usr/lib64/gcc/x86_64-pc-linux-gnu/4.5.2/libstdc++.so.6.0.14-gdb.py", line 59, in <module>
    from libstdcxx.v6.printers import register_libstdcxx_printers
ImportError: No module named libstdcxx.v6.printers
[New Thread 0x7fffe6b73700 (LWP 25846)]
[New Thread 0x7fffe5652700 (LWP 25847)]
[New Thread 0x7fffe4d39700 (LWP 25848)]
[New Thread 0x7fffd6982700 (LWP 25849)]
[New Thread 0x7fffd5a56700 (LWP 25850)]
[New Thread 0x7fffd5255700 (LWP 25851)]
[New Thread 0x7fffd4a54700 (LWP 25852)]
[New Thread 0x7fffd4253700 (LWP 25853)]
[Thread 0x7fffd5a56700 (LWP 25850) exited]
[Thread 0x7fffd4a54700 (LWP 25852) exited]
[Thread 0x7fffd6982700 (LWP 25849) exited]
[Thread 0x7fffd5255700 (LWP 25851) exited]
[Thread 0x7fffd4253700 (LWP 25853) exited]
[New Thread 0x7fffd4253700 (LWP 25854)]
[Thread 0x7fffd4253700 (LWP 25854) exited]
[New Thread 0x7fffd4253700 (LWP 25855)]
[Thread 0x7fffd4253700 (LWP 25855) exited]
[New Thread 0x7fffd4253700 (LWP 25857)]
[Thread 0x7fffd4253700 (LWP 25857) exited]
[New Thread 0x7fffd4253700 (LWP 25858)]
[Thread 0x7fffd4253700 (LWP 25858) exited]
[New Thread 0x7fffd4253700 (LWP 25863)]
[Thread 0x7fffd4253700 (LWP 25863) exited]
Inconsistency detected by ld.so: dl-close.c: 736: _dl_close: Assertion `map->l_init_called' failed!
[Thread 0x7fffe6b73700 (LWP 25846) exited]
[Thread 0x7fffe5652700 (LWP 25847) exited]
[Thread 0x7fffe4d39700 (LWP 25848) exited]

Program exited with code 0177.
(gdb) bt
No stack.
(gdb) 

I still removed the most flags from CFLAGS, but I did not get more elaborate backtrace.

rose@orca:/home/rose(24)$ grep ^C.*FLAGS /etc/make.conf
CFLAGS="-march=core2 -O2 -ggdb"
CXXFLAGS="${CFLAGS}"

Any further comment is appreciated.
Comment 23 Juergen Rose 2011-06-17 14:10:18 UTC
Any news?
Comment 24 Juergen Rose 2011-06-17 16:28:47 UTC
It seems me that the issue disappears with vlc-1.1.10:

rose@orca:/home/rose(2)$ ll /usr/lib/nsbrowser/plugins/
insgesamt 1088
-rwxr-xr-x 1 root root  98064 26. Apr 11:54 gecko-mediaplayer-dvx.so*
-rwxr-xr-x 1 root root  98064 26. Apr 11:54 gecko-mediaplayer-qt.so*
-rwxr-xr-x 1 root root  98064 26. Apr 11:54 gecko-mediaplayer-rm.so*
-rwxr-xr-x 1 root root 102160 26. Apr 11:54 gecko-mediaplayer-wmp.so*
-rwxr-xr-x 1 root root 102160 26. Apr 11:54 gecko-mediaplayer.so*
lrwxrwxrwx 1 root root     60 21. Feb 13:54 javaplugin.so -> //usr/share/java-config-2/nsplugin/sun-jdk-1.6-javaplugin.so*
-rwxr-xr-x 1 root root   1080 16. Jun 15:11 librhythmbox-itms-detection-plugin.la*
-rwxr-xr-x 1 root root   6032 16. Jun 15:12 librhythmbox-itms-detection-plugin.so*
-rwxr-xr-x 1 root root 114768  6. Jun 11:41 libtotem-cone-plugin.so*
-rwxr-xr-x 1 root root 119472  6. Jun 11:41 libtotem-gmp-plugin.so*
-rwxr-xr-x 1 root root  81632  6. Jun 11:41 libtotem-mully-plugin.so*
-rwxr-xr-x 1 root root  90320  6. Jun 11:41 libtotem-narrowspace-plugin.so*
-rwxr-xr-x 1 root root   1122 15. Jun 15:47 libvlcplugin.la*
-rwxr-xr-x 1 root root 132304 15. Jun 15:47 libvlcplugin.so*


rose@orca:/home/rose(4)$ epiphany http://www.springerlink.com/content/k6018700g8822216/fulltext.pdf

rose@orca:/home/rose(5)$  qlist -Iv vlc
media-video/vlc-1.1.10
Comment 25 Pacho Ramos gentoo-dev 2014-05-18 08:52:35 UTC
Any updates with a recent systemd? (with latest vlc and epiphany)