Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 361231 - app-office/dia-0.97.1 - ld: /usr/lib64/python2.7/config/libpython2.7.a(exceptions.o): relocation R_X86_64_32 against `_Py_NoneStruct' can not be used when making a shared object; recompile with -fPIC
Summary: app-office/dia-0.97.1 - ld: /usr/lib64/python2.7/config/libpython2.7.a(except...
Status: VERIFIED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: GNOME Office (OBSOLETE)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-30 07:57 UTC by Gabriel Misailidis
Modified: 2011-08-25 17:07 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,742.28 KB, text/plain)
2011-03-30 07:57 UTC, Gabriel Misailidis
Details
new build log.Pidgin -2.10.0 (build.log,384.09 KB, text/plain)
2011-08-25 17:03 UTC, Gabriel Misailidis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabriel Misailidis 2011-03-30 07:57:42 UTC
Created attachment 267769 [details]
build.log

Hello. 
I use media-gfx/inkscape and needs dia.


$ equery d dia
 * These packages depend on dia:
media-gfx/inkscape-0.48.1 (dia ? app-office/dia)

Dia can be built cause of ..../usr/lib64/python2.7/config/libpython2.7.a: could not read symbols: Bad value.

python-updater also wants to rebuild dia but unsuccesfull.
Comment 1 Dustin Polke 2011-03-30 12:45:28 UTC
Please post your emerge --info in a comment. Thanks.
Comment 2 Gabriel Misailidis 2011-03-30 15:58:23 UTC
# emerge --info
Portage 2.1.9.45 (default/linux/amd64/10.0/desktop, gcc-4.5.2, glibc-2.13-r2, 2.6.38-gentoo x86_64)
=================================================================
System uname: Linux-2.6.38-gentoo-x86_64-Intel-R-_Core-TM-_i5_CPU_M_430_@_2.27GHz-with-gentoo-2.0.2
Timestamp of tree: Wed, 30 Mar 2011 15:30:01 +0000
ccache version 3.1.4 [enabled]
app-shells/bash:     4.2_p8
dev-java/java-config: 2.1.11-r3
dev-lang/python:     2.7.1-r1, 3.1.3-r1
dev-util/ccache:     3.1.4
dev-util/cmake:      2.8.4
sys-apps/baselayout: 2.0.2
sys-apps/openrc:     0.8.0::pentoo
sys-apps/sandbox:    2.5
sys-devel/autoconf:  2.13, 2.68
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.21
sys-devel/gcc:       4.5.2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.4-r1
sys-devel/make:      3.82
virtual/os-headers:  2.6.38 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -msse4 -mcx16 -mpopcnt -msahf -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=core2 -msse4 -mcx16 -mpopcnt -msahf -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs ccache distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="ftp://ftp.ntua.gr/pub/linux/gentoo/ http://ftp.ntua.gr/pub/linux/gentoo/ ftp://mirrors.ludost.net/gentoo/"
LANG="en_GB.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/multimedia /var/lib/layman/pentoo /var/lib/layman/pro-audio /var/lib/layman/gentoo-el"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3ds X a52 aac aalib abiword acl acpi addbookmarks addressbook aften afterimage aim alsa amd64 amr ao aplaymidi apm aqua_theme aspell audio automount autoreplace bash-completion battery beagle beeper berkdb bl bluetooth bonjour bookmarks branding bs2b bzip2 cairo caps cardbus ccache cdda cddax cdr cdrdao cdrom chatzilla clamav clamd clamdtop cli colordiff colors consolekit contactnotes cracklib crypt css cups cursors cvsgraph cxx dbus device-mapper dga dia disk-partition djvu dosformat dri dts dv dvb dvd dvdr dxr3 eap-sim eds eix emacs emacs22icons emboss emovix encode epiphany evo exif faac faad fam fat fbcon ffmpeg firefox flac fortran ftp fuse gcdmaster gd gdbm gdm gdu ggi gif gimp git gmail gnome gnome-print gnutls google google-gadgets gphoto2 gpm gps grace graphics graphicsmagick graphviz groupwise grub gstreamer gtk hddtemp history hpijs html http iconv icq imagemagick ipv6 jabber jack jfs jpeg jpeg2k kde kdm kismet kontact kpathsea laptop lastfmradio latex lcms ldap libburn libcaca libnotify lm_sensors logrotate logviewer logwatch lyrics mad madwifi midi mikmod mmx mmxext mng modules mp3 mp3tunes mp4 mpeg mplayer msn mudflap multilib nas nautilus ncurses nfs nfsv3 nfsv4 nls nptl nptlonly nss ntfs ntp ogg ogg123 openal opengl openmp oscar otr pam pango parted pastebin pcmcia pcre pdf perl pidgin player plugins png pnm policykit ppds pppd pvr python qt3support qt4 quicktime radio rar raw readline reiser4 reiserfs samba scanner sdl search session shm skype smartcard sms spell splash spoof-source sql sqlite sse sse2 sse3 sse4 sse4a sse5 ssl ssse3 startup-notification subversion svg sysfs syslog tcpd tga themes theora thumbnail thumbnails thunar tiff timidity translator truetype udev unicode usb v4l v4l2 video vim vim-pager vim-syntax vorbis vpx wav webcam webkit webpresence wifi wiki wikipedia winetools wma wma-fixed wmf x264 xanim xcb xemacs xfce xfs xml xorg xulrunner xv xvid xvmc yahoo youtube zip zlib zoran" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel vesa fbdev" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Sorry i've forgot it.
Comment 3 Pacho Ramos gentoo-dev 2011-04-03 10:49:18 UTC
Sadly I cannot reproduce :-|
Comment 4 Michal Bystricky 2011-04-14 14:44:22 UTC
Same error here in my Gentoo.

app-office/dia-0.97.1

...
/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.5/../../../../x86_64-pc-linux-gnu/bin/ld: /usr/lib64/python2.7/config/libpython2.7.a(exceptions.o): relocation R_X86_64_32 against `_Py_NoneStruct' can not be used when making a shared object; recompile with -fPIC
/usr/lib64/python2.7/config/libpython2.7.a: could not read symbols: Bad value
collect2: ld returned 1 exit status
...


# emerge --info
Portage 2.1.9.42 (default/linux/amd64/10.0, gcc-4.4.5, glibc-2.11.3-r0, 2.6.37-gentoo-r4 x86_64)
=================================================================
System uname: Linux-2.6.37-gentoo-r4-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T5670_@_1.80GHz-with-gentoo-1.12.14
Timestamp of tree: Wed, 13 Apr 2011 19:00:01 +0000
app-shells/bash:     4.1_p9
dev-java/java-config: 2.1.11-r3
dev-lang/python:     2.6.6-r2, 2.7.1-r1, 3.1.3-r1
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 1.12.14-r1
sys-apps/sandbox:    2.4
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.5
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.36.1 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -mtune=generic -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=core2 -mtune=generic -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://de-mirror.org/distro/gentoo/ http://ftp.fi.muni.cz/pub/linux/gentoo/ rsync://ftp6.linux.cz/pub/linux/gentoo/ rsync://ftp.fi.muni.cz/pub/linux/gentoo/ http://gentoo.wheel.sk/ ftp://gentoo.wheel.sk/pub/linux/gentoo/ ftp://mirror.ynet.sk/pub/gentoo/ http://mirror.ynet.sk/pub/gentoo/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/java-overlay /var/lib/layman/zugaina"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X aalib acl acpi alsa amd64 apache2 apm atm bash-completion berkdb bzip2 cli cracklib crypt ctype cups curl cxx dbus device-mapper dri dv dvb dvd dvdr encode esd exif extras fbcon ffmpeg firefox flac fortran ftp gd gdbm gif gimp glut gnutls gpm gstreamer gtk gzip iconv icu imagemagick imap imlib ipv6 java java6 javascript jpeg jpeg2k lame latex libwww lm_sensors maildir matroska matrox mime mmx modules motif mozilla mp3 mp4 mpeg mplayer mtp mudflap multilib mysql mysqli ncurses networkmanager nls nptl nptlonly ogg openmp pam pcre perl php png policykit pppd python qt4 quicktime raw rdesktop readline rss samba sasl session simplexml smp sockets socks5 spell sse sse2 ssl svg symlink sysfs syslog taglib tcl tcpd threads tiff tk truetype udev unicode usb v4l v4l2 vhosts vorbis wavpack wifi x264 xine xinerama xml xmlrunner xorg xpm xscreensaver xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 5 Pacho Ramos gentoo-dev 2011-04-14 18:21:24 UTC
http://forums.gentoo.org/viewtopic-p-6651823.html looks to show there are other apps affected, did you opened bug reports for them also?
Comment 6 Gabriel Misailidis 2011-04-14 19:40:01 UTC
Pacho Ramos i haven't problem with other applications.

Even though python-updater wants to re emerge gvim vim but these goes fine.Only dia is my problem.

I've read the forum's thread.And i had somekind of same issue.As i remember , python was removed or something.I can't remember.To be honest, i overide dia emerge.Tommorow i will give more tries.
Comment 7 Gilles Dartiguelongue gentoo-dev 2011-04-24 18:02:45 UTC
If wonder where this file comes from. Could you run:
# qfile /usr/lib64/python2.7/config/libpython2.7.a
or
# equery belongs /usr/lib64/python2.7/config/libpython2.7.a
Comment 8 Gabriel Misailidis 2011-04-26 16:47:03 UTC
i5_gentoo gabriel #  equery belongs /usr/lib64/python2.7/config/libpython2.7.a
 * Searching for /usr/lib64/python2.7/config/libpython2.7.a ... 

i5_gentoo gabriel # qfile /usr/lib64/python2.7/config/libpython2.7.a
i5_gentoo gabriel #

I don't see that it belongs anywhere.
Comment 9 Gilles Dartiguelongue gentoo-dev 2011-04-26 18:50:55 UTC
I the file exists, which I assume it does due to the error message, it does not belong to a package managed by portage and is either due to a manual install or a faulty ebuild from overlay or ... In any case I think this bug can be closed as invalid. Please clean up your system and reopen if you can still reproduce on a clean install.
Comment 10 Gabriel Misailidis 2011-08-25 17:03:04 UTC
Created attachment 284649 [details]
new build log.Pidgin -2.10.0
Comment 11 Gabriel Misailidis 2011-08-25 17:06:50 UTC
Hello.Months may passed but problem still exists. I've unemerged dia. But i still have problem with pidgin. Pidgin is managed by portage, not from an overlay : 


# eix net-im/pidgin
* net-im/pidgin
     Available versions:  2.7.11 (~)2.8.0 (~)2.8.0-r1 2.9.0 (~)2.9.0-r1 (~)2.10.0 {dbus debug doc eds gadu gnutls groupwise +gstreamer +gtk idn meanwhile ncurses networkmanager nls perl prediction python qq sasl silc spell tcl tk +xscreensaver zephyr zeroconf}
     Homepage:            http://pidgin.im/
     Description:         GTK Instant Messenger client



emerge --info =net-im/pidgin-2.10.0
Portage 2.1.10.11 (default/linux/amd64/10.0/desktop, gcc-4.5.3, glibc-2.13-r4, 2.6.38-gentoo-r5 x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-2.6.38-gentoo-r5-x86_64-Intel-R-_Core-TM-_i5_CPU_M_430_@_2.27GHz-with-gentoo-2.0.3
Timestamp of tree: Thu, 25 Aug 2011 09:00:01 +0000
ccache version 3.1.6 [enabled]
app-shells/bash:          4.2_p10
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r2, 3.1.4-r2, 3.2-r2
dev-util/ccache:          3.1.6
dev-util/cmake:           2.8.5-r2
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.8.3-r1::pentoo
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.10.3, 1.11.1-r1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 2.6.39 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo multimedia pentoo proaudio gentoo-el
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -msse4 -mcx16 -mpopcnt -msahf -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=core2 -msse4 -mcx16 -mpopcnt -msahf -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs ccache distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="ftp://ftp.ntua.gr/pub/linux/gentoo/ http://ftp.ntua.gr/pub/linux/gentoo/ ftp://mirrors.ludost.net/gentoo/"
LANG="en_GB.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/multimedia /var/lib/layman/pentoo /var/lib/layman/pro-audio /var/lib/layman/gentoo-el"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3ds X a52 aac aalib abiword acl acpi addbookmarks addressbook aften afterimage aim alsa amd64 amr ao aplaymidi apm aqua_theme aspell audio automount autoreplace bash-completion battery beagle beeper berkdb bl bluetooth bonjour bookmarks branding bs2b bzip2 cairo caps cardbus ccache cdda cddax cdr cdrdao cdrom chatzilla clamav clamd clamdtop cli colordiff colors consolekit contactnotes cracklib crypt css cups cursors cvsgraph cxx dbus device-mapper dga dia disk-partition djvu dosformat dri dts dv dvb dvd dvdr dxr3 eap-sim eds eix emacs emacs22icons emboss emovix encode epiphany evo exif faac faad fam fat fbcon ffmpeg firefox flac fortran ftp fuse gcdmaster gd gdbm gdm gdu ggi gif gimp git gmail gnome gnome-print gnutls google google-gadgets gphoto2 gpm gps grace graphics graphicsmagick graphviz groupwise grub gstreamer gtk hddtemp history hpijs html http iconv icq imagemagick ipv6 jabber jack jfs jpeg jpeg2k kde kdm kismet kontact kpathsea laptop lastfmradio latex lcms ldap libburn libcaca libnotify lm_sensors logrotate logviewer logwatch lyrics mad madwifi midi mmx mmxext mng modules mp3 mp3tunes mp4 mpeg mplayer msn mudflap multilib nas nautilus ncurses nfs nfsv3 nfsv4 nls nptl nptlonly nss ntfs ntp ogg ogg123 openal opengl openmp oscar otr pam pango parted pastebin pcmcia pcre pdf perl pidgin player plugins png pnm policykit ppds pppd pvr python qt3support qt4 quicktime radio rar raw readline reiser4 reiserfs samba sdl search session shm skype smartcard sms spell splash spoof-source sql sqlite sse sse2 sse3 sse4 sse4a sse5 ssl ssse3 startup-notification subversion svg sysfs syslog tcpd tga themes theora thumbnail thumbnails thunar tiff timidity translator truetype udev unicode usb v4l v4l2 video vim vim-pager vim-syntax vorbis vpx wav webcam webkit webpresence wifi wiki wikipedia winetools wma wma-fixed wmf x264 xanim xcb xemacs xfce xfs xml xorg xulrunner xv xvid xvmc yahoo youtube zip zlib zoran" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" SANE_BACKENDS="apple cardscan epson epson2 fujitsu hp magicolor" USERLAND="GNU" VIDEO_CARDS="intel vesa fbdev" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS