Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 361139 - app-emulation/ganeti should DEPEND on || ( app-emulation/qemu-kvm app-emulation/qemu-kvm-spice )
Summary: app-emulation/ganeti should DEPEND on || ( app-emulation/qemu-kvm app-emulati...
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Lance Albertson (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-29 15:21 UTC by Simon Alman
Modified: 2011-03-31 20:01 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Alman 2011-03-29 15:21:01 UTC
The ganeti ebuild lists:
 kvm? app-emulation/qemu-kvm
Since qemu-kvm-spice is available and fulfills the same purpose it needs to be an option e.g:
 kvm? ( || ( app-emulation/qemu-kvm app-emulation/qemu-kvm-spice ) )

Reproducible: Always

Steps to Reproduce:
1. emerge qemu-kvm-spice
2. echo "app-emulation/ganeti drbd kvm" >> /etc/portage/package.use
3. emerge ganeti
Actual Results:  
Ganeti attempts to pull in qemu-kvm:

[blocks B     ] app-emulation/qemu-kvm-spice ("app-emulation/qemu-kvm-spice" is blocking app-emulation/qemu-kvm-0.13.0-r2)



Expected Results:  
qemu-kvm-spice should be tolerated as an alternative to qemu-kvm - both come from the same source.

Editing the ebuild and changing:
 kvm? app-emulation/qemu-kvm
For:
 kvm? ( || ( app-emulation/qemu-kvm app-emulation/qemu-kvm-spice ) )

Is all that is needed.
Comment 1 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2011-03-31 18:42:46 UTC
Please don't.

Check bug 335932 and bug 355513.
qemu-kvm-spice should be merged back to qemu-kvm relatively soon.
Comment 2 Simon Alman 2011-03-31 20:01:09 UTC
No problem, wasn't aware of all the changes going on behind the scenes. 

I'm happy enough to close this off and wait for spice support in qemu-kvm.

Thanks for the response.