Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 359865 - sys-kernel/gentoo-sources: emerge gentoo-sources fails with USE="deblob"
Summary: sys-kernel/gentoo-sources: emerge gentoo-sources fails with USE="deblob"
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Kernel Miscellaneous
Depends on:
Reported: 2011-03-22 01:41 UTC by Martin Walch
Modified: 2011-06-02 19:17 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---

kernel-2.eclass patch to force a call to detect_version() if needed (kernel2-eclass-deblob-kv.patch,713 bytes, patch)
2011-04-03 04:15 UTC, Johnny
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Walch 2011-03-22 01:41:36 UTC
>>> Emerging (1 of 1) sys-kernel/gentoo-sources-2.6.37-r3
 * linux-2.6.37.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                                                                                        [ ok ]
 * genpatches-2.6.37-5.base.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                                                                            [ ok ]
 * genpatches-2.6.37-5.extras.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                                                                          [ ok ]
 * Package:    sys-kernel/gentoo-sources-2.6.37-r3
 * Repository: gentoo
 * Maintainer:
 * USE:        amd64 deblob elibc_glibc kernel_linux multilib userland_GNU
 * FEATURES:   ccache nostrip sandbox
>>> Preparing to unpack ...
>>> Unpacking source...
>>> Unpacking linux-2.6.37.tar.bz2 to /var/tmp/portage/sys-kernel/gentoo-sources-2.6.37-r3/work
>>> Unpacking genpatches-2.6.37-5.base.tar.bz2 to /var/tmp/portage/sys-kernel/gentoo-sources-2.6.37-r3/work/patches
>>> Unpacking genpatches-2.6.37-5.extras.tar.bz2 to /var/tmp/portage/sys-kernel/gentoo-sources-2.6.37-r3/work/patches
 * Applying 1000_linux- (-p0+) ...
 [ ok ]
 * Applying 1001_linux- (-p0+) ...
 [ ok ]
 * Applying 1002_linux- (-p0+) ...
 [ ok ]
 * Applying 1003_linux- (-p0+) ...
 [ ok ]
 * Applying 1900_fs-cache-op-handling-fix.patch (-p0+) ...
 [ ok ]
 * Applying 2400_iwlwifi-fw-reload-rf-fix.patch (-p0+) ...
 [ ok ]
 * Applying 4200_fbcondecor-0.9.6.patch (-p0+) ...
 [ ok ]
cp: cannot stat `/var/tmp/portage/sys-kernel/gentoo-sources-2.6.37-r3/distdir/deblob-..': No such file or directory
 * ERROR: sys-kernel/gentoo-sources-2.6.37-r3 failed (unpack phase):
 *   cp deblob-.. failed
 * Call stack:
 *, line   56:  Called src_unpack
 *   environment, line 3054:  Called kernel-2_src_unpack
 *   environment, line 2255:  Called die
 * The specific snippet of code:
 *           cp "${DISTDIR}/${DEBLOB_A}" "${T}" || die "cp ${DEBLOB_A} failed";

I have no clue where this comes from, but emerge fails with any version of gentoo-sources that tries to apply the deblob patch.

emerge --info
Portage (default/linux/amd64/10.0/desktop/kde, gcc-4.4.5, glibc-2.11.3-r0, 2.6.38-gentoo x86_64)
System uname: Linux-2.6.38-gentoo-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q8400_@_2.66GHz-with-gentoo-2.0.1
Timestamp of tree: Tue, 22 Mar 2011 00:15:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.1_p9
dev-java/java-config: 2.1.11-r3
dev-lang/python:     2.6.6-r2, 3.1.3-r1
dev-util/ccache:     2.4-r9
dev-util/cmake:      2.8.4
sys-apps/baselayout: 2.0.1-r1
sys-apps/openrc:     0.7.0
sys-apps/sandbox:    2.4
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.5
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers: (sys-kernel/linux-headers)
ACCEPT_LICENSE="@FREE bea.ri.jsr173 dom4j GPL-2-with-MySQL-FLOSS-exception icu JasPer2.0 jaxen JDOM NCSA-HDF Radiance saxpath wxWinFDL-3 GPL freedist MOTIF Allegro unRAR MSttfEULA UCAR-Unidata GDLS ISOC-rfc intel-ucode truecrypt-3.0 atheros-hal"
CFLAGS="-march=native -O2 -fgcse-after-reload -pipe"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -fgcse-after-reload -pipe"
FEATURES="assume-digests binpkg-logs ccache collision-protect distlocks fixlafiles fixpackages metadata-transfer mirror multilib-strict news nostrip parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-march=native -O2 -fgcse-after-reload -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/var/lib/layman/unknown-horizons /var/lib/layman/java-overlay /usr/local/portage /usr/local/portage/worldforge"
USE="64bit X Xaw3d a52 aac aalib accessibility acl acpi agg akode allegro alsa amarok amd64 amr apache2 autoipd bash-completion bazaar berkdb bittorrent blender blender-game branding bzip2 cairo captury ccache cdaudio cdr cdrom cegui cjk cli clucene consolekit cracklib crypt cups curl cviewer cvs cxx daap dbus deblob declarative default-font designer-plugin desktopglobe devil dga dirac djvu doc dri dts dvd dvdnav dvdr dxr3 emacs embedded emboss encode exif fam fbcon ffmpeg fftw firefox fits flac fltk fortran gcj gdbm gdu ggi git glitz gmm gmp gopher gpg gpm gpu grub gstreamer guile gzip htmlhandbook i18n iceweasel icons iconv icq icu idn imagemagick insecure-savers intel ipv6 jabber jack java java6 javascript jingle jpeg kde kde4 kdebuild kdecards kdehiddenvisibility kdepim kdm kontact ktts latex lcms ldap libcaca libnotify libssh2 libwww lm_sensors logitech-mouse lua lzma lzo matroska mdnsresponder-compat mercurial mikmod mmx mng modules mpeg mpeg2 mpfr mpi mudflap mule multilib musepack mysql ncurses nepomuk networkmanager nio2 nls noamazon nova nowin nptl nptlonly nsplugin offensive ogg ogg123 openal openexr opengl openmp openssl opensslcrypt openstreetmap openxml oscar otr oxygen pae pam pango pcre pdf perl phonon plasma player png policykit posix povray ppds pppd private-headers python qt3support qt4 readline redland reiser4 reiserfs rss schroedinger sdl sdl-image semantic-desktop sensord session shm shmvideo sndfile solver songs sound speex spell sse sse2 sse3 ssl ssse3 startup-notification subversion svg sysfs systemtap tcpd tetex theora threads tidy tiff tk tools truetype type1 udev unicode usb v4l2 vaapi vhook videos visualization vorbis vpx wav wavpack wifi wikipedia wmf wxwindows x264 xcb xcomposite xemacs xerces-c xhtml xine xml xorg xosd xprint xrandr xscreensaver xulrunner xv xvid xvmc zeroconf zfs zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="i965 intel vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2011-03-22 15:43:19 UTC

*** This bug has been marked as a duplicate of bug 359567 ***
Comment 2 Martin Walch 2011-03-23 00:45:59 UTC
Sorry, this is a different bug. It is not fixed by the commit from bug #359567. Actually now emerge also fails with gentoo-sources-2.6.38.
Comment 3 Pablo Cholaky 2011-03-24 03:40:44 UTC
This bug affects me too
Comment 4 Nick White 2011-03-25 18:58:11 UTC
I'm seeing this too, with sys-kernel/gentoo-sources-2.6.36-r8 (using paludis).

Interestingly the deblob scripts aren't attempted to be downloaded. It's odd; it looks from the error as though DEBLOB_PV isn't getting ${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}, but it's not immediately obvious to me why not.

Unrelatedly, one very small inconsistency in the eclass is that first availability is sometimes checked with [[ $K_DEBLOB_AVAILABLE == "1" ]], and sometimes [[ $K_DEBLOB_AVAILABLE == 1 ]]. But this isn't the issue.
Comment 5 Nick White 2011-03-25 18:59:45 UTC
(In reply to comment #4)
> It's odd; it looks from the error as though DEBLOB_PV isn't getting
> ${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}, but it's not immediately obvious to me why
> not.

It doesn't look to me like detect_version is called before DEBLOB_PV being set.
Comment 6 Nick White 2011-03-25 19:06:28 UTC
(In reply to comment #5)
> It doesn't look to me like detect_version is called before DEBLOB_PV being set.

Oops, sorry for the noise, it should be, when checking whether to set K_DEBLOB_AVAILABLE

Another (probably unrelated) issue of style; shouldn't
[[ -z "${K_DEBLOB_AVAILABLE}" ]]
(though I see there's no consistent style in this in the eclass)
Comment 7 Nick White 2011-03-25 19:18:05 UTC
The issue is that CKV is not being set; the bashism 'CKV=${CKV:-${PV}}' doesn't seem to be working. I try to stay away from bashisms, so I'll try leaving it to someone else to debug.
Comment 8 Dmitry Samoyloff 2011-03-26 16:24:37 UTC
Should we file a separate bug report concerning the CKV problem?
Comment 9 Johnny 2011-04-03 04:10:07 UTC
I have this bug also with gentoo-sources-2.6.38-r1.  I have a workaround patch that I successfully used to emerge a deblobbed kernel on a local overlay.  Basically it just makes sure that it always calls kernel_is() once which in turn will call detect_version() if needed.  I don't think this is a proper solution, though.  I think that all of that "if [[ ${ETYPE} ==..." code (lines ~319 through ~388) should be in a function that gets called after detect_version() has been called.
Comment 10 Johnny 2011-04-03 04:15:08 UTC
Created attachment 268275 [details, diff]
kernel-2.eclass patch to force a call to detect_version() if needed
Comment 11 Pablo Cholaky 2011-04-05 18:39:00 UTC
(In reply to comment #10)
> Created attachment 268275 [details, diff]
> kernel-2.eclass patch to force a call to detect_version() if needed

I'm getting problems with the patch:

('Filesize does not match recorded size', 345831, 4039)
!!! Fetched file: deblob-check-2.6.38 VERIFY FAILED!
!!! Reason: Filesize does not match recorded size
!!! Got:      345831
!!! Expected: 4039
Comment 12 Pablo Cholaky 2011-04-19 00:01:45 UTC
I'm tired of masking gentoo-sources, some solution for now?
Comment 13 Mike Pagano gentoo-dev 2011-04-21 12:35:44 UTC
(In reply to comment #10)
> Created attachment 268275 [details, diff]
> kernel-2.eclass patch to force a call to detect_version() if needed

I committed this patch. It worked through my tests. Please post here if anyone sees any new errors. Thanks, Johnny.
Comment 14 Pablo Cholaky 2011-04-21 20:10:54 UTC
(In reply to comment #13)
> (In reply to comment #10)
> > Created attachment 268275 [details, diff]
> > kernel-2.eclass patch to force a call to detect_version() if needed
> I committed this patch. It worked through my tests. Please post here if anyone
> sees any new errors. Thanks, Johnny.

Seems working too for me on official repo.
Comment 15 Dmitry Samoyloff 2011-04-21 20:29:18 UTC
Works for me too! Big thanks to Nick, Johnny and Mike and everyone involved in the fix!
Comment 16 Mike Pagano gentoo-dev 2011-06-02 19:17:57 UTC
Great, thanks. Closing