Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 359803 - sys-process/daemontools-encore fails to build
Summary: sys-process/daemontools-encore fails to build
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
: 536178 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-03-21 14:53 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2019-01-18 02:56 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (daemontools-encore-1.05:20110317-183916.log,7.71 KB, text/plain)
2011-03-21 14:53 UTC, Diego Elio Pettenò (RETIRED)
Details
1.06 build log (build.log,8.59 KB, text/plain)
2013-10-22 14:59 UTC, Dennis Lichtenthäler
Details
Remove 'softlimit p0 still allows exec' test (remove-softlimit-test.diff,666 bytes, patch)
2014-09-23 08:59 UTC, Dennis Lichtenthäler
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2011-03-21 14:53:07 UTC
Created attachment 266747 [details]
Build log

Portage 2.1.9.44 (default/linux/x86/10.0, gcc-4.5.2-asneeded, glibc-2.13-r2, 2.6.38 i686)
=================================================================
System uname: Linux-2.6.38-i686-Quad-Core_AMD_Opteron-tm-_Processor_2350-with-gentoo-2.0.1
Timestamp of tree: Mon, 21 Mar 2011 12:00:01 +0000
ccache version 3.1.4 [disabled]
app-shells/bash:     4.2_p8
dev-java/java-config: 2.1.11-r3
dev-lang/python:     2.4.6, 2.7.1-r1, 3.1.3-r1
dev-util/ccache:     3.1.4
dev-util/cmake:      2.8.4
sys-apps/baselayout: 2.0.1-r1
sys-apps/openrc:     0.7.0
sys-apps/sandbox:    2.5
sys-devel/autoconf:  2.13, 2.68
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.21
sys-devel/gcc:       4.5.2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.4-r1
sys-devel/make:      3.82
virtual/os-headers:  2.6.38 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /opt/openjms/config /usr/lib/tomoyo/conf /usr/share/bufrtables /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/maven-bin-3.0/conf /usr/share/openvpn/easy-rsa /usr/share/qpsmtpd/plugins /usr/share/themes/oxygen-gtk/gtk-2.0 /var/bind /var/lib/hsqldb /var/lib/redmine/config /var/phxd /var/qmail/alias /var/qmail/control /var/vpopmail/etc /var/yp/Makefile"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/games/angband/edit/ /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /var/lib/redmine/config/locales /var/lib/redmine/config/settings.yml"
CXXFLAGS="-O2 -pipe"
DISTDIR="/var/cache/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms split-log strict test test-fail-continue unknown-features-warn unmerge-orphans userfetch userpriv usersandbox"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.wheel.sk/"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu"
MAKEOPTS="-j14"
PKGDIR="/var/spool/portage/packages"
PORTAGE_COMPRESS=""
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/var/cache/portage/tree"
PORTDIR_OVERLAY=""
SYNC="rsync://yamato.home.flameeyes.eu/gentoo-portage"
USE="acl berkdb bzip2 cli cracklib crypt cups cxx dri fortran gdbm gpm iconv ipv6 java5 java6 modules mudflap mysql ncurses nls nostatic nptl nptlonly openmp pam pcre pcsc-lite perl postgres pppd python qt3support readline ruby session ssl sysfs tcpd unicode vhosts x86 xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias auth_digest cgi" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18 jruby ruby19 ree18" USERLAND="GNU" VIDEO_CARDS="intel radeon nouveau vmware" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Tony Vroon gentoo-dev 2013-10-18 10:57:53 UTC
I saw similar failures with 1.05 and believe this to be fixed in 1.06; could you confirm please?
Comment 2 Dennis Lichtenthäler 2013-10-22 14:59:22 UTC
1.05 used to build fine for me, 1.06 seems to have a problem within the rts script:

env - /bin/sh rts.sh 2>&1 | cat -v > rts
diff -u rts.exp rts
--- rts.exp     2013-10-22 16:56:29.000000000 +0200
+++ rts 2013-10-22 16:56:59.000000000 +0200
@@ -163,8 +163,8 @@
 softlimit: fatal: unable to run ./nonexistent: file does not exist
 111
 --- softlimit -p0 still allows exec
-./nonexistent
-0
+softlimit: fatal: unable to run echo: temporary failure
+111
 --- supervise starts, svok works, svup works, svstat works, svc -x works
 100
 100
make: *** [rts] Error 1
Comment 3 Dennis Lichtenthäler 2013-10-22 14:59:49 UTC
Created attachment 361628 [details]
1.06 build log
Comment 4 Tony Vroon gentoo-dev 2013-10-22 15:28:56 UTC
That's the failure I had with 1.05 that went away with 1.06; it seems rather fragile then...
Comment 5 Lars Wendler (Polynomial-C) gentoo-dev 2014-09-22 08:38:08 UTC
daemontools-encore-1.10 is in the tree. Please test and report back if this version fixes the problem.
Comment 6 Dennis Lichtenthäler 2014-09-23 08:46:09 UTC
(In reply to Lars Wendler (Polynomial-C) from comment #5)
> daemontools-encore-1.10 is in the tree. Please test and report back if this
> version fixes the problem.

Building daemontools-encore-1.10 still fails the same way. If I run make rts within the remains at /var/tmp/portage/sys-process/daemontools-encore-1.10/work/daemontools-encore-1.10, the check succeeds.
Comment 7 Dennis Lichtenthäler 2014-09-23 08:59:47 UTC
Created attachment 385324 [details, diff]
Remove 'softlimit p0 still allows exec' test

Removing one specific test (softlimit -p0 still allows exec which runs softlimit -p0 echo ./nonexistent; echo $?) allows me to merge the package.
Comment 8 Thomas Deutschmann gentoo-dev Security 2019-01-18 02:52:16 UTC
*** Bug 536178 has been marked as a duplicate of this bug. ***
Comment 9 Thomas Deutschmann gentoo-dev Security 2019-01-18 02:56:04 UTC
Tests were moved to src_tests allowing to pass compile phase (https://gitweb.gentoo.org/repo/gentoo.git/commit/sys-process/daemontools-encore?id=1b14c147db4e7d0862cc49fb0c73e1376cf52c20).

Closing for now. Please re-open a new bug for the test failure if still present int latest version.