Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 35980 - linux-wlan-ng refuses to emerge on a Gentoo distribution using the 2.6 kernel
Summary: linux-wlan-ng refuses to emerge on a Gentoo distribution using the 2.6 kernel
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Mobile Herd (OBSOLETE)
: 45089 46787 (view as bug list)
Depends on: 32737
  Show dependency tree
Reported: 2003-12-17 01:36 UTC by Mark Miller
Modified: 2005-10-05 14:12 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Mark Miller 2003-12-17 01:36:54 UTC
When I attempted to emerge linux-wlan-ng, it halted with the phrases:

/usr/src/linux/include/linux/modversions.h does not exist!
   To fix, run 'make dep' in /usr/src/linux.

Reproducible: Always
Steps to Reproduce:
1. emerge linux-wlan-ng

Actual Results:  
/usr/src/linux/include/linux/modversions.h does not exist!
   To fix, run 'make dep' in /usr/src/linux.

Expected Results:  
Emerged properly.
Comment 1 Mark Miller 2003-12-17 02:40:24 UTC
I neglected to mention that the 2.6 kernel, when you attempt "make dep", it notes that it is deprecated, and does nothing else.

Also, apparently the linux-wlan-ng 0.2.1_pre11 when compiling it directly, complains about /usr/src/linux/arch/x86/Makefile not existing, while it should be i386 instead of x86.

Attempting to build the 0.2.1-pre16 directly worked fine. Just not nicely emerged.
Comment 2 Peter Johanson (RETIRED) gentoo-dev 2003-12-18 10:42:58 UTC
Please see bug #32737 which is a metabug i openned for all issues regarding building external modules with 2.6 kernels. "kbuild" the build system for 2.6 kernels is really nice, except for the fact that it makes sandbox violations abound when it tries to write things in /usr/src/linux.
Comment 3 Patrik Kullman 2004-01-15 07:09:26 UTC
if I make a linux-wlan-ng_pre16 ebuild, and replace the MY_ARCH variable to ARCH, and FEATURES="-sandbox" it emerges nicely.. even with pcmcia-cs 3.2.7 for pcmcia support
Comment 4 Peter Johanson (RETIRED) gentoo-dev 2004-01-15 07:26:59 UTC
I'll be adding _pre16 in soon, along with pcmcia-cs-3.2.{6,7}. Just need to do some groundwork on the linux-wlan-ng builds to get them ready for 3.2.5 stable, etc.

Thanks for the info, i'm going to be adding comments about the sandbox issues in this ebuild so people will have some chance of this actually working (see #32737 for potential real fixes)
Comment 5 Patrik Kullman 2004-01-15 12:10:30 UTC
Yeah I noted #32737 as well.

Wouldn't an einfo with a FEATURES="-sandbox" within the ebuild be enough?
I mean if it's marked ~x86 it's unstable/untested, right? ;)
Comment 6 Peter Johanson (RETIRED) gentoo-dev 2004-01-15 12:20:15 UTC
The leg work in particular i'm doing is with regards to the annoying pcmcia-cs stuff you need to do since portage can't handle dynamic SRC_URI's based on things like `has_version pcmcia-cs-3.2.5*` so on and so forth. See the currently linux-wlan-ng builds which download an old pcmcia-cs-3.2.1, then patch it up to whatever you are running. I need to get that settled for pcmcia-cs-3.2.4 (plus patches up to 3.2.7). I've got most of it done, just need to do a bit more testing. Have faith. (:
Comment 7 Heinrich Wendel (RETIRED) gentoo-dev 2004-03-13 08:49:30 UTC
what's the status of this?
Comment 8 Peter Johanson (RETIRED) gentoo-dev 2004-03-13 08:53:19 UTC
If you'd check bug #32737, this will be resolved when the new kmod.eclass is commited, and all ebuilds are moved over to using this. I'm working on the "config-kernel" tool which is needed to accompany this, and it should be ready this week.
Comment 9 Peter Johanson (RETIRED) gentoo-dev 2004-03-18 18:06:16 UTC
*** Bug 45089 has been marked as a duplicate of this bug. ***
Comment 10 Daniel Savard 2005-02-18 08:58:51 UTC
Anything new on this? I am getting an error message while trying to build linux-wlan-ng saying I should look at bug#32737 and use linux-wlan-ng-2.0.1_pre17 and disable sandbox.

So, I did:
FEATURES="-sandbox" emerge linux-wlan-ng-2.0.1_pre17
And I got:
problem in net-wirless/linux-wlan-ng-2.0.1_pre17 dependencies.
"Specific key requires an operator (net-wireless/linux-wlan-ng-2.0.1_pre17)
(try adding an '=')" exceptions.
pcmcia-cs is 3.2.5-r1
Since last update to this bug report is old, I was expecting this was finally and cleanly solved. What am I supposed to do to make it building?
Comment 11 Henrik Brix Andersen 2005-06-04 04:53:12 UTC
*** Bug 46787 has been marked as a duplicate of this bug. ***
Comment 12 Petteri Räty (RETIRED) gentoo-dev 2005-09-26 14:14:08 UTC
Please, test with experimental new ebuilds in 
Comment 13 Henrik Brix Andersen 2005-10-05 14:06:12 UTC
Please test if this problem still exists with linux-wlan-ng-0.2.2

Awaiting feedback from reporter.
Comment 14 Henrik Brix Andersen 2005-10-05 14:11:50 UTC
User reported back by e-mail:

On Wed, Oct 05, 2005 at 04:09:32PM -0500, Mark A. Miller wrote:
> I no longer have this particular hardware, since this bug was reported in
> December of 2003. So I can't really give any feedback. -.-
Comment 15 Henrik Brix Andersen 2005-10-05 14:12:37 UTC
Closing as INVALID (should be fixed in 0.2.2).