Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 358519 - media-sound/amarok-2.4.0 crash on gui display after last updates
Summary: media-sound/amarok-2.4.0 crash on gui display after last updates
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
: 367217 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-03-12 09:34 UTC by Marco Napetti
Modified: 2011-11-11 20:01 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
amarok -debug output (amarok.debug,255.16 KB, text/plain)
2011-03-12 09:35 UTC, Marco Napetti
Details
second amarok --debug output (amarok.debug,254.09 KB, text/plain)
2011-03-13 14:26 UTC, Marco Napetti
Details
amarok kcrash (maybe unrelated) (amarok-20110317-215441.kcrash,4.48 KB, text/plain)
2011-03-17 20:59 UTC, Marco Napetti
Details
Poisony playlist (current.xspf,5.41 KB, application/xml)
2011-05-18 19:09 UTC, Marco Napetti
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marco Napetti 2011-03-12 09:34:27 UTC
After last updates (I can't tell which update, I don't use amarok every day) amarok crashes when displaying his gui.

My emerge --info:
Portage 2.1.9.42 (default/linux/amd64/10.0, gcc-4.5.2, glibc-2.13-r1, 2.6.37-gentoo-r1 x86_64)
=================================================================
System uname: Linux-2.6.37-gentoo-r1-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_5600+-with-gentoo-2.0.1
Timestamp of tree: Sat, 12 Mar 2011 09:00:01 +0000
app-shells/bash:     4.2_p7
dev-java/java-config: 2.1.11-r3
dev-lang/python:     2.7.1-r1, 3.1.3-r1
dev-util/cmake:      2.8.4
sys-apps/baselayout: 2.0.1-r1
sys-apps/openrc:     0.7.0
sys-apps/sandbox:    2.5
sys-devel/autoconf:  2.13, 2.68
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.21
sys-devel/gcc:       4.5.2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.4-r1
sys-devel/make:      3.82
virtual/os-headers:  2.6.36.1 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA skype-eula dlj-1.1 PUEL AdobeFlash-10.1"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -pipe -O2"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/openvpn/easy-rsa /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -pipe -O2"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps=y"
FEATURES="assume-digests binpkg-logs candy distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="it_IT.UTF-8"
LC_ALL="it_IT.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="it"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/home"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac aalib acl addbookmarks alias alsa amd64 amr amuled apache2 audiofile autoreplace avi bash-completion berkdb bluetooth boost branding browserplugin bzip2 cdaudio cdb cdda cddb cdinstall cdio cdparanoia cdr cleartype cli clucene codecs connectionstatus contactnotes cpudetection cracklib crypt css ctype cups curl custom-optimization cxx dbus decibel dga divx4linux dlloader dri dts dv dvb dvd dvdr dvdread dxr3 edl emul-linux-x86 encode exif extensions faad fam fame ffmpeg filter firefox flac fontconfig fortran ftp gadu gcj gd gdbm ggi gif gimp gimpprint git glib glitz gnutls gpm groupwise gstreamer highlight history hou iconv idn ieee1394 imagemagick imap imlib inquisitio insecure-drivers ipv6 irc ithreads jack java javascript jingle jpeg jpeg2k kde lame lcd lcdfilter libcaca libnotify live lm_sensors lzo mad matroska messenger mikmod mime mjpeg mmx mmxext modules monkey moodbar mozbranding mozdevelop mozilla mp3 mp4 mpeg msn msword mudflap multilib musepack musicbrainz mysql mysqli mythtv ncurses nepomuk netmeeting nls nodrm nowin nowlistening nptl nptlonly nsplugin objc objc++ objc-gc offensive ogg oggvorbis opengl openmp pam pcre pdf perl phonon php plasma png ppds pppd python qt qt-copy qt3support qt4 quicktime rar rdp readline remote replytolist samba sametime scanner sdl semantic-desktop sensord session slp smp sms sndfile sou sound speex sqlite sse sse2 ssl startup-notification statistics subversion svg sysfs taglib tcpd telepathy texteffect tga theora threads tidy tiff tokenizer translator truetype truetype-fonts unicode upnp usb v4l v4l2 vcd video videos visualization vnc vorbis wavpack webdav webpresence wifi winpopup wlm xanim xattr xcb xcomposite xine xinerama xml xmlpatterns xmlreader xmlwriter xorg xscreensaver xv xvid xvmc yahoo zip zlib" ALSA_CARDS="emu10k1" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="worker" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DVB_CARDS="tda10046" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="it" LIRC_DEVICES="livedrive_midi" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" SANE_BACKENDS="epson2" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Reproducible: Always
Comment 1 Marco Napetti 2011-03-12 09:35:35 UTC
Created attachment 265613 [details]
amarok -debug output
Comment 2 Franz Trischberger 2011-03-13 07:27:34 UTC
I could not find any information about a crash in the debug-output. It just shows some Debug-Output.
Didn't you get the kcrash-Dialog? If amarok really crashed, it should have popped up, with a (hopefully) useful callstack.

Possibly amarok just starts minimized? Did you get a systray-icon? Does amarok show up, when you start amarok again (press the icon, start in console, ...)?
Comment 3 Marco Napetti 2011-03-13 10:34:28 UTC
When I start amarok, the splash screen appears, ask me the password for the portlet and then goes on systray.
From the systray it works using the right click, for example I can start the actual playlist (from the last time I used it).
If I left click on the systray, few lines are drawed on the screen and then amarok disappers, both from the screen and the systray, without any crash report.
If I restart amarok It reloads from the beginning with the splash screen.

If I launch an already running amarok (still on systray) on console appears those messages:
Amarok is already running!
amarok(12854)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
amarok(12854)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
amarok(12854)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
amarok(12854)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 

Sorry for my bad english
Comment 4 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2011-03-13 13:51:42 UTC
You need to run "amarok --debug" twice before amarok will show all the debug information. Please do so from the console and paste the relevant log here.
Comment 5 Marco Napetti 2011-03-13 14:26:34 UTC
Created attachment 265727 [details]
second amarok --debug output

I had already done it twice.
Now I've done as first command
amarok --debug 2> amarok.debug
and then
amarok --debug
the result is the same as clicking on the systray icon: amarok crashes.
Comment 6 Franz Trischberger 2011-03-14 10:14:51 UTC
Searching the output for "crash" or "seg" does not show any result - so not really useful.

Could you run in a terminal
$ gdb amarok
(gdb) run

Then make amarok "crash". Go to the terminal and type
(gdb) bt

This should give you a backtrace of all the recent function calls in all started threads, and information about the thread that crashed amarok.
Comment 7 Marco Napetti 2011-03-14 19:26:43 UTC
No way, I also re-emerged amarok with debug USE flag, but the output is always the same:

gdb amarok
GNU gdb (Gentoo 7.2 p1) 7.2
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-pc-linux-gnu".
For bug reporting instructions, please see:
<http://bugs.gentoo.org/>...
Reading symbols from /usr/bin/amarok...(no debugging symbols found)...done.
(gdb) run
Starting program: /usr/bin/amarok 
Traceback (most recent call last):
  File "/usr/share/gdb/auto-load/usr/lib64/gcc/x86_64-pc-linux-gnu/4.5.2/libstdc++.so.6.0.14-gdb.py", line 59, in <module>
    from libstdcxx.v6.printers import register_libstdcxx_printers
ImportError: No module named libstdcxx.v6.printers
[Thread debugging using libthread_db enabled]
KGlobal::locale::Warning your global KLocale is being recreated with a valid main component instead of a fake component, this usually means you tried to call i18n related functions before your main component was created. You should not do that since it most likely will not work 

(amarok:13351): GStreamer-CRITICAL **: gst_debug_add_log_function: assertion `func != NULL' failed
amarok(13351)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
amarok(13351)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
amarok(13351)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
amarok(13351)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
amarok(13351)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
********************************************************************************************** 
** AMAROK WAS STARTED IN NORMAL MODE. IF YOU WANT TO SEE DEBUGGING INFORMATION, PLEASE USE: ** 
** amarok --debug                                                                           ** 
********************************************************************************************** 

Program exited normally.
(gdb) HTTP GET  QUrl( "http://post.audioscrobbler.com:80/?hs=true&p=1.2.1&c=ark&v=2.4.0&u=nappa85&t=1300130173&a=56ade805f6098f6943808797571dbbac&api_key=402d3ca8e9bc9d3cf9b85e1202944ca5&sk=d5692d06b5218b035579c861c1e3f5fe" )  
amarok(13351)/kdecore (KPluginInfo) KPluginInfo::kcmServices: found 0 offers for "Amarok Script Console"
amarok(13351)/kdecore (KPluginInfo) KPluginInfo::kcmServices: found 0 offers for "Amarok2Remote"
amarok(13351)/kdecore (KPluginInfo) KPluginInfo::kcmServices: found 0 offers for "LyricWiki"
amarok(13351)/kdecore (KPluginInfo) KPluginInfo::kcmServices: found 0 offers for "Cool Streams"
amarok(13351)/kdecore (KPluginInfo) KPluginInfo::kcmServices: found 0 offers for "Librivox.org"
"OK
6149f8ba083d4fdeb74abdcdd6faa4cb
http://post.audioscrobbler.com:80/np_1.2
http://post2.audioscrobbler.com:80/protocol_1.2" 
 QUrl( "http://ws.audioscrobbler.com/2.0/?api_key=402d3ca8e9bc9d3cf9b85e1202944ca5&lang=it&method=user.getNeighbours&user=nappa85" )  
 QUrl( "http://ws.audioscrobbler.com/2.0/?api_key=402d3ca8e9bc9d3cf9b85e1202944ca5&lang=it&method=user.getFriends&user=nappa85" )  
 QUrl( "http://ws.audioscrobbler.com/2.0/?api_key=402d3ca8e9bc9d3cf9b85e1202944ca5&lang=it&method=user.getTopTags&user=nappa85" )  
 QUrl( "http://ws.audioscrobbler.com/2.0/?api_key=402d3ca8e9bc9d3cf9b85e1202944ca5&lang=it&method=user.getTopArtists&user=nappa85" )  
amarok(13351)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
amarok(13351)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
amarok(13351)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
amarok(13351)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0) 
bt
No stack.
(gdb) bt
No stack.
(gdb)
Comment 8 Marco Napetti 2011-03-17 20:59:51 UTC
Created attachment 266285 [details]
amarok kcrash (maybe unrelated)

I still have the problem, fortunately I can browse my collection using Amarok2 Remote for android.
I just had a crash from amarok when closing it with the right click on the systray, I don't know if the crash is related to the main problem but hope this can help.
Comment 9 Marco Napetti 2011-03-18 20:36:33 UTC
Ok, call me crazy, but now it works and I didn't do anything since iesterday...
The only things I've done are normal system updates and I've empty the playlist using Amarok2 Remote from Android before closing Amarok (maybe it has been when it crashed with the kcrash dialog? I don't remember).

Thanks for the support.
Comment 10 Jeroen Roovers (RETIRED) gentoo-dev 2011-05-17 10:14:52 UTC
*** Bug 367217 has been marked as a duplicate of this bug. ***
Comment 11 Marco Napetti 2011-05-18 15:23:41 UTC
My new bugreport was more accurate, tagging it as a duplicate I think it will be ignored...
Comment 12 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2011-05-18 17:30:15 UTC
(In reply to comment #11)
> My new bugreport was more accurate, tagging it as a duplicate I think it will
> be ignored...

Just add the information here.

Reading through the other bug report I get the idea you may have an issue with some of the tracks in the playlist. If you can, please try to identify the tracks that cause issues and let us know their format.
Comment 13 Marco Napetti 2011-05-18 17:53:30 UTC
Unfortunately, after some tests, now amarok doesn't go on systray but immediately exits.
On the few tests I have done, always with the Katatonia album Viva Emptiness, it's only the full album that causes the problem.
Removing the first track, for example, solves the problem.
But the first track alone doesn't give any problem.
At this moment I'm unable to do more tests until I found a new way to empty the playlist...
Comment 14 Marco Napetti 2011-05-18 19:09:38 UTC
Created attachment 273867 [details]
Poisony playlist

This is amarok's current playlist file.
Using this file amarok doesn't works, but simply commenting out a single track from the file amarok returns to work fine.
Comment 15 Mauro Rizzato 2011-05-24 16:30:53 UTC
Same to me.
Amarok doesn't crash: gdb report the it exit normally.
I investigated it:
1) deleted the file .kde4/share/apps/amarok/current.xspf
2) amarok run correctly with an empty palylist
3) add some songs to the play list (about 10)
4) exit from amarok and re-run amarok: start correctly
5) add other songs: run correctly
6) deleted some songs: amarok exit after the splash screen

I saved the two file current.xspf, the first has 20 songs, the second 18. I noted that this happen when the last row in the playlist is partially visible.
So if you start amarok without playlist, modify the windows size, restore the previous playlist, amarok will start correctly.

It seems that this happen when the last item of the playlist is partially visible. And only if it is the last in the playlist.
Comment 16 Martin Luessi 2011-06-12 09:25:19 UTC
I have the same problem with both, 2.4.0 and 2.4.1. I searched the kde bug database but couldn't find anything. Does anyone know if the amarok devs are aware of this bug?
Comment 17 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2011-10-24 14:44:03 UTC
Please test amarok-2.4.3.
Comment 18 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2011-11-09 18:16:26 UTC
Given there weren't recent reports about this issue, I plan to close it in a few days as OBSOLETE.
Comment 19 Marco Napetti 2011-11-11 19:56:29 UTC
I successfully tested with amarok 2.4.3, the problem doesn't seem to exist no more.