Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 357667 - app-portage/[k]elogviewer-1.0.0 version bump/addition
Summary: app-portage/[k]elogviewer-1.0.0 version bump/addition
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal with 1 vote (vote)
Assignee: Paul Varner (RETIRED)
URL: http://sourceforge.net/projects/elogv...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-06 16:08 UTC by Mathias Laurin
Modified: 2015-02-08 16:22 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
ebuild for elogviewer 1.0.1 (elogviewer-1.0.1.ebuild,1.84 KB, text/plain)
2013-01-30 10:28 UTC, poncho
Details
fix setup.py (fix-path-in-setup.patch,880 bytes, patch)
2013-01-30 10:29 UTC, poncho
Details | Diff
version bump (elogviewer-2.0.ebuild,1.28 KB, text/plain)
2013-06-06 22:06 UTC, Mathias Laurin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mathias Laurin 2011-03-06 16:08:03 UTC
I released elogviewer 1.0.0 on sourceforge.

It now comprises both elogviewer (gtk frontend) and kelogviewer (qt frontend --- updated to qt4)

Reproducible: Always

Steps to Reproduce:
Please note that, although the UI is mostly untouched, the program has been heavily refactored. Whereas it used to live in a single file, I split the code such as the pygtk code and the core of the functionality are in separate files. That in turned allowed me to resurrect the pyqt version (now obviously PyQt4).
Actual Results:  
Everything is now in the directory libelogviewer. There also is a python launcher ./libelogviewer/elogviewer.py that takes care of parsing the command line arguments and selecting the frontend.

Expected Results:  
The ebuild should therefore propose the user to either 
1. install and use the gtk2 frontend (USE=gtk), with dependencies on dev-python/pygtk and gnome-base/librsvg and install an "elogviewer" shell script launcher in /usr/bin similar to the one I include in the root of the archive
2. install and use the qt4 frontend (USE=qt or kde), with dependency on dev-python/PyQt4 only and install a "kelogviewer" shell script launcher in /usr/bin similar to the one I include in the root of the archive
3. there is no problem I am aware of installing with both frontends

I also included an icon for the program in the svg format, it comes from gnome and is gpl2 as well. It is saved in libelogviewer/rsc/scalable. I did not rename it either.
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2011-03-07 22:15:29 UTC
<overlay contact="gentoo-desktop+subscribe@lists.gentoo.org" name="kde-sunset" ...>

IMO this is wrong. Mailing lists are not bugzilla subscribers, so please change [1] to reflect that, or bugs cannot be assigned appropriately.

I am probably wrong in assigning this to kde@ but it's the closest I could find right now.


[1] http://www.gentoo.org/proj/en/overlays/layman-global.txt
Comment 2 Theo Chatzimichos (RETIRED) archtester gentoo-dev Security 2011-03-07 22:52:54 UTC
it is properly documented: 
http://www.gentoo.org/proj/en/desktop/kde/kde4-guide.xml#doc_chap1
Comment 3 Jeroen Roovers (RETIRED) gentoo-dev 2011-03-08 18:44:54 UTC
Maybe you should make a note of that in layman-global.txt. How else can people know they should not file a bug report?
Comment 4 Theo Chatzimichos (RETIRED) archtester gentoo-dev Security 2011-03-08 19:01:31 UTC
it is already there (if that's what you mean):

<overlay contact="gentoo-desktop+subscribe@lists.gentoo.org" name="kde-sunset" src="git://git.overlays.gentoo.org/proj/kde-sunset.git" status="unofficial" type="git">
    <!-- THIS FILE IS GENERATED, PLEASE EDIT repositories.xml INSTEAD. -->
    <link>http://git.overlays.gentoo.org/gitweb/?p=proj/kde-sunset.git;a=summary</link>
    <description>User-maintained overlay for old KDE packages removed from the tree, such as KDE3.</description>
  </overlay>

Plus we advertised it a lot when we removed kde3 from tree, what else can we do?
Comment 5 Jeroen Roovers (RETIRED) gentoo-dev 2011-03-08 19:21:13 UTC
Index: layman-global.txt
===================================================================
RCS file: /var/cvsroot/gentoo/xml/htdocs/proj/en/overlays/layman-global.txt,v
retrieving revision 1.483
diff -u -B -r1.483 layman-global.txt
--- layman-global.txt   3 Mar 2011 11:29:03 -0000       1.483
+++ layman-global.txt   8 Mar 2011 19:20:35 -0000
@@ -600,7 +600,8 @@
   <overlay contact="gentoo-desktop+subscribe@lists.gentoo.org" name="kde-sunset" src="git://git.overlays.gentoo.org/proj/kde-sunset
.git" status="unofficial" type="git">                                                                                                    <!-- THIS FILE IS GENERATED, PLEASE EDIT repositories.xml INSTEAD. -->
     <link>http://git.overlays.gentoo.org/gitweb/?p=proj/kde-sunset.git;a=summary</link>
-    <description>User-maintained overlay for old KDE packages removed from the tree, such as KDE3.</description>
+    <description>User-maintained overlay for old KDE packages removed from the tree, such as KDE3.
+       Please do not file bug reports, but subscribe to the contact mailing list.</description>
   </overlay>
   <overlay contact="mueli@gentoo.org" name="kerberos" src="git://git.overlays.gentoo.org/proj/kerberos.git" status="unofficial" typ
e="git">                                                                                                                                 <!-- THIS FILE IS GENERATED, PLEASE EDIT repositories.xml INSTEAD. -->
Comment 6 Mathias Laurin 2011-03-08 20:28:16 UTC
I believe there was some misunderstanding in this thread.


elogviewer and kelogviewer is an application that displays gentoo's elogs, generated by portage. I am now proposing it with two frontends: elogviewer uses gtk and kelogviewer, qt.

elogviewer (gtk2 frontend) has been slightly updated, with only a few user-facing changes.

kelogviewer (qt4 frontend) has been updated to run with the current version of qt in the tree, i.e., qt4. It is not a KDE application, it does not require KDE. It actually has nothing to do with KDE, it only uses the same toolkit, and should therefore look native in KDE.


elogviewer and kelogviewer are now two frontends to the same codebase, I am not sure that having an ebuild for each is a good idea, but I definitely leave that up to you, maintainers.


Since I honestly have no idea how anything that has been discussed in the thread so far applies to my poor little software, I would like to reopen this bug and  kindly ask again for its update/inclusion in the tree.


Thank you for giving a little bit more consideration to my contribution, no matter how little it appears to be.
Comment 7 Theo Chatzimichos (RETIRED) archtester gentoo-dev Security 2011-03-09 00:48:09 UTC
Yeah, there has been a communication failure here. Anyway, Jeroen reassigned it to proper maintainers (and as a side note I did the update in layman xml file)
Sorry for the noise
Comment 8 Mathias Laurin 2011-05-06 13:35:24 UTC
Please do not hesitate to tell me if I may help in any way to get this update into the tree. I think the Qt version, even though it may not be perfect, is a worthy addition to this program.
Comment 9 Brian Dolbec gentoo-dev 2011-05-06 14:48:10 UTC
Mathias, we now have a gentoo-guis overlay for development work on guis for gentoo tools.  We can help you get the ebuild/installation sorted out and host the ebuild in the overlay. Once it is proven good it should be easy to move it to the tree.

There is an email list for gentoo-guis and #gentoo-guis on the freenode irc network.  Come join us, the more the better.
Comment 10 David J Cozatt 2011-05-29 13:23:38 UTC
could this be added to $ARCH for testing? I've a suggestion or two for this application but cannot even test a current version.

I'd love to see a script to run that showed in a pane the $date postinstall information

Perhaps it already has something like this but cannot say.

Seems to be a nice tool Thanks Mathias ;)
Comment 11 Paul Varner (RETIRED) gentoo-dev 2011-08-10 03:15:23 UTC
Mathias,

I'm not having fun trying to get this working properly.  I am unable to get elogviewer or kelogviewer to run at all from the elogviewer-1.0.0.tar.bz2 file from sourceforge.  This really needs a lot more work before we can put it into the tree.  I'm willing to work with you but your best bet is to probably work with gentoo-guis overlay since there are several people that can help with getting this working well.

My advice would be to take the time to figure out how to make the package installable using distutils from python.  Once that is done, it is fairly simple for me to write an ebuild to install the software correctly.
Comment 12 poncho 2013-01-30 10:28:38 UTC
Created attachment 337300 [details]
ebuild for elogviewer 1.0.1

The ebuild is only tested on amd64 with python2_7
Comment 13 poncho 2013-01-30 10:29:15 UTC
Created attachment 337302 [details, diff]
fix setup.py
Comment 14 poncho 2013-01-31 18:45:26 UTC
And it's broken again after today's update :(
Comment 15 Julian Ospald 2013-04-24 15:36:39 UTC
I get lots of Index out of range errors in get_contents() function, e.g. when the elog file has "ERROR: pretend", then again "ERROR: setup" works.

I cloned from svn (where is the new repo?) which appears to have version 0.7.0. I added xz and gz support and it seems relatively stable.
Comment 16 Mathias Laurin 2013-05-08 20:54:58 UTC
(In reply to comment #15)
> I cloned from svn (where is the new repo?) which appears to have version
> 0.7.0. I added xz and gz support and it seems relatively stable.

on git

git clone git://git.code.sf.net/p/elogviewer/code elogviewer-code
Comment 17 Mathias Laurin 2013-06-06 22:06:25 UTC
Created attachment 350310 [details]
version bump

- works for me on amd64 in a VM with PyQt4 (pyside segfaults)
- the program (not the ebuild) was tested on python 2.7 and python 3
Comment 18 Brian Dolbec gentoo-dev 2013-06-15 00:15:50 UTC
OK, starting some testing.  it works on python-2.6 and up, but since I didn't have argparse intalled in 3.1 it fails, so, I'll add the argparse dep for 2.6 & 3.1

Is there a way to set column widths?  It's annoying having to make the window real wide just to get the timestamp to show in one line, and have other columns with a single icon super wide.

Second.  Is there a way to change the light yellow error text on a white background to something else?

I'll push the 2 ebuilds, 2.0 & 2.1 to gentoo-guis after adjusting the ebuild.
Comment 19 Brian Dolbec gentoo-dev 2013-06-15 02:10:45 UTC
Well, virtual/argparse was already in the ebuild.
updated to add python-2.6.

I've pushed both 2.0 and 2.1 ebuilds to the gentoo-guis overlay for initial testing/debugging.

One small code bug I've noticed.  The important flag is being set at times when changing the selection.  Not clicking the important column.

Color selection.  I see it is hard coded in the source.  I changed the error to red and the warn to papaya orange, ... much better :)

                if line.startswith("ERROR:"):
                    prefix = '<p style="color: red">'
                elif line.startswith("WARN:"):
                    prefix = '<p style="color: #E56717">'
Comment 20 Mathias Laurin 2013-06-15 20:03:56 UTC
> I've pushed both 2.0 and 2.1 ebuilds to the gentoo-guis overlay for initial
> testing/debugging.

thank you

> One small code bug I've noticed.  The important flag is being set at times
> when changing the selection.  Not clicking the important column.

I do not know how this is even possible. I could make the 'important' flag react only on double click?..

> Color selection.  I see it is hard coded in the source.  I changed the error
> to red and the warn to papaya orange, ... much better :)

That is fixed in 2.1a. The keyboard shortcuts are also now shown in the tooltip to make them more obvious.
Comment 21 Ondrej Grover 2013-08-11 08:00:36 UTC
Tested elogviewer-2.1 from gentoo-guis overlay.
Works like charm, a wonderful program :)
I think I'll start using it instead of elogv, the read/undread and important bookmaking for later processing is a great idea.

The only thing missing that elogv has better is that the "Highest eclass" only lists the name of the eclass, not the color like elogv. If colorizing in that column was added, that would be great.
Comment 22 Mathias Laurin 2013-08-22 21:54:07 UTC
(In reply to Ondrej Grover from comment #21)
> Tested elogviewer-2.1 from gentoo-guis overlay.
> Works like charm, a wonderful program :)

Thank you!

> The only thing missing that elogv has better is that the "Highest eclass"
> only lists the name of the eclass, not the color like elogv. If colorizing
> in that column was added, that would be great.

I added that in 2.2. The ebuild is on sourceforge as well.