Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 356479 - dev-libs/boost-1.46.1 and boost-build-1.46.1 version bump
Summary: dev-libs/boost-1.46.1 and boost-build-1.46.1 version bump
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Tiziano Müller
URL:
Whiteboard:
Keywords: InOverlay
Depends on: 357609
Blocks:
  Show dependency tree
 
Reported: 2011-02-25 21:36 UTC by Myk Taylor
Modified: 2011-03-22 09:52 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
all overlay files required to build (boost-1.46.overlay.tgz,9.40 KB, application/octet-stream)
2011-02-25 21:37 UTC, Myk Taylor
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Myk Taylor 2011-02-25 21:36:13 UTC
boost-1.46 is out.  I found that renamed 1.45 ebuilds worked just fine.  I'll attach the renamed files I have in my overlay.

Note that filesystem v3 classes are used by default as of this version, which might break other projects that depend on v2 behavior without #defining BOOST_FILESYSTEM_VERSION 2

Reproducible: Always
Comment 1 Myk Taylor 2011-02-25 21:37:02 UTC
note: tested on stable amd64
Comment 2 Myk Taylor 2011-02-25 21:37:47 UTC
Created attachment 263855 [details]
all overlay files required to build
Comment 3 Myk Taylor 2011-03-02 02:24:11 UTC
confirmed that at least media-gfx/exiv2-0.19 and media-video/mkvtoolnix-4.4.0 fail to build with boost-1.46.0.  app-office/akonadi-server-1.4.1 built fine, though.
Comment 4 tman 2011-03-02 06:12:52 UTC
i can confirm that some applications failes on compile with new boost.

/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.2/include/g++-v4/bits/basic_string.h:540:7: note:                 std::basic_string<_CharT, _Traits, _Alloc>& std::basic_string<_CharT, _Traits, _Alloc>::operator=(const _CharT*) [with _CharT = char, _Traits = std::char_traits<char>, _Alloc = std::allocator<char>, std::basic_string<_CharT, _Traits, _Alloc> = std::basic_string<char>]
/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.2/include/g++-v4/bits/basic_string.h:551:7: note:                 std::basic_string<_CharT, _Traits, _Alloc>& std::basic_string<_CharT, _Traits, _Alloc>::operator=(_CharT) [with _CharT = char, _Traits = std::char_traits<char>, _Alloc = std::allocator<char>, std::basic_string<_CharT, _Traits, _Alloc> = std::basic_string<char>]
/var/tmp/portage/media-video/cclive-0.7.2/work/cclive-0.7.2/cclive/src/file.cpp: In function ‘boost::filesystem3::path cclive::output_dir(const boost::program_options::variables_map&)’:
/var/tmp/portage/media-video/cclive-0.7.2/work/cclive-0.7.2/cclive/src/file.cpp:336:33: warning: ignoring return value of ‘char* getcwd(char*, size_t)’, declared with attribute warn_unused_result
/usr/include/boost-1_46/boost/system/error_code.hpp: At global scope:
/usr/include/boost-1_46/boost/system/error_code.hpp:214:36: warning: ‘boost::system::posix_category’ defined but not used
/usr/include/boost-1_46/boost/system/error_code.hpp:215:36: warning: ‘boost::system::errno_ecat’ defined but not used
/usr/include/boost-1_46/boost/system/error_code.hpp:216:36: warning: ‘boost::system::native_ecat’ defined but not used
make[2]: *** [cclive/CMakeFiles/cclive.dir/src/file.cpp.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[1]: *** [cclive/CMakeFiles/cclive.dir/all] Error 2
make: *** [all] Error 2
emake failed
 * ERROR: media-video/cclive-0.7.2 failed (compile phase):

Portage 2.1.9.41 (default/linux/amd64/10.0/desktop, gcc-4.5.2, glibc-2.13-r1, 2.6.37-gentoo-r1 x86_64)
=================================================================
System uname: Linux-2.6.37-gentoo-r1-x86_64-Intel-R-_Core-TM-2_Duo_CPU_P9700_@_2.80GHz-with-gentoo-2.0.1
Timestamp of tree: Wed, 02 Mar 2011 05:30:01 +0000
app-shells/bash:     4.1_p10
dev-java/java-config: 2.1.11-r3
dev-lang/python:     2.7.1-r1, 3.1.3-r1
dev-util/cmake:      2.8.4
sys-apps/baselayout: 2.0.1-r1
sys-apps/openrc:     0.7.0
sys-apps/sandbox:    2.5
sys-devel/autoconf:  2.13, 2.68
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.21
sys-devel/gcc:       4.5.2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.4-r1
sys-devel/make:      3.82
virtual/os-headers:  2.6.36.1 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/boot/grub/40_custom /etc /etc/X11/Sessions/awesome /etc/X11/Sessions/dwm /etc/X11/xorg.conf /etc/apache2/httpd.conf /etc/conf.d/hwclock /etc/conf.d/keymaps /etc/default/grub /etc/fstab /etc/grub.d/05_theme /etc/make.conf /etc/xdg/openbox/autostart.sh /etc/xdg/openbox/menu.xml /etc/xdg/openbox/rc.xml /etc/xdg/openbox/start /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /usr/share/xsessions/openbox.desktop /var/bind /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=core2 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs buildpkg distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="de_DE.UTF-8"
LC_ALL=""
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de en vi"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/emacs /usr/portage/local/layman/lorelei /usr/portage/local/layman/lxde /usr/portage/local/layman/mgorny /usr/portage/local/layman/mpd /usr/portage/local/layman/mellon /usr/portage/local/layman/scarabeus /usr/portage/local/layman/wirelay /usr/portage/local/layman/java-overlay /usr/portage/local/layman/poly-c /usr/portage/local/layman/techwolf /usr/portage/local/layman/bleeding-edge /usr/portage/local/layman/nikai /usr/portage/local/layman/science /usr/portage/local/layman/qting-edge /usr/portage/local/layman/roslin /usr/portage/local/local-overlay"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="*+ X a52 aac aalib accessibility acl acpi adns afs aim alsa amd64 ao apache2 ass atm audio audiofile bash-completion beagle berkdb bidi bluetooth branding bzip2 cairo caps cdda cdio cdparanoia cdr cgi cjk clamdtop cli clisp consolekit cracklib crypt cscope css csv cups curl curlwrappers cvs cxx dbus dc1394 dga dhcp dhcpcd dia dirac directfb dmx dri dts dv dvd dvdr dvi emacs emboss enca encode enscript exceptions exif expat extras faac faad fam fastcgi fbcon ffmpeg firefox flac flash fortran ftp fuse gcj gd gdbm gdu geoip ggi gif gimp git glib gmp gnome gnome-keyring gnutls gphoto2 gpm graphviz gs gstreamer gtk gzip hal hash hddtemp highlight httpd iconv icq icu idn ieee1394 imagemagick imap imlib ipv6 ithreads jabber jack java java6 javascript jingle joystick jpeg jpeg2k kerberos lame lapack latex lcms ldap libcaca libnotify libwww live logrotate lua lzo mad maildir matroska mbrola md5sum memlimit mercurial mhash midi mikmod milter mime mjpeg mmap mmx mmxext mng modules mono motif mp3 mp4 mpeg mplayer msn mudflap mule multilib musepack mysql nas nautilus ncurses netboot network networkmanager nfs nls nptl nptlonly nsplugin nvidia ogg ogg123 openal openexr opengl openmp oss pam pango pcap pcmcia pcre pdf perl php pic pidgin png policykit posix postgres ppds pppd ps pulseaudio python qt3support qt4 quicktime radio rar raw rdesktop readline reflection rss rtsp ruby samba sasl savedconfig schroedinger sdl sdl-image session sip slang slp smp soap sockets sox spamassassin speex spell spl sqlite sse sse2 ssl ssse3 startup-notification stream stun subversion svg swat sysfs syslog sysvipc tcl tcpd theora threads tidy tiff timidity tk tokenizer truetype udev unicode urandom usb userlocales v4l v4l2 vcd vhosts video vim-syntax vlm vnc vorbis wav wavpack webkit wifi wma wmf wxwidgets x264 xattr xcb xcomposite xft xinerama xinetd xml xmlrpc xorg xpm xscreensaver xsl xulrunner xv xvid xvmc yahoo zip zlib zsh-completion" ALSA_CARDS="hda_intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation php5 proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="worker" CAMERAS="canon" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard synaptics evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de en vi" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18 jruby" USERLAND="GNU" VIDEO_CARDS="nv nvidia vesa fbdev vga nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 5 Myk Taylor 2011-03-06 19:25:37 UTC
(In reply to comment #4)
>  * ERROR: media-video/cclive-0.7.2 failed (compile phase):
I made patches for exiv2 and mkvtoolnix (see bug 357605 and bug 357609), but I couldn't get cclive to compile at all on my system due to non-boost reasons (errors about "QUIET"?).  Not quite sure what's going on there.
Comment 6 Markos Chandras (RETIRED) gentoo-dev 2011-03-14 01:37:58 UTC
Renaming the 1.45.0 ebuilds to 1.46.1 fails when trying to use eselect to make the new boost the default one. I have to find sometime to understand why is wrong with it. If someone feels like testing, rename the ebuilds and drop the 2 version specific(1.45.0) patches from dev-util/boost
Comment 7 Gert Wollny 2011-03-15 17:28:25 UTC
Tried 1.46.1 and after some debugging I found out that eselect deletes the symlinks of type libboost_bla-1_46_1.so because the eselect scripts  assumes that the symlinks are libboost_bla-X_XX.(a|so) 
(See boost-eselect line 43) 
Since my knowledge of regular expressions is limited I don't yet know how to fix this.
Comment 8 Markos Chandras (RETIRED) gentoo-dev 2011-03-15 19:17:23 UTC
The updated ebuilds are in my overlay. Please give them a shot. Thanks to Sebastian Luther for his work. The ETA for portage inclusion is 5 days from today (hopefully)
Comment 9 Sebastian Luther (few) 2011-03-15 19:57:10 UTC
If someone hits boost.filesystem related failures: An easy hack is:
inherit flag-o-matic
append-flags -DBOOST_FILESYSTEM_VERSION=2

If the build system doesn't respect CXXFLAGS, patch the source to contain 
#define BOOST_FILESYSTEM_VERSION 2
before any boost.filesystem header is included.

Note that support for version 2 will not be included in boost-1.48 and later and upstream should migrate to version 3.
Comment 10 Markos Chandras (RETIRED) gentoo-dev 2011-03-22 09:52:41 UTC
The ebuilds are on tree now but masked. Thank you