Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 356373 - media-video/avidemux-2.5.4-r1 fails to build with >=media-libs/x264-0.0.20110223
Summary: media-video/avidemux-2.5.4-r1 fails to build with >=media-libs/x264-0.0.20110223
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Markos Chandras (RETIRED)
: 357195 (view as bug list)
Depends on:
Reported: 2011-02-25 05:20 UTC by Patrick
Modified: 2011-03-12 16:29 UTC (History)
29 users (show)

See Also:
Package list:
Runtime testing required: ---

Complete build log (build.log.bz2,26.43 KB, application/x-bzip2)
2011-02-25 05:21 UTC, Patrick
c:\Users\jansa\Documents\avidemux-2.5.4-x264-X264_WEIGHTP_BLIND-fix.patch (avidemux-2.5.4-x264-X264_WEIGHTP_BLIND-fix.patch,1.06 KB, patch)
2011-02-25 10:48 UTC, Martin Jansa
Details | Diff
avidemux-2.5.4-r1.ebuild.diff (avidemux-2.5.4-r1.ebuild.diff,415 bytes, patch)
2011-02-25 10:48 UTC, Martin Jansa
Details | Diff
Avidemux 2.5 r6787 (Patch) (avidemux-2.5-r6787.patch,3.96 KB, patch)
2011-03-10 07:29 UTC, Dennis Schridde
Details | Diff
avidemux-2.5.4-x264-version-fix.patch (avidemux-2.5.4-x264-version-fix.patch,3.91 KB, patch)
2011-03-12 10:54 UTC, PhobosK
Details | Diff
avidemux-2.5.4-r2.ebuild (avidemux-2.5.4-r2.ebuild,4.30 KB, text/plain)
2011-03-12 10:57 UTC, PhobosK

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick 2011-02-25 05:20:01 UTC
emerge @preserved-rebuild triggered a rebuild of avidemux-2.5.4-r1, but the build fails:

[ 14%] Building CXX object plugins/ADM_videoEncoder/ADM_vidEnc_x264/CMakeFiles/ADM_vidEnc_x264.dir/x264Options.cpp.o                               
/var/tmp/portage/media-video/avidemux-2.5.4-r1/work/avidemux_2.5.4/plugins/ADM_videoEncoder/ADM_vidEnc_x264/x264Options.cpp: In member function ‘virtual void x264Options::addOptionsToXml(xmlNode*)’:
/var/tmp/portage/media-video/avidemux-2.5.4-r1/work/avidemux_2.5.4/plugins/ADM_videoEncoder/ADM_vidEnc_x264/x264Options.cpp:1389:8: error: ‘X264_WEIGHTP_BLIND’ was not declared in this scope
/var/tmp/portage/media-video/avidemux-2.5.4-r1/work/avidemux_2.5.4/plugins/ADM_videoEncoder/ADM_vidEnc_x264/x264Options.cpp: In member function ‘void x264Options::parseAnalyseOptions(xmlNode*)’:
/var/tmp/portage/media-video/avidemux-2.5.4-r1/work/avidemux_2.5.4/plugins/ADM_videoEncoder/ADM_vidEnc_x264/x264Options.cpp:1899:28: error: ‘X264_WEIGHTP_BLIND’ was not declared in this scope
make[2]: *** [plugins/ADM_videoEncoder/ADM_vidEnc_x264/CMakeFiles/ADM_vidEnc_x264.dir/x264Options.cpp.o] Error 1

# emerge --info
Portage 2.2.0_alpha25 (default/linux/amd64/10.0/desktop, gcc-4.5.2, glibc-2.13-r1, 2.6.37-gentoo x86_64)
System uname: Linux-2.6.37-gentoo-x86_64-AMD_Phenom-tm-_II_X4_965_Processor-with-gentoo-2.0.1
Timestamp of tree: Fri, 25 Feb 2011 02:00:01 +0000
ccache version 3.1.4 [disabled]
app-shells/bash:     4.1_p9
dev-java/java-config: 2.1.11-r3
dev-lang/python:     2.6.6-r1, 2.7.1-r1
dev-util/ccache:     3.1.4
dev-util/cmake:      2.8.4
sys-apps/baselayout: 2.0.1-r1
sys-apps/openrc:     0.7.0
sys-apps/sandbox:    2.5
sys-devel/autoconf:  2.13, 2.68
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.21
sys-devel/gcc:       4.5.2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.4-r1
sys-devel/make:      3.82
virtual/os-headers: (sys-kernel/linux-headers)
Repositories: gentoo sunrise kde x11 mozilla local
Installed sets: 
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-march=amdfam10 -O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=amdfam10 -O2 -pipe"
EMERGE_DEFAULT_OPTS="-j --load-average=5"
FEATURES="assume-digests binpkg-logs distlocks fixlafiles fixpackages news nostrip parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_GB de de_DE zh_CN"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/var/lib/layman/sunrise /var/lib/layman/kde /var/lib/layman/x11 /var/lib/layman/mozilla /usr/local/portage"
USE="X a52 aac acl acpi alsa amd64 bash-completion berkdb bluetooth branding bzip2 cairo cddb cdr cjk cli consolekit crypt cups curl cxx dbus dri dts dvd dvdr dvdread emboss encode exif expat fam ffmpeg firefox flac foomaticdb ftp gd gdbm gdu gif gnutls gpm gtk iconv icq idn ieee1394 imagemagick imap imlib innodb ipod ipv6 jabber java javascript jingle jpeg jpeg2k kde kdehiddenvisibility lame lcms ldap libnotify lzo mad matroska md5sum midi mikmod mmap mmx mng modules mp3 mp4 mpeg mplayer msn mudflap multilib musepack musicbrainz ncurses nls nptl nptlonly nsplugin offensive ogg openal openexr opengl openmp oscar pam pango pcre pdf perl php png policykit ppds python qt3support qt4 quicktime raw rdesktop readline rss samba sdl semantic-desktop session speex spell sqlite sqlite3 sse sse2 sse3 ssl ssse3 startup-notification subversion svg sysfs syslog taglib tcpd threads tidy tiff truetype udev unicode usb vorbis wifi wmf wxwindows x264 xattr xcb xcomposite xine xinerama xml xmlrpc xorg xpm xulrunner xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="canon ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LINGUAS="en en_GB de de_DE zh_CN" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Comment 1 Patrick 2011-02-25 05:21:46 UTC
Created attachment 263745 [details]
Complete build log
Comment 2 Dennis Schridde 2011-02-25 10:45:42 UTC
Probably caused by the recent update to media-libs/x264-0.0.20110223.
Comment 3 Martin Jansa 2011-02-25 10:48:29 UTC
Created attachment 263769 [details, diff]

Fix from archlinux
Comment 4 Martin Jansa 2011-02-25 10:48:55 UTC
Created attachment 263771 [details, diff]
Comment 5 Erik Zeek 2011-02-25 11:32:20 UTC
I dropped the patch in /etc/portage/patches/media-video/avidemux and avidemux emerged just fine.

Comment 6 Billy DeVincentis 2011-02-25 12:43:42 UTC
Worked here too!!
Comment 7 Eric F. GARIOUD 2011-02-25 15:07:36 UTC
Pardon me if I do not understand why this problem should be solved by patching avidemux and why it is not reported against media-libs/x264.

1/ I would believe more coherent to patch media-libs/x264 x264.h
2/ If this patch is committed in the portage tree, then build will be broken for all those running stable media-libs/x264
3/ I do not find pertinent to force >= media-libs/x264-0.0.20110223 in avidemux' ebuild yet.
Comment 8 Erik Zeek 2011-02-25 15:36:25 UTC
(In reply to comment #7)
> Pardon me if I do not understand why this problem should be solved by patching
> avidemux and why it is not reported against media-libs/x264.

Because upstream is:

P.S.  This patch is probably better as it handles muptiple x264 versions.
Comment 9 Eric F. GARIOUD 2011-02-25 16:23:39 UTC
(In reply to comment #8)
> P.S.  This patch is probably better as it handles muptiple x264 versions.

Indeed !

Comment 10 tarek 2011-02-25 23:17:21 UTC
(In reply to comment #4)
> Created an attachment (id=263771) [details]
> avidemux-2.5.4-r1.ebuild.diff

Note this diff is absolute referenced to full portage path. One should really be making changes within an overlay to avoid clobbering files on next sync.  To use this patch properly in an overlay one will need to  establish the correct -p option for patch;  most likely -p6 which is not elegant. 

Patch itself works fine.
Comment 11 Mathieu Z 2011-03-03 10:23:19 UTC
*** Bug 357195 has been marked as a duplicate of this bug. ***
Comment 12 Dennis Schridde 2011-03-09 21:58:38 UTC
Is there any fix to this yet?
Comment 13 Markos Chandras (RETIRED) gentoo-dev 2011-03-09 22:23:11 UTC
There will be as soon as I manage to understand how this damn websvn interface works so I can export the patch of that specific revision
Comment 14 Dennis Schridde 2011-03-10 07:29:41 UTC
Created attachment 265409 [details, diff]
Avidemux 2.5 r6787 (Patch)

(In reply to comment #13)
> There will be as soon as I manage to understand how this damn websvn interface
> works so I can export the patch of that specific revision
I do not think WebSVN or ViewVC can do this. I used the following instead:
svn diff -c6787 svn:// > avidemux-2.5-r6787.patch
Comment 15 Rafał Mużyło 2011-03-10 11:28:29 UTC
*** Bug 358179 has been marked as a duplicate of this bug. ***
Comment 16 Markos Chandras (RETIRED) gentoo-dev 2011-03-10 12:32:10 UTC
Thanks for the patch. I will sort this out today
Comment 17 PhobosK 2011-03-12 10:54:25 UTC
Created attachment 265619 [details, diff]

This patch is taken from upstream and is almost as the proposed patches above, but it is with fixed lines numbers etc.
With it avidemux compiles ok. I have not tested if the x264 plug-in works as expected (the qt4 version of avidemux).
Please check it and upload it to main gentoo tree with the avidemux-2.5.4-r2.ebuild that i am uploading next.
Comment 18 PhobosK 2011-03-12 10:57:04 UTC
Created attachment 265621 [details]

This is the actual ebuild that uses the avidemux-2.5.4-x264-version-fix.patch.
Comment 19 Markos Chandras (RETIRED) gentoo-dev 2011-03-12 11:26:13 UTC
Thank you very much. This *should* be fixed in -r2. Please test it and report any problems.
Comment 20 Waldemar Szostak 2011-03-12 12:44:38 UTC
I had this problem before. Now avidemux compiles fine. Thank you.
Comment 21 Richard Cox 2011-03-12 16:29:53 UTC
It can confirm it fixed it for me...AMD64.  Thank you, great job!