Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 355931 - request: disable vala for net-libs/telepathy-glib on default
Summary: request: disable vala for net-libs/telepathy-glib on default
Status: VERIFIED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-22 00:00 UTC by Uwe Breidenbach
Modified: 2011-02-22 15:56 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Uwe Breidenbach 2011-02-22 00:00:45 UTC
Would you please disable the use-flag vala for net-libs/telepathy-glib on default, because this package pulls in dev-lang/vala, which (in my case and I think in many others too) is never used. Those who work with the vala language will probably set the vala-use by themselves.
Is this possible or is there any package, that depends on telepathy-glib with vala bindings?

Thanks

Reproducible: Always
Comment 1 Gilles Dartiguelongue gentoo-dev 2011-02-22 13:07:12 UTC
It is needed for gnome 2.32 (empathy/folks/telepathy-logger -> tp-gabble -> tp-glib[vala]).
Comment 2 Uwe Breidenbach 2011-02-22 15:06:25 UTC
I only can confirm empathy-2.32.2 -> folks-0.2.1 -> telepathy-glib[vala].
And empathy is not a default package in the gnome-2.32 ebuild. Therefore the telepathy-use, which pulled in the telepathy-glib and vala, is not necessary on default. But I think you have a different opinion on this ;)
Comment 3 Gilles Dartiguelongue gentoo-dev 2011-02-22 15:38:37 UTC
empathy is part of gnome, it's absence from meta is only due to missing keywords up until recently.
Comment 4 Uwe Breidenbach 2011-02-22 15:56:08 UTC
Ok, understood. Thanks.