Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 355883 - media-gfx/xv-3.10a-r15 fails to build with libpng-1.5
Summary: media-gfx/xv-3.10a-r15 fails to build with libpng-1.5
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Joe Peterson (RETIRED)
URL: ftp://ftp.netbsd.org/pub/pkgsrc/curre...
Whiteboard:
Keywords:
Depends on:
Blocks: libpng-1.5
  Show dependency tree
 
Reported: 2011-02-21 17:58 UTC by SpanKY
Modified: 2011-09-15 22:07 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
half assed attempt (xv-libpng-1.5.patch,6.53 KB, patch)
2011-02-21 17:58 UTC, SpanKY
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description SpanKY gentoo-dev 2011-02-21 17:58:14 UTC
i started to port this, but gave up
Comment 1 SpanKY gentoo-dev 2011-02-21 17:58:54 UTC
Created attachment 263343 [details, diff]
half assed attempt
Comment 2 Samuli Suominen gentoo-dev 2011-08-07 09:55:17 UTC
Looks like netbsd folks did the rest of way here:

ftp://ftp.netbsd.org/pub/pkgsrc/current/pkgsrc/graphics/xv/patches/patch-ae

+*xv-3.10a-r16 (07 Aug 2011)
+
+  07 Aug 2011; Samuli Suominen <ssuominen@gentoo.org> +xv-3.10a-r16.ebuild,
+  +files/xv-3.10a-libpng15.patch:
+  Fix building with libpng15 wrt #355883 by Mike Frysinger
Comment 3 Joe Peterson (RETIRED) gentoo-dev 2011-08-12 21:03:22 UTC
Re-opening this bug, since the patch in r16 causes xv to segfault during saving of PNG files, leaving partial files.  I have tried this with multiple PNGs.  I have masked r16 until we resolve it.
Comment 4 Joe Peterson (RETIRED) gentoo-dev 2011-08-12 21:04:08 UTC
Note that I tried the latest libpng15 as well - still segfaults.
Comment 5 Samuli Suominen gentoo-dev 2011-09-15 22:07:18 UTC
Unable to reproduce that. PNG saving works fine here and also for user called _AxS_.

Therefore,

  15 Sep 2011; Samuli Suominen <ssuominen@gentoo.org> xv-3.10a-r16.ebuild,
  files/xv-3.10a-libpng15.patch:
  Enchance -libpng15.patch by _AxS_ from Freenode with some bits also from
  NetBSD. Restore keywording as libpng15 is about to get unmasked and PNG
  saving is working fine here (see bug #355883)

If it still fails for you, masking/keyword dropping is unacceptable and USE="png" will have to be masked in base/package.use.mask instead.