Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 355871 - x11-libs/gdk-pixbuf-2.22.1 fails to build with libpng-1.5.x
Summary: x11-libs/gdk-pixbuf-2.22.1 fails to build with libpng-1.5.x
Status: RESOLVED DUPLICATE of bug 354557
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: libpng-1.5
  Show dependency tree
 
Reported: 2011-02-21 17:34 UTC by SpanKY
Modified: 2011-02-21 17:53 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description SpanKY gentoo-dev 2011-02-21 17:34:16 UTC
make[2]: Entering directory `/var/tmp/portage/x11-libs/gdk-pixbuf-2.22.1/work/gdk-pixbuf-2.22.1/gdk-pixbuf'
/bin/sh ../libtool  --tag=CC   --mode=compile x86_64-pc-linux-gnu-gcc -std=gnu99 -DHAVE_CONFIG_H -I. -I.. -DG_LOG_DOMAIN=\"GdkPixbuf\" -DGDK_PIXBUF_COMPILATION -I.. -I.. -I../gdk-pixbuf -I../gdk-pixbuf -DGDK_PIXBUF_LOCALEDIR=\"/usr/share/locale\" -DGDK_PIXBUF_LIBDIR=\"/usr/lib64\" -DGDK_PIXBUF_BINARY_VERSION=\"2.10.0\" -DGDK_PIXBUF_PREFIX=\"/usr\"   -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libpng15    -DGDK_PIXBUF_ENABLE_BACKEND "-DPIXBUF_LIBDIR=\"/usr/lib64/gdk-pixbuf-2.0/2.10.0/loaders\"" "-DBUILT_MODULES_DIR=\"./.libs\"" -DCPPFLAGS_TEST -DG_DISABLE_SINGLE_INCLUDES  -DGDK_PIXBUF_DISABLE_DEPRECATED -O2 -march=k8 -pipe -g -Wimplicit-function-declaration -Wall -MT io-png.lo -MD -MP -MF .deps/io-png.Tpo -c -o io-png.lo io-png.c
libtool: compile:  x86_64-pc-linux-gnu-gcc -std=gnu99 -DHAVE_CONFIG_H -I. -I.. -DG_LOG_DOMAIN=\"GdkPixbuf\" -DGDK_PIXBUF_COMPILATION -I.. -I.. -I../gdk-pixbuf -I../gdk-pixbuf -DGDK_PIXBUF_LOCALEDIR=\"/usr/share/locale\" -DGDK_PIXBUF_LIBDIR=\"/usr/lib64\" -DGDK_PIXBUF_BINARY_VERSION=\"2.10.0\" -DGDK_PIXBUF_PREFIX=\"/usr\" -pthread -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libpng15 -DGDK_PIXBUF_ENABLE_BACKEND -DPIXBUF_LIBDIR=\"/usr/lib64/gdk-pixbuf-2.0/2.10.0/loaders\" -DBUILT_MODULES_DIR=\"./.libs\" -DCPPFLAGS_TEST -DG_DISABLE_SINGLE_INCLUDES -DGDK_PIXBUF_DISABLE_DEPRECATED -O2 -march=k8 -pipe -g -Wimplicit-function-declaration -Wall -MT io-png.lo -MD -MP -MF .deps/io-png.Tpo -c io-png.c  -fPIC -DPIC -o .libs/io-png.o
io-png.c: In function 'png_simple_error_callback':
io-png.c:186:30: error: dereferencing pointer to incomplete type
io-png.c: In function 'gdk_pixbuf__png_image_load':
io-png.c:290:22: error: dereferencing pointer to incomplete type
io-png.c:344:32: warning: passing argument 5 of 'png_get_iCCP' from incompatible pointer type
/usr/include/libpng15/png.h:1875:22: note: expected 'png_bytepp' but argument is of type 'char **'
io-png.c: In function 'gdk_pixbuf__png_image_begin_load':
io-png.c:462:31: error: dereferencing pointer to incomplete type
io-png.c: In function 'gdk_pixbuf__png_image_load_increment':
io-png.c:534:31: error: dereferencing pointer to incomplete type
io-png.c: In function 'png_info_callback':
io-png.c:657:38: warning: format '%ld' expects type 'long int', but argument 5 has type 'png_uint_32'
io-png.c:657:38: warning: format '%ld' expects type 'long int', but argument 6 has type 'png_uint_32'
io-png.c:681:32: warning: passing argument 5 of 'png_get_iCCP' from incompatible pointer type
/usr/include/libpng15/png.h:1875:22: note: expected 'png_bytepp' but argument is of type 'char **'
io-png.c: In function 'png_error_callback':
io-png.c:772:30: error: dereferencing pointer to incomplete type
io-png.c: In function 'real_save_png':
io-png.c:981:28: error: dereferencing pointer to incomplete type
io-png.c:1009:31: warning: pointer targets in passing argument 5 of 'png_set_iCCP' differ in signedness
/usr/include/libpng15/png.h:1882:15: note: expected 'png_const_bytep' but argument is of type 'gchar *'
make[2]: *** [io-png.lo] Error 1
Comment 1 Samuli Suominen gentoo-dev 2011-02-21 17:53:25 UTC

*** This bug has been marked as a duplicate of bug 354557 ***