Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 355115 - dev-python/matplotlib-1.0.1: compilation fails with media-libs/libpng-1.5.x
Summary: dev-python/matplotlib-1.0.1: compilation fails with media-libs/libpng-1.5.x
Status: RESOLVED DUPLICATE of bug 354551
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Python Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-15 22:03 UTC by Lars Wendler (Polynomial-C)
Modified: 2011-02-15 22:07 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lars Wendler (Polynomial-C) gentoo-dev 2011-02-15 22:03:17 UTC
i686-pc-linux-gnu-g++ -pthread -march=barcelona -O2 -pipe -fno-strict-aliasing -fPIC -DPY_ARRAY_UNIQUE_SYMBOL=MPL_ARRAY_API -DPYCXX_ISO_CPP_LIB=1 -I/usr/include/libpng15 -I/usr/include -I. -I/usr/lib/python2.7/site-packages/numpy/core/include -I. -I/usr/include/python2.7 -c src/_png.cpp -o build-2.7/temp.linux-i686-2.7/src/_png.o
src/_png.cpp: In member function ‘Py::Object _png_module::read_png(const Py::Tuple&)’:
src/_png.cpp:353:33: error: invalid use of incomplete type ‘struct png_info’
/usr/include/libpng15/png.h:670:16: error: forward declaration of ‘struct png_info’
src/_png.cpp:354:34: error: invalid use of incomplete type ‘struct png_info’
/usr/include/libpng15/png.h:670:16: error: forward declaration of ‘struct png_info’
src/_png.cpp:356:29: error: invalid use of incomplete type ‘struct png_info’
/usr/include/libpng15/png.h:670:16: error: forward declaration of ‘struct png_info’
src/_png.cpp:364:18: error: invalid use of incomplete type ‘struct png_info’
/usr/include/libpng15/png.h:670:16: error: forward declaration of ‘struct png_info’
src/_png.cpp:377:17: error: invalid use of incomplete type ‘struct png_info’
/usr/include/libpng15/png.h:670:16: error: forward declaration of ‘struct png_info’
src/_png.cpp:383:17: error: invalid use of incomplete type ‘struct png_info’
/usr/include/libpng15/png.h:670:16: error: forward declaration of ‘struct png_info’
src/_png.cpp:411:17: error: invalid use of incomplete type ‘struct png_info’
/usr/include/libpng15/png.h:670:16: error: forward declaration of ‘struct png_info’
src/_png.cpp:415:22: error: invalid use of incomplete type ‘struct png_info’
/usr/include/libpng15/png.h:670:16: error: forward declaration of ‘struct png_info’
src/_png.cpp:424:30: error: invalid use of incomplete type ‘struct png_info’
/usr/include/libpng15/png.h:670:16: error: forward declaration of ‘struct png_info’
error: command 'i686-pc-linux-gnu-g++' failed with exit status 1
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2011-02-15 22:07:47 UTC

*** This bug has been marked as a duplicate of bug 354551 ***