Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 355015 - net-libs/webkit-gtk-1.2.7: compilation fails with media-libs/libpng-1.5.x
Summary: net-libs/webkit-gtk-1.2.7: compilation fails with media-libs/libpng-1.5.x
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL: https://bugs.webkit.org/show_bug.cgi?...
Whiteboard:
Keywords:
Depends on:
Blocks: libpng-1.5
  Show dependency tree
 
Reported: 2011-02-15 12:29 UTC by Lars Wendler (Polynomial-C)
Modified: 2011-04-04 20:48 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lars Wendler (Polynomial-C) gentoo-dev 2011-02-15 12:29:58 UTC
CXX    WebCore/platform/image-decoders/png/libwebkit_1_0_la-PNGImageDecoder.lo
WebCore/platform/image-decoders/png/PNGImageDecoder.cpp: In member function ‘void WebCore::PNGImageDecoder::headerAvailable()’:
WebCore/platform/image-decoders/png/PNGImageDecoder.cpp:219:28: error: invalid use of incomplete type ‘struct png_struct’
/usr/include/libpng15/png.h:803:16: error: forward declaration of ‘struct png_struct’
WebCore/platform/image-decoders/png/PNGImageDecoder.cpp:220:29: error: invalid use of incomplete type ‘struct png_struct’
/usr/include/libpng15/png.h:803:16: error: forward declaration of ‘struct png_struct’
WebCore/platform/image-decoders/png/PNGImageDecoder.cpp:223:12: error: invalid use of incomplete type ‘struct png_struct’
/usr/include/libpng15/png.h:803:16: error: forward declaration of ‘struct png_struct’
WebCore/platform/image-decoders/png/PNGImageDecoder.cpp:223:40: error: invalid use of incomplete type ‘struct png_struct’
/usr/include/libpng15/png.h:803:16: error: forward declaration of ‘struct png_struct’
WebCore/platform/image-decoders/png/PNGImageDecoder.cpp:280:68: error: invalid use of incomplete type ‘struct png_struct’
/usr/include/libpng15/png.h:803:16: error: forward declaration of ‘struct png_struct’
WebCore/platform/image-decoders/png/PNGImageDecoder.cpp:281:12: error: invalid use of incomplete type ‘struct png_struct’
/usr/include/libpng15/png.h:803:16: error: forward declaration of ‘struct png_struct’
WebCore/platform/image-decoders/png/PNGImageDecoder.cpp: In member function ‘void WebCore::PNGImageDecoder::rowAvailable(unsigned char*, unsigned int, int)’:
WebCore/platform/image-decoders/png/PNGImageDecoder.cpp:303:31: error: invalid use of incomplete type ‘struct png_struct’
/usr/include/libpng15/png.h:803:16: error: forward declaration of ‘struct png_struct’
make[1]: *** [WebCore/platform/image-decoders/png/libwebkit_1_0_la-PNGImageDecoder.lo] Error 1


This was already reported upstream (see URL).
Comment 1 Gilles Dartiguelongue gentoo-dev 2011-02-15 12:42:52 UTC
lowering priority since we have more urgent things to handle for now (gtk+:2 vs gtk+:3 and such).
Comment 2 tman 2011-02-17 13:09:44 UTC
i can confirm this bug too 


WebCore/platform/image-decoders/gif/GIFImageDecoder.cpp: In member function ‘bool WebCore::GIFImageDecoder::initFrameBuffer(unsigned int)’:
WebCore/platform/image-decoders/gif/GIFImageDecoder.cpp:346:54: warning: suggest braces around empty body in an ‘if’ statement
WebCore/platform/image-decoders/gif/GIFImageDecoder.cpp:360:56: warning: suggest braces around empty body in an ‘if’ statement
  CXX    WebCore/platform/image-decoders/gif/libwebkit_1_0_la-GIFImageReader.lo
  CXX    WebCore/platform/image-decoders/ico/libwebkit_1_0_la-ICOImageDecoder.lo
  CXX    WebCore/platform/image-decoders/jpeg/libwebkit_1_0_la-JPEGImageDecoder.lo
  CXX    WebCore/platform/image-decoders/png/libwebkit_1_0_la-PNGImageDecoder.lo
  CXX    WebCore/platform/network/soup/libwebkit_1_0_la-CookieJarSoup.lo
  CXX    WebCore/platform/network/soup/libwebkit_1_0_la-DNSSoup.lo
WebCore/platform/image-decoders/png/PNGImageDecoder.cpp: In member function ‘void WebCore::PNGImageDecoder::headerAvailable()’:
WebCore/platform/image-decoders/png/PNGImageDecoder.cpp:292:118: error: ‘png_process_data_pause’ was not declared in this scope
make[1]: *** [WebCore/platform/image-decoders/png/libwebkit_1_0_la-PNGImageDecoder.lo] Error 1
make[1]: *** Waiting for unfinished jobs....
make[1]: Leaving directory `/var/tmp/portage/net-libs/webkit-gtk-1.2.7/work/webkit-1.2.7'
make: *** [all] Error 2
emake failed
 * ERROR: net-libs/webkit-gtk-1.2.7 failed (compile phase):
 *   Compile failed
 * 
 * Call stack:
Comment 3 Lars Wendler (Polynomial-C) gentoo-dev 2011-02-21 08:58:32 UTC
The patch from URL does only work with libpng-1.5.x but not with earlier versions. So we should maybe wait for the official upstream fix.
Comment 4 Samuli Suominen gentoo-dev 2011-04-04 20:48:32 UTC
http://trac.webkit.org/changeset/82344 applied as -1.2.7-libpng15.patch to Portage