Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 354919 - sparc64 minimal install CD 20110207 hangs after switching console
Summary: sparc64 minimal install CD 20110207 hangs after switching console
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Release Media
Classification: Unclassified
Component: InstallCD (show other bugs)
Hardware: Sparc64 Linux
: High major (vote)
Assignee: Gentoo Release Team
URL: http://marc.info/?l=linux-sparc&m=129...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-14 21:44 UTC by seraph@xs4all.nl
Modified: 2011-09-26 15:04 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description seraph@xs4all.nl 2011-02-14 21:44:37 UTC
I'm trying to install Gentoo on my Blade 100 using a serial console. SILO starts normally and the kernel does boot, but the machine hangs directly after switching from the boot console, even sending a break over the serial line no longer works.

Reproducible: Always

Steps to Reproduce:
1. Set up a Blade 100 with a serial console
2. Attempt to boot from the install CD.

Actual Results:  
clocksource: mult[b40001] shift[16]
clockevent: mult[16c16bf] shift[32]
Console: colour dummy device 80x25
console [tty0] enabled
(system hangs here and needs powercycling)

Expected Results:  
Using the netboot image instead:
atyfb: 3D RAGE XL (Mach64 GR, PCI-33) [0x4752 rev 0x27]
atyfb: 8M SDRAM (1:1), 29.498928 MHz XTAL, 230 MHz PLL, 83 Mhz MCLK, 63 MHz XCLK
Console: switching to colour frame buffer device 144x56
atyfb: fb0: ATY Mach64 frame buffer device on PCI
f007d648: ttyS0 at MMIO 0x1fe020003f8 (irq = 9) is a 16550A
Console: ttyS0 (SU)
console [ttyS0] enabled
(system continues booting normally here)

This is a so called "headless" installation, no monitor or keyboard attached.
Comment 1 Michael Weber (RETIRED) gentoo-dev 2011-02-21 14:32:15 UTC
Have you tested the cd with normal screen output?
I just tried to boot the install-sparc64-minimal-20110214.iso and
it didn't complete the boot neither.

I've to take a screenshot but the output stops at an early stage and the dvd drive stops turning after a while. Have to check the network activity.
Comment 2 seraph@xs4all.nl 2011-02-21 15:06:20 UTC
Sorry, both of my Blades are installed in a rack and attaching a monitor and screen at this time is difficult. I can only use the serial console for the time being. 
Comment 3 Raúl Porcel (RETIRED) gentoo-dev 2011-02-21 18:35:08 UTC
Its probably http://marc.info/?l=linux-sparc&m=129426177717121&w=2
Comment 4 Alex Buell 2011-02-21 18:54:42 UTC
The patches for those went into 2.6.37, so we need to stabilse 2.6.37 and spin a minimal bootcd for testing. 
Comment 5 Alex Buell 2011-02-21 18:56:20 UTC
Sorry, my mistake, I meant 2.6.38. Damn numbers :p
Comment 6 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2011-05-13 18:58:20 UTC
@sparc:

time to mark 2.6.38 stable?
Comment 7 Raúl Porcel (RETIRED) gentoo-dev 2011-06-19 15:41:03 UTC
.38 stable, but since installcd fails to build...will keep this open until we have installcd working...
Comment 8 Jim Faulkner 2011-08-21 19:38:26 UTC
My Sun Blade 100 hangs even with 3.0.3:

https://bugzilla.kernel.org/show_bug.cgi?id=41522
Comment 9 Jim Faulkner 2011-09-02 01:16:51 UTC
resetting my nvram to defaults fixed the boot problem for me:

https://bugzilla.kernel.org/show_bug.cgi?id=41522

Also, I see that installcds are being built now, should this bug be closed?
Comment 10 Raúl Porcel (RETIRED) gentoo-dev 2011-09-24 16:18:36 UTC
yep
Comment 11 seraph@xs4all.nl 2011-09-26 15:04:08 UTC
Confirmed fixed with install CD image install-sparc64-minimal-20110919.iso.

Thanks to everyone who contributed to this.