Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 354817 - issue with 2.6.36 kernel caused gentoo forums downtime
Summary: issue with 2.6.36 kernel caused gentoo forums downtime
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Infrastructure
Classification: Unclassified
Component: Forums (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Forum Moderators
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-14 08:17 UTC by Francisco Blas Izquierdo Riera
Modified: 2012-08-24 18:48 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Francisco Blas Izquierdo Riera gentoo-dev 2011-02-14 08:17:31 UTC
The gentoo forums are down.

Although the machine is pingable attempts to access through the www service result in a timeout as there is no SYN/ACK after the TCP SYN.

Reproducible: Always




Other people are reporting to be affected by this issue. Proxying the requests through another computer on a different country and network didn't help.
Comment 1 Francisco Blas Izquierdo Riera gentoo-dev 2011-02-14 08:17:54 UTC
Adding infra as CC
Comment 2 Marcus Becker 2011-02-14 08:46:08 UTC
That's +1h now :)
I am addicted, you know.
Comment 3 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2011-02-14 09:23:33 UTC
Does anybody know of TCP changes, perhaps specific to IPVS between 2.6.32 and 2.6.36? That's what changed on the load balancer, and was causing loss of half of the TCP connection :-(

Reverted for now.
Comment 4 Francisco Blas Izquierdo Riera gentoo-dev 2011-02-14 09:39:25 UTC
(In reply to comment #3)
> Does anybody know of TCP changes, perhaps specific to IPVS between 2.6.32 and
> 2.6.36? That's what changed on the load balancer, and was causing loss of half
> of the TCP connection :-(
No but I know of some bugs on hardened-sources-2.6.36 prior to r9 (but none TCP secific)

There are no clues in the logs?
Comment 5 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2011-02-21 22:57:09 UTC
changing the summary so it doesn't look like a problem that needs immediate fix (when looking at the bug queue)
Comment 6 Francisco Blas Izquierdo Riera gentoo-dev 2011-02-22 00:00:20 UTC
You guys aren't using .26 are you?

Robin, the .36 was a really bad release from a hardened point of view, if you have time you'd want to ask blueness how stable he finds .37 and try jumping to it.

Also we aren't going to maintain it anymore as upstream isn't going to release new patches.
Comment 7 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2011-02-22 00:09:55 UTC
(In reply to comment #6)
> You guys aren't using .26 are you?

Right, thx for fixing the summary.
Comment 8 Christian Ruppert (idl0r) gentoo-dev 2012-08-24 18:48:17 UTC
We recently switched to 3.x so I'll close this for now.